Messaggio di errore: "Classe non registrata" quando si aggiornano i dati PowerPivot

Sintomi

Quando si tenta di aggiornare i dati in una cartella di lavoro PowerPivot creata in un computer diverso, vengono visualizzati gli errori seguenti:

Il nome> del provider <Provider non è registrato.
Errore di sistema seguente: Classe non registrata Impossibile effettuare una connessione all'origine dati con l'ID> origine dati DataSourceID<', Nome del nome> dell'origine <dati. Errore durante l'elaborazione del nome> della <tabella. Il nome> del provider <Provider non è registrato.
L'operazione è stata annullata.

Nota

L'errore può essere ripetuto per ogni connessione che ha esito negativo.

Causa

Questo problema si verifica in genere negli scenari seguenti:

  • Provare ad aggiornare i dati con i dati più recenti dal server back-end usando l'opzione Aggiorna tutto nel menu Aggiorna .
  • Si tenta di importare dati usando una delle connessioni nell'opzione Connessione esistente nella scheda Progettazione .

Si tratta di un comportamento legato alla progettazione del prodotto. Si verifica quando il provider definito per la connessione dati per i dati PowerPivot non esiste nel sistema.

Risoluzione

Per risolvere il problema, usare una delle procedure seguenti.

Procedura 1: Configurare la connessione non riuscita per l'uso di un provider diverso e compatibile esistente nel sistema

A tal fine, attenersi alla seguente procedura:

  1. Nella finestra di Power Pivot selezionare la scheda Progettazione nel menu della barra multifunzione.
  2. Selezionare Connections esistente.
  3. Nell'elenco delle connessioni disponibili selezionare la connessione che ha esito negativo e quindi selezionare Modifica.
  4. Nella finestra Modifica connessione selezionare Avanzate.
  5. Nell'area Imposta proprietà avanzate modificare il valore provider in un provider diverso e compatibile e quindi aggiornare i dati.

Ad esempio, se la connessione è configurata per l'uso di SQLNCLI10 (provider SQL Native Client 10) e se il client SQL Native non è installato nel sistema, modificare il provider in SQLOLEDB e quindi aggiornare i dati nella cartella di lavoro.

Procedura 2: Installare il provider

  1. Identificare il provider usato per la connessione non riuscita. A tale scopo, usare le informazioni nel messaggio di errore o i passaggi documentati nella procedura 1 per identificare il provider.
  2. Installare il provider nel sistema usando il supporto di installazione o scaricando il provider da Internet.

Ulteriori informazioni

È anche possibile che venga visualizzato un messaggio di errore simile quando si usa un sistema a 32 bit per lavorare con una cartella di lavoro sviluppata in un sistema a 64 bit. Inoltre, non è disponibile alcun provider a 32 bit per una o più connessioni definite nella cartella di lavoro oppure il provider a 32 bit non è installato nel sistema o viceversa.

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