Erreur (la connexion à l’hôte distant spécifié a été refusée) lorsque vous essayez de démarrer Exchange Management Shell ou console de gestion Exchange

Numéro de la base de connaissances d’origine : 2027064

Symptômes

Lorsque vous essayez de démarrer Exchange Management Shell (EMS) ou console de gestion Exchange (EMC) sur un ordinateur exécutant Microsoft Exchange Server 2010, Microsoft Exchange Server 2013 ou Microsoft Exchange Server 2016, vous recevez le message d’erreur suivant :

La connexion à l’hôte distant spécifié a été refusée. Vérifiez que le service WS-Management est en cours d’exécution sur l’hôte distant et configuré pour écouter les requêtes sur le port et l’URL HTTP appropriés. Pour plus d’informations, consultez la rubrique d’aide about_Remote_Troubleshooting.

Cause

Ce problème se produit car une ou plusieurs des conditions suivantes sont remplies :

  • Le pool d’applications MSExchangePowerShellAppPool rencontre des problèmes ou n’est pas en cours d’exécution.
  • L’utilisateur n’a pas de status Remote PowerShell Enabled.
  • La gestion à distance Windows (WinRM) est configurée de manière incorrecte sur le serveur.

Résolution

Pour résoudre ce problème, appliquez l’une des méthodes suivantes :

  • Vérifiez que le pool d’applications MSExchangePowerShellAppPool est en cours d’exécution. Si le pool est en cours d’exécution, essayez de le recycler. Ensuite, case activée d’erreurs ou d’avertissements dans les journaux des événements.

  • Assurez-vous que l’utilisateur qui tente de se connecter dispose de Remote PowerShell Enabled status. Pour déterminer si un utilisateur est activé pour Remote PowerShell, démarrez Exchange Management Shell à l’aide d’un compte activé, puis exécutez la requête suivante :

    (Get-User <username>).RemotePowershellEnabled
    

    Cette requête retourne une réponse true oufalse. Si la réponse est False, l’utilisateur n’est pas activé pour PowerShell à distance. Pour activer l’utilisateur, exécutez la commande suivante :

    Set-User \<username> -RemotePowerShellEnabled $True
    
  • Assurez-vous que WinRM est correctement configuré sur le serveur. Pour cela, procédez comme suit :

    1. Exécutez WinRM QuickConfig. Pour ce faire, cliquez sur Démarrer, tapez WinRM QuickConfig dans la zone Démarrer la recherche , puis appuyez sur Entrée.

    2. Assurez-vous que les deux tests réussissent et qu’aucune action n’est requise. Si des actions sont nécessaires, cliquez sur Oui dans la fenêtre d’invite pour autoriser les modifications de configuration WinRM.

    3. Cliquez sur Démarrer, tapez cmd dans la zone Démarrer la recherche , puis appuyez sur Entrée. Dans la fenêtre Invite de commandes, tapez WinRM énumérer winrm/config/listener à l’invite de commandes, puis appuyez sur Entrée.

    4. Assurez-vous qu’il existe un écouteur pour le protocole HTTP sur le port 5985 et que l’écouteur écoute toutes les adresses.