Errore (la connessione all'host remoto specificato è stata rifiutata) quando si tenta di avviare Exchange Management Shell o Exchange Management Console

Numero KB originale: 2027064

Sintomi

Quando si tenta di avviare Exchange Management Shell (EMS) o Exchange Management Console (EMC) in un computer che esegue Microsoft Exchange Server 2010, Microsoft Exchange Server 2013 o Microsoft Exchange Server 2016, viene visualizzato il messaggio di errore seguente:

La connessione all'host remoto specificato è stata rifiutata. Verificare che il servizio WS-Management sia in esecuzione nell'host remoto e configurato per l'ascolto delle richieste sulla porta e sull'URL HTTP corretti. Per altre informazioni, vedere l'argomento della Guida about_Remote_Troubleshooting.

Causa

Questo problema si verifica perché si verificano una o più delle condizioni seguenti:

  • Il pool di applicazioni MSExchangePowerShellAppPool presenta problemi o non è in esecuzione.
  • L'utente non ha lo stato Remote PowerShell Enabled .
  • Gestione remota Windows (WinRM) è configurata in modo non corretto nel server.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi riportati di seguito:

  • Assicurarsi che il pool di applicazioni MSExchangePowerShellAppPool sia in esecuzione. Se il pool è in esecuzione, provare a riciclarlo. Verificare quindi la presenza di errori o avvisi nei log eventi.

  • Assicurarsi che lo stato dell'utente che sta provando a connettersi sia Abilitato per PowerShell remoto . Per determinare se un utente è abilitato per PowerShell remoto, avviare Exchange Management Shell usando un account abilitato e quindi eseguire la query seguente:

    (Get-User <username>).RemotePowershellEnabled
    

    Questa query restituisce una risposta true o false. Se la risposta è False, l'utente non è abilitato per PowerShell remoto. Per abilitare l'utente, eseguire il comando seguente:

    Set-User \<username> -RemotePowerShellEnabled $True
    
  • Assicurarsi che WinRM sia configurato correttamente nel server. A tal fine, attenersi alla seguente procedura:

    1. Eseguire WinRM QuickConfig. A tale scopo, fare clic su Start, digitare WinRM QuickConfig nella casella Start Search (Avvia ricerca ) e quindi premere INVIO.

    2. Assicurarsi che entrambi i test superino e che non siano necessarie azioni. Se sono necessarie azioni, fare clic su nella finestra del prompt per consentire l'esecuzione delle modifiche alla configurazione di WinRM.

    3. Fare clic su Start, digitare cmd nella casella Avvia ricerca e quindi premere INVIO. Nella finestra del prompt dei comandi digitare WinRM enumerate winrm/config/listener al prompt dei comandi e quindi premere INVIO.

    4. Assicurarsi che esista un listener per il protocollo HTTP sulla porta 5985 e che il listener sia in ascolto su tutti gli indirizzi.