Erro (A ligação ao anfitrião remoto especificado foi recusada) quando tenta iniciar a Shell de Gestão do Exchange ou Consola de Gestão do Exchange

Número original da BDC: 2027064

Sintomas

Quando tenta iniciar o Exchange Management Shell (EMS) ou o Consola de Gestão do Exchange (EMC) num computador com Microsoft Exchange Server 2010, Microsoft Exchange Server 2013 ou Microsoft Exchange Server Em 2016, recebe a seguinte mensagem de erro:

A ligação ao anfitrião remoto especificado foi recusada. Verifique se o serviço WS-Management está em execução no anfitrião remoto e configurado para escutar pedidos na porta correta e no URL HTTP. Para obter mais informações, consulte o tópico about_Remote_Troubleshooting Ajuda.

Causa

Este problema ocorre porque uma ou mais das seguintes condições são verdadeiras:

  • O conjunto aplicacional MSExchangePowerShellAppPool está a ter problemas ou não está em execução.
  • O utilizador não tem o estado Do PowerShell Remoto Ativado .
  • A Gestão Remota do Windows (WinRM) está configurada incorretamente no servidor.

Resolução

Para resolver este problema, utilize um dos seguintes métodos:

  • Confirme que o conjunto aplicacional MSExchangePowerShellAppPool está em execução. Se o conjunto estiver em execução, tente reciclá-lo. Em seguida, verifique se existem erros ou avisos nos registos de eventos.

  • Certifique-se de que o utilizador que está a tentar ligar tem o estado Do PowerShell Remoto Ativado . Para determinar se um utilizador está ativado para o PowerShell Remoto, inicie a Shell de Gestão do Exchange com uma conta que tenha sido ativada e, em seguida, execute a seguinte consulta:

    (Get-User <username>).RemotePowershellEnabled
    

    Esta consulta devolve uma resposta de Verdadeiro ou Falso. Se a resposta for Falso, o utilizador não está ativado para o PowerShell Remoto. Para ativar o utilizador, execute o seguinte comando:

    Set-User \<username> -RemotePowerShellEnabled $True
    
  • Confirme que o WinRM está configurado corretamente no servidor. Para tal, siga estes passos:

    1. Execute WinRM QuickConfig. Para tal, clique em Iniciar, escreva WinRM QuickConfig na caixa Iniciar Pesquisa e, em seguida, prima ENTER.

    2. Certifique-se de que ambos os testes passam e que não são necessárias ações. Se forem necessárias ações, clique em Sim na janela de pedido para permitir que as alterações de configuração do WinRM sejam efetuadas.

    3. Clique em Iniciar, escreva cmd na caixa Iniciar Pesquisa e, em seguida, prima ENTER. Na janela Linha de Comandos, escreva WinRM enumerar winrm/config/listener na linha de comandos e, em seguida, prima ENTER.

    4. Certifique-se de que existe um serviço de escuta para o protocolo HTTP na porta 5985 e de que o serviço de escuta está a escutar em todos os endereços.