Der neue Drucker status ist offline, nachdem Sie eine Druckwarteschlange gelöscht und dann einen Windows-basierten Computer neu gestartet haben.

Dieser Artikel bietet eine Lösung für ein Problem, bei dem der neue Drucker status offline ist, nachdem Sie eine Druckwarteschlange gelöscht und dann einen Windows-basierten Computer neu gestartet haben.

Gilt für: Windows Server 2012 R2
Ursprüngliche KB-Nummer: 2027593

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie löschen eine Druckwarteschlange, während sie sich in einem Offline-status befindet.
  • Sie fügen eine neue Druckwarteschlange hinzu, die den gleichen Namen wie die alte Druckwarteschlange hat.
  • Sie starten den Computer neu.

In diesem Szenario wird die status der neuen Druckwarteschlange als Offline angezeigt.

Ursache

Dieses Problem tritt auf, wenn auf dem Computer der folgende Registrierungswert konfiguriert ist, wenn Sie den Drucker auf den Offline-status festlegen:

Schlüssel: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name> Wert: PrinterOnLine
Data: 0

Dieser Wert wird jedoch nicht von der Localspl.dll Datei gelöscht, wenn die Druckwarteschlange gelöscht wird. Wenn Sie also eine Druckwarteschlange hinzufügen, die den gleichen Namen wie die alte Druckwarteschlange hat, erbt die neue Druckerwarteschlange den Offline-status der gelöschten Druckwarteschlange.

Lösung

Um dieses Problem zu beheben, klicken Sie im Tool Drucker und Faxe mit der rechten Maustaste auf die neue Druckwarteschlange, und deaktivieren Sie dann die Einstellung Drucker offline verwenden . Dadurch wird der Registrierungsschlüssel auf den richtigen Wert zurückgesetzt. Stattdessen können Sie den Registrierungsschlüssel löschen, der im Abschnitt Ursache erwähnt wird, nachdem Sie eine Druckwarteschlange gelöscht haben, aber bevor Sie eine neue Druckwarteschlange mit demselben Namen hinzufügen.

Hat dies das Problem behoben?

  • Testen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie sich an den Support wenden.
  • Wir würden uns über Ihr Feedback freuen. Um Feedback zu geben oder Probleme mit dieser Lösung zu melden, hinterlassen Sie einen Kommentar, indem Sie uns eine E-Mail-Nachricht senden.

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