Il nuovo stato della stampante è Offline dopo l'eliminazione di una coda di stampa e quindi il riavvio di un computer basato su Windows

Questo articolo fornisce una soluzione a un problema per cui lo stato della nuova stampante è Offline dopo l'eliminazione di una coda di stampa e quindi il riavvio di un computer basato su Windows.

Si applica a: Windows Server 2012 R2
Numero KB originale: 2027593

Sintomi

Considerare lo scenario descritto di seguito:

  • È possibile eliminare una coda di stampa mentre è in stato Offline.
  • Si aggiunge una nuova coda di stampa con lo stesso nome della coda di stampa precedente.
  • Riavviare il computer.

In questo scenario, lo stato della nuova coda di stampa viene visualizzato come Offline.

Causa

Questo problema si verifica se nel computer è configurato il valore del Registro di sistema seguente quando si imposta la stampante sullo stato Offline :

Chiave: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name> Valore: PrinterOnLine
Dati: 0

Tuttavia, questo valore non viene eliminato dal file Localspl.dll quando la coda di stampa viene eliminata. Pertanto, quando si aggiunge una coda di stampa con lo stesso nome della coda di stampa precedente, la nuova coda della stampante eredita lo stato Offline della coda di stampa eliminata.

Risoluzione

Per risolvere questo problema, fare clic con il pulsante destro del mouse sulla nuova coda di stampa nello strumento Stampanti e fax e quindi deselezionare l'impostazione Usa stampante offline . In questo modo la chiave del Registro di sistema viene reimpostata sul valore corretto. È invece possibile eliminare la chiave del Registro di sistema indicata nella sezione Causa dopo aver eliminato una coda di stampa ma prima di aggiungere una nuova coda di stampa con lo stesso nome.

È stato risolto il problema

  • Verificare se il problema è stato risolto. Se il problema è stato risolto, questa sezione è terminata. Se il problema non è stato risolto, è possibile contattare il supporto tecnico.
  • Apprezziamo il tuo feedback. Per fornire commenti e suggerimenti o segnalare eventuali problemi relativi a questa soluzione, lasciare un commento inviando un messaggio di posta elettronica .

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando il TSS per i problemi relativi all'esperienza utente.