Karta śledzenia spotkań programu Outlook nie jest aktualizowana

Symptomy

Rozpatrzmy następujący scenariusz:

  1. Program Microsoft Outlook służy do planowania spotkania i zapraszania uczestników.
  2. Uczestnicy akceptują lub odrzucają spotkanie i wysyłają odpowiedzi na spotkanie.
  3. Odpowiedzi na spotkanie są widoczne w folderze Skrzynka odbiorcza w programie Outlook.

W tym scenariuszu po otwarciu zaplanowanego spotkania z folderu Kalendarz zauważysz, że na stronie Śledzenie nie są wyświetlane zaktualizowane wartości w kolumnie Odpowiedź .

Ponadto jeśli włączono opcję Śledzenie aktualizacji, a następnie usunięto odpowiedzi w programie Outlook, odpowiedzi na spotkanie nie zostaną usunięte zgodnie z oczekiwaniami.

Przyczyna

Odpowiedzi na spotkanie są przetwarzane przez innego klienta, urządzenie lub aplikację innej firmy. Mogą one obejmować, ale nie są ograniczone do następujących.

  • Dodatki programu Outlook
  • Program archiwizacji poczty
  • Urządzenia korzystające z obiektów danych współpracy (CDO) do synchronizacji ze skrzynką pocztową lub kalendarzem programu Microsoft Exchange
  • Urządzenia korzystające z usługi Microsoft Exchange ActiveSync (EAS) do synchronizacji ze skrzynką pocztową lub kalendarzem

Uwaga

Jeśli uczestnicy zaakceptują spotkanie i zdecydują się nie wysyłać odpowiedzi, oczekuje się, że karta śledzenia nie zostanie zaktualizowana o ich odpowiedź.

Rozwiązanie

Aby ustalić, czy dodatki programu Outlook spowodowały przetworzenie odpowiedzi na spotkanie, tymczasowo wyłącz dodatki programu Outlook, a następnie spróbuj odtworzyć problem. Jeśli problem nie występuje, gdy dodatki są wyłączone, może być konieczne dodatkowe badanie dodatków.

Aby uzyskać więcej informacji na temat wyłączania dodatków w programie Outlook, zobacz Wyświetlanie dodatków i instalowanie ich oraz zarządzanie nimi w programach pakietu Office.

Aby określić, czy urządzenie przenośne spowodowało przetworzenie odpowiedzi na spotkanie, określ, czy masz urządzenia przenośne, które są regularnie używane do synchronizacji z kalendarzem programu Exchange. Upewnij się, że uaktualniono do najnowszego systemu operacyjnego urządzenia przenośnego, aby uniknąć znanych problemów, które zostały już rozwiązane. Tymczasowo wyłącz dostęp do urządzenia przenośnego, a następnie spróbuj odtworzyć zachowanie. Jeśli zachowanie nie wystąpi, może być konieczne dodatkowe badanie urządzenia przenośnego.

Przyczynę zachowania można również zbadać za pomocą narzędzia MFCMapi w celu przejrzenia elementu kalendarza. MFCMapi to klient interfejsu API obsługi komunikatów (MAPI), który udostępnia dodatkowe informacje o folderach i elementach w skrzynce pocztowej programu Exchange. Pobierz aplikację MFCMAPI z serwisu GitHub (przewiń w dół, a następnie kliknij pozycję Najnowsza wersja).

Aby ustalić, czy odpowiedź na spotkanie została przetworzona przez coś innego niż program Outlook, wykonaj następujące kroki:

  1. Na komputerze klienckim programu Outlook utwórz spotkanie, a następnie wyślij zaproszenie na spotkanie do uczestnika.

  2. Zakończ pracę programu Outlook.

  3. Poproś uczestnika o zaakceptowanie zaproszenia na spotkanie, a następnie poproś go o wysłanie odpowiedzi do organizatora.

  4. Na komputerze klienckim pozostaw program Outlook zamknięty.

  5. Użyj narzędzia MFCMapi, aby zbadać odpowiedź na spotkanie wysłaną przez uczestnika. Aby to zrobić, wykonaj następujące kroki.

    1. Uruchom MFCMAPI.exe.

    2. Kliknij menu Sesja , a następnie kliknij pozycję Zaloguj.

    3. Jeśli zostanie wyświetlony monit o utworzenie profilu, wybierz nazwę profilu, a następnie kliknij przycisk OK.

    4. W górnym okienku znajdź wiersz odpowiadający skrzynce pocztowej i kliknij ją dwukrotnie.

    5. W okienku nawigacji (okienku po lewej stronie) rozwiń węzeł Kontener główny, a następnie rozwiń węzeł IPM_SUBTREE.

      Uwaga

      Jeśli profil wybrany w kroku 5C łączy się ze skrzynką pocztową programu Exchange w trybie online, rozwiń pozycję Top of Information Store zamiast IPM_SUBTREE.

    6. Kliknij dwukrotnie folder Skrzynka odbiorcza, aby otworzyć nowe okno z jego zawartością.

    7. Znajdź element odpowiedzi na spotkanie wysłany do Ciebie przez uczestnika, a następnie wybierz go. Nie klikaj dwukrotnie, aby go otworzyć.

    8. W dolnym okienku znajdź właściwość PR_PROCESSED w kolumnie Nazwy właściwości .

      • Jeśli odpowiedź na spotkanie ma właściwość PR_PROCESSED i jeśli właściwość ma wartość True, odpowiedź na spotkanie została przetworzona przez innego klienta, urządzenie lub aplikację innej firmy. W związku z tym po uruchomieniu programu Outlook uważa, że ten element został już przetworzony i nie aktualizuje śledzenia elementu kalendarza.
      • Jeśli odpowiedź na spotkanie nie ma właściwości PR_PROCESSED, odpowiedź na spotkanie nie została przetworzona.
  6. Użyj narzędzia MFCMapi, aby zlokalizować odpowiedź na spotkanie uczestnika. Aby to zrobić, wykonaj następujące kroki.

    1. Otwórz folder Kalendarz, a następnie znajdź element.
    2. W kolumnie Nazwa właściwości znajdź właściwość PR_RECIPIENT_TRACKSTATUS, a następnie przyjrzyj się kolumnie Smart View . Możliwe wartości są następujące:
      • Flagi: respNone
      • Flagi: respAccepted
      • Flagi: respDeclined
      • Flagi: respTentative