Katalogsynkroniseringsverktyget för Microsoft Online Services stoppar synkronisering av objekt och utlöser ett katalogsynkroniseringsfel

Problem

Du märker att synkroniseringen av objekt från din lokala Active Directory Domain Services till Microsofts molntjänster har stoppats. (Dessa tjänster kan omfatta Microsoft 365, Microsoft Azure och Microsoft Intune.)

Dessutom loggas händelse-ID 0 eller händelse-ID 109 i Loggboken:

Event ID: 0 or Event ID: 109

Source: Directory Synchronization

Description: This version of the Microsoft Online Services Directory Sync tool is no longer supported. Uninstall this version, and then download and install the latest version from your Admin Portal page.

Orsak

Det här problemet uppstår om du använder en inaktuell version av katalogsynkroniseringsverktyget för Microsoft Online Services. Vi accepterar inte längre anslutningar till Microsoft Entra ID om du använder en föråldrad version av katalogsynkroniseringsverktyget för Microsoft Online Services.

Lösning

Uppgradera till Microsoft Entra Connect. Det här verktyget måste vara installerat på en 64-bitarsversion av Windows Server. Mer information om hur du uppgraderar från DirSync finns i Microsoft Entra Connect: Upgrade from DirSync (Uppgradera från DirSync).

Mer information

Mer information om hybrididentitet med Microsoft Entra ID finns i Förbereda för katalogsynkronisering.

Mer information om system- och programvarukraven för Microsoft Entra Connect finns i Förutsättningar för Microsoft Entra Connect.

Mer information om de attribut som synkroniseras av Microsoft Entra Connect finns i Microsoft Entra Connect Sync: Attribut synkroniserade med Microsoft Entra ID.

Behöver du fortfarande hjälp? Gå till Microsoft Community eller Microsoft Entra Forum.