Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si tenta di riprodurre un file con Windows Media Player, è possibile che venga visualizzato uno o più dei seguenti messaggi di errore:

Formato di file non valido. (Errore=8004022F)

Oppure

Impossibile riprodurre il file. Formato non supportato. (Errore=80040265)

Oppure

Impossibile riprodurre il flusso video. Non è stato trovato alcun decompressore adatto. (Errore=80040255)

Oppure

Impossibile trovare una combinazione di filtri per il rendering del flusso. (Errore=80040218)

Oppure

Impossibile caricare il filtro di origine per il file. (Errore=80040241)

Oppure

Impossibile aprire. Verificare che il percorso e il nome del file siano corretti, quindi riprovare (Errore=8007000D).

Cause

Questo problema può verificarsi in presenza di una delle seguenti condizioni:

  • Windows Media Player non supporta il formato di file o il codec del file multimediale che si tenta di riprodurre.

  • Alcuni dei file di Windows Media Player mancano o sono danneggiati.

  • Il file multimediale è danneggiato.

  • Il file multimediale utilizza un codec non installato.

  • Il sistema operativo non dispone di funzionalità audio. Ad esempio:

    • Nel computer non è installata alcuna periferica audio.

    • Il driver corretto per la periferica audio non è installato oppure è disabilitato.

    • Si utilizzano Windows NT e Windows 2000 Terminal, privi di funzionalità audio.

    • Windows XP Terminal è configurato per l'esclusione della riproduzione dell'audio.

Risoluzione

Per risolvere il problema, utilizzare i metodi seguenti nell'ordine indicato. Dopo l'esecuzione di ogni metodo, verificare se il problema è stato risolto.

Importante Windows Media Player non supporta la riproduzione di tutti i tipi di file multimediali attualmente disponibili, benché supporti quelli più comuni. Verificare pertanto che il tipo di file multimediale sia supportato. In caso contrario, non utilizzare i metodi successivi al metodo 1. Se Windows Media Player non supporta il formato di file utilizzato, contattare il distributore del file per verificare l'eventuale disponibilità di un visualizzatore specifico.
Per ulteriori informazioni su uno specifico messaggio di errore, fare clic sui numeri degli articoli della Knowledge Base riportati di seguito:

156286 Messaggio di errore: Impossibile riprodurre il flusso video.

195880 Messaggio di errore: Impossibile trovare una combinazione di filtri per il rendering...

Metodo 1: Verificare che Windows Media Player supporti il formato di file utilizzato

Windows Media Player supporta i formati di file inclusi nel seguente elenco:

  • Estensioni dei nomi di file Windows Media: asf, asx, avi, wav, wax, wma, wm, wmv

    Nota I file wmv sono supportati solo da Windows Media Player versione 6.4 e successive.

  • Estensioni dei nomi di file MPEG (Moving Pictures Experts Group): m3u, mp2v, mpg, mpeg, m1v, mp2, mp3, mpa, mpe, mpv2

  • Estensioni dei nomi di file MIDI (Musical Instrument Digital Interface): mid, midi, rmi

  • Estensioni dei nomi di file Apple QuickTime, Macintosh AIFF: qt, aif, aifc, aiff, mov

  • Estensioni dei nomi di file Unix: au, snd

Nota Windows Media Player supporta i file creati con Apple QuickTime versioni 1 e 2 e non supporta più i formati di file ra, rm e ram.

Metodo 2: Determinare se il file che si desidera riprodurre è danneggiato

Provare a riprodurre con Windows Media Player un file diverso con la stessa estensione del file utilizzato quando è stato visualizzato il messaggio di errore. Se quest'ultimo file viene riprodotto correttamente, il file che si tentava di riprodurre in origine è probabilmente danneggiato. Se viene visualizzato un messaggio di errore ogni volta che si prova a riprodurre file di questo tipo, passare al metodo successivo.

Per ulteriori informazioni sui tipi di file supportati in Windows Media Player 7, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

316992 Formati di file multimediali di Windows Media Player

Metodo 3: Reinstallare Windows Media Player

Disinstallare Windows Media Player, riavviare il computer e reinstallare il programma.

Nota È necessario utilizzare la versione più recente di Windows Media Player. Per scaricare la versione più recente di Windows Media Player, visitare il seguente sito Web Microsoft:

http://www.microsoft.com/windows/windowsmedia/download

Metodo 4: Reinstallare la versione più recente di Microsoft DirectX

Per ulteriori informazioni sulla risoluzione dei problemi e l'installazione di DirectX, fare clic sui numeri degli articoli della Knowledge Base riportati di seguito:

179113 Istruzioni per scaricare e installare DirectX

157730 Determinazione della versione di DirectX utilizzando lo strumento di diagnostica DirectX

Metodo 5: Verificare che sia in uso il codec corretto per il file multimediale

Per ulteriori informazioni sulla verifica, l'installazione e la risoluzione dei problemi relativi ai codec audio, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:

141801 Risoluzione dei problemi relativi ai codec audio e video in Windows 95

191533 Impossibile riprodurre un file .avi con Media Player utilizzando il codec Indeo 4.x

221831 Messaggio di errore: Impossibile scaricare il programma di decompressione appropriato

Informazioni

Per ulteriori informazioni su Windows Media Player e sulla risoluzione dei relativi problemi, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):

http://windows.microsoft.com/it-it/windows7/Windows-Media-Player-frequently-asked-questionsI prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×