Se produce un error en la llamada al agente del grupo de respuesta de Microsoft Lync Server

Síntomas

Un usuario de Lync realiza una llamada a un agente del grupo de respuesta de Lync Server que aparece en la lista de contactos de Lync. Sin embargo, el agente del grupo de respuesta de Lync Server no recibe la llamada según lo previsto.

Causa

Este problema se produce si se cumplen una o varias de las condiciones siguientes:

  • La cuenta de usuario habilitada para Lync Server para el agente del grupo de respuesta de Lync Server se asignó a un dominio SIP diferente que está registrado con el grupo o servidor de Lync Server.
  • La actualización del URI SIP del agente del grupo de respuesta de Lync Server no se produjo en los grupos de respuesta de Lync Server de los que es miembro el agente del grupo de respuesta de Lync Server.

Solución

Para resolver este problema, siga estos pasos:

  1. Use la Panel de control de Lync Server para acceder a la opción de menú Grupos de respuesta.
  2. En el menú Grupo de respuesta , haga clic en Grupo.
  3. Seleccione el grupo de respuesta de Lync Server específico al que pertenece el agente del grupo de respuesta actualizado.

    Nota:

    El agente del grupo de respuesta de Lync Server puede pertenecer a más de un grupo de respuesta de Lync Server.

  4. En la barra de menús, haga clic en Editar detalles.
  5. Desplácese hacia abajo para buscar el URI SIP original del agente del grupo de respuesta de Lync Server en la lista Agente .
  6. Seleccione el agente de grupo de respuesta de Lync Server especificado y, a continuación, haga clic en la opción Quitar de la barra de menús.
  7. En la barra de menús superior, haga clic en la opción Confirmar .
  8. Repita los pasos 3 y 4.
  9. Desplácese hacia abajo para buscar la lista agente del grupo de respuesta de Lync Server.
  10. Haga clic en Seleccionar en la barra de menús.
  11. En el cuadro de diálogo Seleccionar agentes , use la característica Buscar para buscar el usuario habilitado para Lync Server que se volverá a agregar al grupo de respuesta de Lync Server seleccionado.
  12. Seleccione el agente que tiene el URI SIP correcto y, a continuación, haga clic en Aceptar.
  13. En la barra de menús superior, haga clic en Confirmar.
  14. En la parte superior del panel Grupo de respuesta, haga clic en Actualizar.
  15. Cierre la sesión y vuelva a iniciar sesión en los clientes de Lync que experimentan el problema.
  16. Realice una llamada a un agente del grupo de respuesta de Lync Server desde la lista de contactos de cliente de Lync.

Más información

De forma predeterminada, la aplicación genera el siguiente error:

Windows Powershell returned the following errors: Cannot insert duplicate key row in object dbo.Agents with unique index IX_Agents_UserSid. 
The statement has been terminated.

Este error se produce porque la información del agente del grupo de respuesta de Lync Server eliminada se ha marcado para su eliminación en el dbo. Tabla de agentes de la base de datos rgsconfig. Hay cierta latencia asociada al proceso de eliminación del registro de agente del grupo de respuesta de Lync Server quitado en el dbo. Tabla de agentes de la base de datos rgsconfig. Solo después de que la fila que contiene la información del agente del grupo de respuesta de Lync Server no deseada se quite por completo del dbo. Tabla de agentes se puede completar el proceso de confirmación del grupo de agentes del grupo de respuesta de Lync Server.

Por lo tanto, el comportamiento que se describe en la sección "Síntomas" es por diseño.

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