Microsoft Lync Server 応答グループ エージェントの呼び出しが失敗する

現象

Lync ユーザーは、Lync 連絡先リストに表示されている Lync Server 応答グループ エージェントを呼び出します。 ただし、Lync Server 応答グループ エージェントは、期待どおりに通話を受信しません。

原因

この問題は、次の条件の 1 つ以上が当てはまる場合に発生します。

  • Lync Server 応答グループ エージェントの Lync Server 対応ユーザー アカウントが、Lync Server プールまたはサーバーに登録されている別の SIP ドメインに割り当てられました。
  • Lync Server 応答グループ エージェント SIP URI の更新は、Lync Server 応答グループ エージェントがメンバーである Lync Server 応答グループでは発生しませんでした。

解決方法

この問題を解決するには、次の手順を実行します。

  1. Lync Server コントロール パネルを使用して、[応答グループ] メニュー オプションにアクセスします。
  2. [ 応答グループ ] メニューの [ グループ] をクリックします。
  3. 更新された応答グループ エージェントがメンバーである特定の Lync Server 応答グループを選択します。

    注:

    Lync Server 応答グループ エージェントは、複数の Lync Server 応答グループに属できます。

  4. メニュー バーの [詳細の 編集] をクリックします。
  5. 下にスクロールして、エージェント の一覧 で Lync Server 応答グループ エージェントの元の SIP URI を見つけます。
  6. 指定した Lync Server 応答グループ エージェントを選択し、メニュー バーの [削除 ] オプションをクリックします。
  7. 一番上のメニュー バーで、[ コミット ] オプションをクリックします。
  8. 手順 3 と 4 を繰り返します。
  9. 下にスクロールして、Lync Server 応答グループ エージェント の一覧を見つけます。
  10. メニュー バーの [選択 ] をクリックします。
  11. [ エージェントの選択 ] ダイアログ ボックスで、[検索] 機能を使用して、選択した Lync Server 応答グループに再追加する Lync Server 対応ユーザーを見つけます。
  12. 正しい SIP URI を持つエージェントを選択し、[OK] をクリック します
  13. 一番上のメニュー バーで、[ コミット] をクリックします。
  14. [応答グループ] ウィンドウの上部にある [ 更新] をクリックします。
  15. サインアウトしてから、問題が発生している Lync クライアントに再度サインインします。
  16. Lync クライアント連絡先リストから Lync Server 応答グループ エージェントを呼び出します。

詳細情報

既定では、アプリケーションによって次のエラーが生成されます。

Windows Powershell returned the following errors: Cannot insert duplicate key row in object dbo.Agents with unique index IX_Agents_UserSid. 
The statement has been terminated.

このエラーは、削除された Lync Server 応答グループ エージェント情報が dbo で削除対象としてマークされているために発生します。rgsconfig データベースのエージェント テーブル。 dbo で削除された Lync Server 応答グループ エージェント レコードの削除プロセスに関連する待機時間がいくつかあります。rgsconfig データベースのエージェント テーブル。 不要な Lync Server 応答グループ エージェント情報を含む行が dbo から完全に削除された後のみです。エージェント テーブル Lync Server 応答グループ エージェント グループのコミット プロセスを完了できます。

そのため、「現象」セクションで説明されている動作は設計上の動作です。

さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。