서비스가 갑자기 중지되면 오류 1058이 표시됩니다.

이 문서에서는 서비스가 갑자기 중지되면 "오류 1058"이 발생하는 문제에 대한 솔루션을 제공합니다.

적용 대상: Windows 10 - 모든 버전, Windows 7, Windows Vista, Windows XP
원본 KB 번호: 241584

증상

서비스가 갑자기 중지되면 다음 오류 메시지가 표시될 수 있습니다.

오류 1058: 서비스를 사용할 수 없거나 연결된 디바이스가 없으므로 서비스를 시작할 수 없습니다.

서비스를 시작하려고 할 때 이 오류 메시지가 표시될 수도 있습니다.

원인

이 문제는 서비스를 사용하지 않도록 설정하거나 현재 사용 중인 하드웨어 프로필에 대해 서비스를 사용하지 않도록 설정한 경우에 발생할 수 있습니다.

Windows 10, Windows 7 및 Windows Vista에 대한 해결 방법

  1. 시작을 클릭하고 서비스를 검색한 다음 검색 결과에서 서비스를 클릭합니다.

  2. 서비스를 찾을 때까지 스크롤한 다음 서비스를 두 번 클릭합니다.

    라우팅 및 원격 액세스 속성(로컬 컴퓨터) 대화 상자의 일반 탭에 있는 시작 유형 옵션의 스크린샷

  3. 서비스를 사용하지 않도록 설정한 경우 시작 유형 목록을 클릭한 다음 사용 안 함 이외의 옵션을 선택합니다.

  4. 적용을 클릭합니다.

  5. 시작을 클릭하여 서비스를 시작합니다.

  6. 확인을 클릭합니다.

Windows XP에 대한 해상도

  1. 시작을 클릭하고 모든 프로그램, 관리 도구를 차례로 가리킨 다음 서비스를 클릭합니다.

  2. 중지되거나 비활성화된 서비스를 찾을 때까지 스크롤합니다.

  3. 시작되지 않은 서비스를 두 번 클릭합니다.

  4. 로그온 탭을 클릭합니다.

    RPC(원격 프로시저 호출) 로케이터 속성(로컬 컴퓨터) 대화 상자의 로그온 탭 스크린샷

  5. 사용 중인 하드웨어 프로필에 대해 서비스가 비활성화되지 않은지 확인합니다. 하드웨어 프로필에 대해 서비스를 사용하지 않도록 설정한 경우 사용을 클릭합니다.

  6. 일반 탭을 클릭한 다음 시작 유형 상자에서 서비스가 사용하지 않도록 설정되어 있지 않은지 확인합니다. 서비스를 사용하지 않도록 설정한 경우 자동 을 클릭하여 컴퓨터를 시작할 때 시작하도록 합니다.

    일반 탭의 시작 유형 상자 스크린샷

  7. 확인을 클릭합니다.

추가 정보

서비스가 자동으로 시작되도록 설정되어 있지만 사용 중인 하드웨어 프로필에 대해 서비스를 사용하지 않도록 설정하면 서비스가 시작되지 않고 오류 메시지가 생성되지 않습니다.