Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You build a Microsoft Visual Studio 2008 Setup project and then install the generated MSI file to an installation path.

  • You migrate the Setup project to Visual Studio 2010 and then take the following actions for a major upgrade:

    • You change the major field of the ProductVersion property.

    • You change the ProductCode property.

    • You set the RemovePreviousVersions property to True.

  • You rebuild the Setup project and then install the generated MSI file on the same installation path.


In this scenario, the files and registry keys for the installation path disappear unexpectedly.

Cause

This problem occurs because a different hashing algorithm is used to create the GUIDs in Visual Studio 2010. When you install the MSI file that is created from the Visual Studio 2010 Setup project, the MSI file determines that the GUID has changed and removes the files and registry keys for the installation path based on the sequence of the project.

Resolution

To resolve this problem, apply this hotfix. This hotfix introduces the BackwardCompatibleIDGeneration property. By default, this property is set to False. Before you build the Setup project in Visual Studio 2010, you have to explicitly set the BackwardCompatibleIDGeneration property to True to enable the hotfix.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft website:

http://code.msdn.microsoft.com/KB2418919
Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Or, you can download this hotfix from the following Microsoft Connect website:

https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=32676

Prerequisites

To apply this hotfix, you must have Visual Studio 2010 installed.

Restart information

You may have to restart the computer after you apply this hotfix. We recommend that you exit any instances of Visual Studio or of the Microsoft .NET Framework applications before you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

File name

File version

File size

Date

Time

Platform

Dpca.dll

10.0.30319.464

236,872

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

145,232

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

145,744

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

146,256

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

147,280

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

147,792

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

148,304

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

904,520

11-May-2011

13:08

x86

Dpedt.dll

10.0.30319.464

696,136

11-May-2011

13:08

x86

Dpplg.dll

10.0.30319.464

2,606,408

11-May-2011

13:08

x86

Dpprj.dll

10.0.30319.464

1,229,640

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

163,152

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

163,664

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

167,248

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

168,272

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

178,000

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

178,512

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

180,560

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

181,072

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

181,584

11-May-2011

13:08

x86

Projectsidl3.tlb

Not applicable

2,816

10-May-2011

03:47

Not applicable


Workaround

To work around this problem, use one of the following methods:

  • Method 1: Manually change all component GUIDs to be the same as those of Visual Studio 2008.

  • Method 2: Resequence the RemoveExistingProducts action after the InstallInitialize action. This makes sure that older files are removed and then reinstalled by the newer version.

    Note This method does not work when you have shared components.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×