Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Considerare lo scenario descritto di seguito:

  • Compilare un progetto di installazione di Microsoft Visual Studio 2008 e quindi installare il file MSI generato in un percorso di installazione.

  • Migrare il progetto di installazione di Visual Studio 2010 e quindi effettuare le seguenti operazioni per un aggiornamento importante:

    • Modificare il campo principale della proprietà ProductVersion .

    • Si modifica la proprietà ProductCode .

    • Impostare la proprietà RemovePreviousVersions su True.

  • Si rigenera il progetto di installazione e quindi installa il file MSI generato con lo stesso percorso di installazione.

In questo scenario, i file e chiavi del Registro di sistema per il percorso di installazione scompaiono improvvisamente.

Causa

Questo problema si verifica perché un algoritmo di hash diverso viene utilizzato per creare il GUID in Visual Studio 2010. Quando si installa il file MSI creato dal progetto di installazione di Visual Studio 2010, il file MSI determina che il GUID è stato modificato e rimuove i file e chiavi del Registro di sistema per il percorso di installazione in base alla sequenza del progetto.

Risoluzione

Per risolvere questo problema, applicare questo hotfix. Questa correzione introduce la proprietà BackwardCompatibleIDGeneration . Per impostazione predefinita, questa proprietà è impostata su False. Prima di compilare il progetto di installazione di Visual Studio 2010, è necessario impostare in modo esplicito la proprietà BackwardCompatibleIDGeneration su True per attivare l'hotfix.

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix. Per risolvere immediatamente questo problema, contattare il supporto tecnico clienti Microsoft per ottenere l'hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota In casi particolari, le spese normalmente addebitate per le chiamate di supporto potrebbero essere annullate qualora un addetto al supporto Microsoft determina che uno specifico aggiornamento risolverà il problema. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione. Per scaricare questo hotfix da MSDN Code Gallery, visitare il seguente sito Web Microsoft:

http://code.msdn.microsoft.com/KB2418919Nota MSDN Code Gallery vengono visualizzate le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua elencata, è perché la pagina delle risorse di Code Gallery non è disponibile per tale lingua. In alternativa, è possibile scaricare questo aggiornamento rapido dal seguente sito Web Microsoft Connect:

https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=32676

Requisiti

Per applicare questo hotfix, è necessario disporre di Visual Studio 2010 installato.

Informazioni sul riavvio

Potrebbe essere necessario riavviare il computer dopo avere applicato questo hotfix. Si consiglia di chiudere tutte le istanze di Visual Studio o delle applicazioni di Microsoft.NET Framework prima di applicare questo hotfix.

Informazioni sulla sostituzione degli hotfix

Questo hotfix non sostituisce alcun altro hotfix precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix installa file che hanno gli attributi elencati nella seguente tabella. Le date e gli orari per questi file sono elencati in formato UTC (Coordinated Universal Time). Le date e gli orari per questi file sul vostro computer locale sono espressi nel vostro orario locale e tengono anche conto dell'ora solare (DST). Inoltre, le date e le ore potrebbero cambiare con l'esecuzione di alcune operazioni sui file.

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Dpca.dll

10.0.30319.464

236,872

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

145,232

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

145,744

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

146,256

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

147,280

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

147,792

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

148,304

11-May-2011

13:08

x86

Dpdpl.dll

10.0.30319.464

904,520

11-May-2011

13:08

x86

Dpedt.dll

10.0.30319.464

696,136

11-May-2011

13:08

x86

Dpplg.dll

10.0.30319.464

2,606,408

11-May-2011

13:08

x86

Dpprj.dll

10.0.30319.464

1,229,640

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

163,152

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

163,664

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

167,248

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

168,272

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

178,000

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

178,512

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

180,560

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

181,072

11-May-2011

13:08

x86

Dpprjui.dll

10.0.30319.464

181,584

11-May-2011

13:08

x86

Projectsidl3.tlb

Not applicable

2,816

10-May-2011

03:47

Not applicable

Soluzione alternativa

Per risolvere il problema, utilizzare uno dei metodi descritti di seguito.

  • Metodo 1: Modificare manualmente tutti i GUID di componente per essere uguali a quelle di Visual Studio 2008.

  • Metodo 2: Resequence l'azione RemoveExistingProducts dopo l'azione InstallInitialize . In questo modo i file meno recenti vengono rimossi e quindi reinstallati con la versione più recente.Nota Questo metodo non funziona quando si dispone di componenti condivisi.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×