Errore durante il tentativo di installazione dello strumento di sincronizzazione di Azure Active Directory: il computer deve essere aggiunto a un dominio

Versione originale del prodotto: Servizi cloud (Ruoli Web/Ruoli di lavoro), Microsoft Entra ID, Microsoft Intune, Backup di Azure, Gestione delle identità di Office 365
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Sintomi

Quando si tenta di installare lo strumento di sincronizzazione Microsoft Azure Active Directory, è possibile che venga visualizzato il messaggio di errore seguente:

Il computer deve essere aggiunto a un dominio.

Causa

Questo problema può verificarsi se il computer non è aggiunto a un dominio di Active Directory Domain Services (AD DS) o se il computer non registra un record di risorse host (A) con il relativo DNS (Domain Name System).

Risoluzione

Per risolvere questo problema, utilizzare uno dei seguenti metodi.

Metodo 1: il computer non è aggiunto a un dominio di Active Directory Domain Services

Aggiungere il computer a un dominio di Active Directory Domain Services. A tal fine, attenersi alla seguente procedura:

  1. Nel computer a cui si vuole aggiungere un dominio selezionare Avvia, selezionare Pannello di controllo e quindi fare doppio clic su Sistema.
  2. In Impostazioni nome computer, dominio e gruppo di lavoro selezionare Modifica impostazioni.
  3. Nella scheda Nome computer selezionare Modifica.
  4. In Membro di selezionare Dominio, digitare il nome del dominio a cui verrà aggiunto il computer e quindi selezionare OK.
  5. Selezionare OK e quindi riavviare il computer.

Metodo 2: il computer è già aggiunto a un dominio di Active Directory Domain Services

Se il computer è già aggiunto a un dominio di Active Directory Domain Services, assicurarsi che le impostazioni DNS del computer siano corrette e che un record di risorse host (A) per il computer sia registrato con DNS. A tal fine, attenersi alla seguente procedura:

  1. Aprire Connections di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione di rete da configurare e quindi scegliere Proprietà.

  3. Eseguire una delle operazioni seguenti, in base alle esigenze per la connessione che si vuole configurare:

    • Per una connessione all'area locale: nella scheda Generale selezionare Protocollo Internet (TCP/IP) e quindi selezionare Proprietà.
    • Per tutte le altre connessioni: nella scheda Rete selezionare Protocollo Internet (TCP/IP) e quindi selezionare Proprietà.
  4. Per ottenere gli indirizzi del server DNS da un server DHCP (Dynamic Host Configuration Protocol), selezionare Ottieni automaticamente l'indirizzo del server DNS.

  5. Per configurare manualmente gli indirizzi del server DNS, selezionare Usa gli indirizzi del server DNS seguenti. Nella casella Server DNS preferito digitare gli indirizzi IP del server DNS preferito. Nella casella Server DNS alternativo digitare gli indirizzi IP del server DNS alternativo.

  6. Selezionare OK due volte e quindi chiudere Rete Connections.

  7. Al prompt dei comandi digitare i comandi seguenti e premere INVIO dopo ogni comando:

    ipconfig /flushdns
    
    ipconfig /registerdns
    
  8. Se il problema non viene risolto, riavviare il computer in cui è installato lo strumento di sincronizzazione directory.

  9. Se il problema non è ancora stato risolto, assicurarsi che il computer in cui è installato lo strumento di sincronizzazione directory possa comunicare con il computer che esegue Servizi di dominio Active Directory.

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