Local drive redirection isn't working in RDP Session
This article provides a solution to an issue where local drive redirection isn't working in RDP Session.
Applies to: Windows Server 2003
Original KB number: 2436104
Symptoms
You may notice the following symptoms when connecting via Remote Desktop Protocol (RDP) to a Windows Server 2003 or Windows Server 2003 R2 Terminal Server:
- Local drives aren't redirected in the RDP Session.
- Other devices and resources may be properly redirected.
- There are no events in the Event Viewer pertaining to the failure to redirect drives.
Things to Check:
On the Server: Terminal Services Configuration - Connections - RDP-Tcp - Properties - Client Settings: Make sure Drive Mapping option is unchecked under Disable the Following.
On the Server: Terminal Services Configuration - Connections - RDP-Tcp - Properties - Client Settings: Under Connections - Connect Client Drives at logon is selected.
On the client Machine: Start - Run - MSTSC - Options - Local Resource - Make sure Disk Drives is selected.
Check Resultant Set of Policy on the machine: Terminal Services Group Policies, under
Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Client/Server
data redirection - Don't allow drive redirection: shouldn't be enabled.
Cause
Network Providers value for RDP might be missing in the registry.
Resolution
Make sure the Network Providers entry has at least the default entries:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order - ProviderOrder -
Default entries: RDPNP, LanmanWorkstation, web client
More information
No reboot is required after making these changes.
Feedback
https://aka.ms/ContentUserFeedback.
Coming soon: Throughout 2024 we will be phasing out GitHub Issues as the feedback mechanism for content and replacing it with a new feedback system. For more information see:Submit and view feedback for