Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you restore a previous registry using the scanreg /restore command, you may receive the following error message:

Microsoft Registry Checker
System restore operation failed.

Cause

This behavior occurs because you are attempting to restore the oldest version of the saved registries. The maximum number of registries is already saved as specified in the Scanreg.ini file by the MaxBackupCopies setting.


When you attempt to restore the oldest registry, Windows attempts to back up the current registry. Because Windows attempts to overwrite the same registry backup that you are attempting to restore, the restore operation is unsuccessful.


NOTE: Your oldest registry backup is still replaced with a backup of the current registry, and the oldest registry is no longer available to restore.

Resolution

To resolve this issue, perform either of the following actions before using the scanreg /restore command:

  • Rename one or more of the other saved registry backups to make room for another backup.

  • Increase the MaxBackupCopies setting in the Scanreg.ini file to accommodate a backup of the current registry.

You can also manually restore the registry files, which prevents the automatic backup of the current registry. For more information about this option, click the article number below to view the article in the Microsoft Knowledge Base:

220878 Error Message: Restore Operation Failed

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×