Comment les administrateurs système peuvent résoudre une erreur HTTP 404 - Message d’erreur indiquant un fichier introuvable sur un serveur exécutant IIS

Cet article vous aide à résoudre le problème d’erreur HTTP 404, lorsqu’un fichier est introuvable sur un serveur qui exécute Internet Information Services (IIS).

Remarque

Cet article est destiné aux administrateurs de sites web. Les utilisateurs finaux qui rencontrent ces erreurs doivent informer l’administrateur du site web du problème.

Version du produit d’origine : Internet Information Services
Numéro de l’article d’origine dans la base de connaissances : 248033

Symptômes

Lorsqu’une page web est demandée, le message d’erreur suivant s’affiche en haut du navigateur web :

La page est introuvable
La page que vous recherchez a peut-être été supprimée, a été renommée ou est provisoirement indisponible.

Le message d’erreur suivant s’affiche plus bas sur la page web :

HTTP 404 - Fichier introuvable
Services Internet (IIS)

Cause

Le serveur web renvoie le message d’erreur HTTP 404 - Fichier introuvable lorsqu’il ne peut pas récupérer la page demandée.

Ce message d’erreur est généralement dû à l’une des causes suivantes :

  • Le fichier demandé a été renommé.
  • Le fichier demandé a été déplacé vers un autre emplacement et/ou supprimé.
  • Le fichier demandé est temporairement indisponible en raison de la maintenance, des mises à niveau ou d’autres causes inconnues.
  • Le fichier demandé n’existe pas.
  • IIS 6.0 : l’extension de service web ou le type MIME approprié n’est pas activé.
  • Un répertoire virtuel est mappé à la racine d’un lecteur sur un autre serveur.

Résolution

Pour résoudre ce problème, vérifiez que le fichier demandé dans l’URL du navigateur existe sur l’ordinateur IIS et qu’il se trouve à l’emplacement approprié.

Utilisez le composant logiciel enfichable MMC (Microsoft Management Console) IIS pour déterminer où le fichier demandé doit exister dans le système de fichiers de l’ordinateur IIS.

Cela est important si le site web utilise un répertoire virtuel (VDIR). Un VDIR est un répertoire qui n’est pas contenu dans le répertoire de base du site web, mais qui apparaît au navigateur client comme si c’était le cas. Ce répertoire virtuel doit être mappé à un sous-dossier sur un lecteur ou référencer les fichiers par nom.

Par exemple, supposons que l’URL qui a provoqué l’erreur 404 est http://Microsoft.Com/Test/File1.htm, et que le composant logiciel enfichable IIS montre que pour le site web Microsoft.com, le répertoire /Test/ est en fait un répertoire virtuel qui mappe vers l’emplacement de c:\Information sur l’ordinateur IIS. Cela signifie que vous devez vérifier que le fichier File1.htm se trouve dans le répertoire c:\Information (et que le nom du fichier est correctement orthographié).

Contenu dynamique IIS : une entrée 404.2 dans le fichier journal étendu W3C est enregistrée lorsqu’une extension web n’est pas activée. Utilisez le composant logiciel enfichable MMC (Microsoft Management Console) IIS pour activer l’extension web appropriée. Les extensions web par défaut incluent : ASP, ASP.NET, SSI (Server-Side Includes), publication WebDAV, FrontPage Server Extensions, interface CGI (Common Gateway Interface). Les extensions personnalisées doivent être ajoutées et explicitement activées. Pour en savoir plus, consultez le fichier d’aide IIS.

Contenu statique IIS : une entrée 404.3 dans le fichier journal étendu W3C est enregistrée lorsqu’une extension n’est pas mappée à une extension connue dans la propriété de mappage MIME. Utilisez le composant logiciel enfichable MMC (Microsoft Management Console) IIS pour configurer l’extension appropriée dans le mappage MIME. Pour en savoir plus, consultez le fichier d’aide IIS.

Pour plus d’informations sur les autres causes moins courantes de ce message d’erreur, consultez l’article Les fichiers statiques masqués IIS renvoient des erreurs HTTP 404 ou Accès refusé.

Plus d’informations