Vous ne pouvez pas attribuer un domaine fédéré à un utilisateur dans le Centre Administration Microsoft 365

Problème

Vous créez un utilisateur dans le centre Administration Microsoft 365. Toutefois, lorsque vous essayez d’attribuer un domaine fédéré au nouvel utilisateur, le domaine fédéré n’est pas répertorié dans la liste des domaines de l’utilisateur.

Voici un exemple de scénario de ce qui se passe lorsque vous rencontrez ce problème :

  • Dans le portail Microsoft 365, l’authentification unique (SSO) et la synchronisation Active Directory sont activées.
  • Lorsque vous affichez les propriétés du domaine dans la page des propriétés du domaine, le type de domaine est répertorié comme Fédéré ou Authentification unique. Par exemple, adatum.com est le domaine fédéré.
  • Lorsque vous créez un utilisateur, vous voyez que le domaine par défaut fourni par Microsoft 365 est répertorié en tant que première option dans la zone de liste déroulante. Par exemple, le domaine par défaut est contoso.onmicrosoft.com.
  • Lorsque vous cliquez sur la zone de liste déroulante pour afficher la liste des domaines, le domaine fédéré n’est pas répertorié. Par exemple, adatum.com n’est pas répertorié.

Cause

Ce comportement est par nature dans Microsoft 365. Vous ne pouvez pas créer d’utilisateurs fédérés via le portail. Tous les utilisateurs fédérés doivent être créés localement et synchronisés à l’aide de l’outil de synchronisation Microsoft Azure Active Directory.

Remarque

Vous ne pouvez pas non plus définir un domaine fédéré comme domaine par défaut dans Microsoft 365.

Solution

Pour contourner ce comportement, créez un compte d’utilisateur correspondant dans l’environnement Active Directory local Domain Services (AD DS), configurez le nom d’utilisateur principal (UPN) de manière appropriée, puis synchronisez le compte et Microsoft Entra ID à l’aide de la synchronisation d’annuaires. Pour ce faire, procédez comme suit :

  1. Obtenez l’adresse SMTP principale du compte d’utilisateur Microsoft 365 en procédant comme suit :

    1. Connectez-vous au portail Microsoft 365 en tant qu’administrateur général.
    2. Sélectionnez Administration>Exchange pour ouvrir exchange Administration Center.
    3. Recherchez le compte d’utilisateur, puis double-cliquez dessus.
    4. Dans le volet de navigation gauche, sélectionnez Email’adresse, puis notez l’adresse SMTP principale du compte d’utilisateur.
  2. Démarrez Utilisateurs et ordinateurs Active Directory, puis créez un compte d’utilisateur dans le domaine local qui correspond au compte d’utilisateur Microsoft 365. Pour plus d’informations, consultez Créer un compte d’utilisateur dans Utilisateurs et ordinateurs Active Directory.

  3. Assurez-vous que l’UPN du compte d’utilisateur est mis à jour avec le nom de domaine fédéré. Pour plus d’informations, consultez Résoudre les problèmes liés aux comptes d’utilisateur Active Directory qui sont pilotés en tant qu’ID utilisateur compatibles avec l’authentification unique Microsoft 365.

  4. Utilisez les interfaces de service Active Directory (ADSI) Modifier pour modifier l’attribut proxyAddresses de l’objet utilisateur afin qu’il corresponde à l’adresse SMTP principale que vous avez notée à l’étape 1D. Pour ce faire, procédez comme suit :

    Remarque

    Pour plus d’informations sur l’installation d’ADSI Edit, consultez Installation d’ADSI Edit.

    1. Sélectionnez Démarrerl’exécution>, tapez ADSIEdit.msc, puis sélectionnez OK.

    2. Cliquez avec le bouton droit sur Modifier ADSI, sélectionnez Se connecter à, puis sélectionnez OK pour charger la partition de domaine.

    3. Dans le volet de navigation, recherchez l’objet utilisateur que vous souhaitez modifier, cliquez dessus avec le bouton droit, puis sélectionnez Propriétés.

    4. Dans la liste Attributs , sélectionnez l’attribut proxyAddresses , puis sélectionnez Modifier.

    5. Dans le champ Valeur à ajouter , entrez l’adresse SMTP appropriée, puis sélectionnez Ajouter.

      Remarque

      La valeur d’adresse SMTP principale de l’objet utilisateur doit être ajoutée par un indicateur SMTP : majuscule pour que la valeur d’adresse soit correctement mise en forme pour l’attribut proxyAddressesattribute. Par exemple, « SMTP :username@contoso.com » est une valeur acceptable et «username@contoso.com » n’est pas une valeur acceptable.

    6. Sélectionnez OK deux fois, puis quittez ADSI Edit.

    Pour plus d’informations sur l’utilisation de la modification ADSI pour modifier les attributs Active Directory, consultez Utilisation de la modification ADSI

  5. Forcez la synchronisation dʼannuaires.

Informations supplémentaires

Pour plus d’informations, consultez Résoudre les problèmes de nom d’utilisateur qui se produisent pour les utilisateurs fédérés lorsqu’ils se connectent à Microsoft 365, Azure ou Intune.

Encore besoin d’aide ? Accédez à Microsoft Community.