Ошибка "Произошла ошибка при удалении базы данных", когда пользователь пытается перейти в автономный режим в клиенте Microsoft Dynamics CRM для Outlook

Эта статья поможет устранить проблему, которая возникает при попытке перейти в автономный режим в клиенте Microsoft Dynamics CRM для Outlook.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 2496443

Симптомы

Рассмотрим следующий сценарий.

  • Клиентский компьютер используется несколькими пользователями или используется в среде сервера терминалов или Citrix.
  • Пользователь переходит в автономный режим. Затем второй пользователь нажимает кнопку Перейти в автономный режим.

В этом сценарии второй пользователь не может перейти в автономный режим. На самом деле, другие пользователи не могут перейти в автономный режим. Кроме того, появляется приведенное ниже сообщение об ошибке:

Произошла ошибка при удалении базы данных. Обратитесь за помощью к администратору Microsoft Dynamics CRM и попробуйте снова перейти в автономный режим.

Важно!

В статье содержатся сведения об изменении реестра. Перед внесением изменений рекомендуется создать резервную копию реестра. и изучить процедуру его восстановления на случай возникновения проблемы. Для получения дополнительной информации о том, как создать резервную копию, восстановить и изменить реестр, см. Сведения о резервном копировании и восстановлении реестра Windows.

Причина

Только один пользователь может быть настроен на переход в автономный режим в клиенте Microsoft Dynamics CRM для Microsoft Office Outlook.

Решение

Такое поведение является особенностью данного продукта. В Microsoft Dynamics CRM 2011 можно установить и настроить клиент Microsoft Dynamics CRM для Outlook. Затем можно установить автономные компоненты, нажав кнопку Перейти в автономный режим .

Если вы не хотите, чтобы пользователи могли нажать кнопку Перейти в автономный режим , можно использовать один из следующих вариантов.

  • Вариант 1

    Удалите разрешения перейти в автономный режим для пользователей, для которых вы не хотите видеть кнопку Перейти в автономный режим . Для этого выполните следующие действия:

    1. Чтобы пользователь, у которого есть разрешения на изменение роли безопасности CRM, щелкните Параметры, Администрирование, а затем — Роли безопасности.

    2. Щелкните, чтобы открыть роль безопасности, которую необходимо изменить. (Например, щелкните Менеджер по продажам)

    3. Перейдите на вкладку Управление бизнесом и снимите флажок Перейти в автономный проверка в разделе Прочие привилегии.

    4. Нажмите кнопку Сохранить, а затем — Закрыть.

      Примечание.

      Если клиент уже настроен, кнопка исчезнет на панели инструментов клиента, может потребоваться 5 минут или более.

  • Вариант 2

    Отключите кнопку Перейти в автономный режим для всех пользователей на каждом компьютере, а затем установите клиент Microsoft Dynamics CRM для Outlook вместе с помощью disableofflinecapability параметра . Для этого выполните следующие действия:

    1. Нажмите кнопку Пуск, нажмите кнопку Выполнить, а затем введите путь к файлу Setupclient.exe.

    2. /disableofflinecapability Установите клиент Microsoft Dynamics CRM для Outlook. (Например, используйте C:\Client\i386\SetupClient.exe/disableofflinecapability команду.)

    3. Нажмите кнопку Установить сейчас или используйте переключатель /q , чтобы выполнить тихую установку без запросов пользователя.

  • Вариант 3

    Предупреждение

    При неправильном изменении реестра с использованием редактора реестра или другого способа могут случиться серьезные проблемы. Для решения этих проблем может потребоваться переустановка операционной системы. Компания Microsoft не может гарантировать, что эти проблемы могут быть решены. Вносите изменения в реестр на ваш страх и риск.

    Если вы уже установили клиент Microsoft Dynamics CRM для Outlook, вы можете изменить разделы реестра LightClient, чтобы новые пользователи, которые запускали конфигурацию, не отображали кнопку Перейти в автономный режим. Для этого выполните следующие действия:

    1. Нажмите кнопку Пуск, нажмите кнопку Выполнить, введите Regedit и нажмите кнопку ОК.

    2. Найдите подраздел реестра: HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient.

    3. Щелкните правой кнопкой мыши раздел реестра LightClient и выберите команду Изменить.

    4. Измените значение на1, выберите Десятичный и нажмите кнопку ОК.

    5. Запустите клиент Microsoft Dynamics CRM для Outlook.

      Примечание.

      Если клиент уже настроен, кнопка исчезнет на панели инструментов клиента, может потребоваться 5 минут или более.

    6. Найдите подраздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient.

      Примечание.

      Если вы используете 64-разрядный клиентский компьютер и установлена 3-разрядная версия Microsoft Office, соответствующий подраздел реестра выглядит следующим образом:
      HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient.

    7. Щелкните правой кнопкой мыши раздел реестра LightClient и выберите команду Изменить.

    8. Измените значение на1, выберите Десятичный и нажмите кнопку ОК. При запуске новой конфигурации кнопка Перейти в автономный режим будет удалена.

    Примечание.

    При изменении записи реестра в HKEY_CURRENT_USERэто изменение повлияет только на пользователя, вошедшего в систему. Чтобы применить изменение к нескольким пользователям, найдите их запись в разделе HKEY_Users\. Или примените ключ с помощью групповая политика к multiple/other users.

Дополнительная информация

Если пользователь уже перешел в автономный режим и другой пользователь должен иметь возможность перейти в автономный режим на том же компьютере, необходимо удалить базу данных из предыдущего пользователя. Дополнительные сведения о том, как удалить базу данных SQL Express, см. в разделе DROP DATABASE (Transact-SQL).