Outlook viser feil søkeresultater for GAL i Exchange Server

Opprinnelig KB-nummer: 2497077

Symptomer

Når du bruker Microsoft Office Outlook 2007, Outlook 2010 eller Outlook 2013 til å søke etter brukere i en global adresseliste (GAL) i Microsoft Exchange Server 2007, Exchange Server 2010 eller Exchange Server 2013, kan følgende problemer oppstå:

  • Når du velger alternativet som sorterer søkeresultatene ved hjelp av [Visningsnavn] -feltet under Avansert søk i Outlook-adresseboken, sorteres ikke resultatene ved hjelp av [Visningsnavn] -kolonnen.
  • Når du søker etter objekter som har et brukernavn eller et distribusjonslistenavn, returnerer ikke søkeoperasjonen det riktige objektet hvis alternativet [Bare navn] er aktivert.

Obs!

Når alternativet [Flere kolonner] er aktivert, returnerer søkeoperasjonene de riktige resultatene.

Årsak

Dette problemet oppstår fordi Active Directory Domain Services (AD DS) bruker furigana for indeksering i Windows Server 2008.

Når fonetiske visningsnavn er satt til bruker- eller distribusjonsgruppeobjekter i AD DS i Windows Server 2008, genereres en indeks over det fonetiske visningsnavnet på den globale katalogserveren. Indeksen brukes til å søke eller ordne et søkeresultat av en gal i den japanske versjonen av Outlook. Når objektene i GAL ikke har et fonetisk visningsnavn, brukes visningsnavnet til indeksering. Hvis alternativet [bare navn] er valgt, er søkeomfanget begrenset til objekter som har fonetiske visningsnavn. Derfor får du feil resultater når du søker i en adressebok i Office Outlook hvis objekter ikke har fonetiske visningsnavn.

Du søker for eksempel etter et visningsnavn som er forskjellig fra det fonetiske visningsnavnet i en GAL der enkelte objekter ikke har fonetiske visningsnavn. I dette scenarioet returneres ikke objektet som har det samsvarende visningsnavnet i [Visningsnavn ]-kolonnen i søkeresultatene, og bare objekter som har fonetiske visningsnavn, returneres.

Hvis det fonetiske visningsnavnet for alle brukere og distribusjonslister på GAL ikke er angitt, returnerer et søk som bruker alternativet [Bare navn] , riktige resultater. Riktige resultater returneres fordi indeksen for fonetiske visningsnavn bare inneholder visningsnavn.

Løsning

Viktig

Dette avsnittet, denne metoden eller denne oppgaven inneholder trinn som forteller deg hvordan du kan endre registret. Det kan imidlertid oppstå alvorlige problemer hvis du endrer registret på feil måte. Sørg derfor for at du følger fremgangsmåten nøye. Husk å ta sikkerhetskopi av registret før du endrer det, som en ekstra beskyttelse. Da kan du gjenopprette registret hvis det skulle oppstå problemer. Hvis du vil ha mer informasjon om hvordan du sikkerhetskopierer og gjenoppretter registret, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
322756 Slik sikkerhetskopierer og gjenoppretter du registeret i Windows

Følg en av disse fremgangsmåtene for å omgå dette problemet:

Hvis du vil at vi skal løse dette problemet ved hjelp av metode 1 for deg, kan du gå til delen «La meg løse det selv».

La meg løse det selv

  • Metode 1

    1. Klikk Start , klikk Kjør, skriv regedit, og trykk deretter OK.
    2. Finn og klikk registeroppføringen DisableGALPhonetic i en av følgende registerundernøkler:
      • HKEY_CURRENT_USER\Software\Policies\Microsoft\Exchange\Exchange Provider
      • HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

    Obs!

    Hvis registeroppføringen DisableGALPhonetic ikke finnes, må du opprette denne oppføringen. Dette gjør du slik:

    1. Klikk NyRediger-menyen, og klikk deretter DWORD(32-biters) verdi.
    2. Skriv inn DisableGALPhonetic, og trykk deretter ENTER.
    3. Høyreklikk DisableGALPhonetic, klikk Endre, skriv inn 1 i Verdidata-boksen , og klikk deretter OK.
    4. Avslutt registeret Redaktør, og start deretter datamaskinen på nytt for å bruke endringen.
  • Metode 2

    Bruk alternativet [Flere kolonner] i stedet for alternativet [Bare navn] når du søker etter objekter med furigana og objekter som ikke har furigana.

Løste dette problemet

Kontroller om problemet er løst. Hvis problemet er løst, er du ferdig med denne inndelingen. Hvis problemet ikke er løst, kan du kontakte kundestøtte.

Mer informasjon

Outlook-klienter kobler til Client Access Server (CAS) i Exchange Server 2010-organisasjonen. CAS støtter imidlertid ikke indeks for furigana når du søker eller viser gal i Outlook i Exchange Server 2010 RTM. Når du bruker ikke-bufret modus til å søke i adresselisten i Office Outlook, returneres ikke de samsvarende brukerne i søkeresultatet. De nederste objektene i adresselisten er imidlertid valgt. Installer Exchange Server 2010 Service Pack 1 (SP1) for å løse dette problemet.