Symptômes
Prenons l’exemple du scénario suivant :
-
Dans un environnement Microsoft Exchange Server 2010, vous vous connectez à votre boîte aux lettres à l’aide de Premium d’Outlook Web App (OWA) dans Internet Explorer 7.
-
Vous sélectionnez un message électronique qui a deux ou plusieurs pièces jointes.
-
La ligne d’objet du message électronique contient des caractères spéciaux. Par exemple, l’objet inclut les caractères suivants :
-
/
-
\
-
:
-
*
-
?
-
"
-
<
-
>
-
|
-
-
Vous cliquez sur télécharger toutes les pièces jointes pour enregistrer toutes les pièces jointes dans un fichier compressé.
Dans ce scénario, la boîte de dialogue Téléchargement de fichier disparaît après avoir cliqué sur Enregistrer. En outre, les pièces jointes ne sont pas enregistrées.Remarque
-
Ce problème ne se produit pas lorsque vous utilisez Internet Explorer 8 ou Internet Explorer 9.
-
Ce problème ne se produit pas lorsque vous utilisez OWA Light, qui ne fournit pas la fonctionnalité de téléchargement de zip.
Cause
Ce problème se produit car la fonctionnalité de téléchargement de zip dans OWA ne vérifie pas si la ligne d’objet contient des caractères non valides avant qu’il génère le nom du fichier compressé.
Résolution
Pour résoudre ce problème, installez le correctif cumulatif suivant :
2582113 Description du correctif cumulatif 5 pour Exchange Server 2010 Service Pack 1
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.
Solution de contournement
Pour contourner ce problème, effectuez les opérations suivantes :
-
Cliquez sur le bouton Transférer pour transférer l’e-mail à vous-même.
-
Supprimez ces caractères spéciaux dans l’objet.
-
Cliquez sur le bouton Envoyer pour envoyer l’e-mail.
-
Ouvrez l’e-mail reçu plus tard pour enregistrer les pièces jointes.