削除しようとしたオブジェクトは別のオブジェクトに関連付けられているので、Microsoft Dynamics CRMでマネージド ソリューションをアンインストールしようとすると、エラーを削除できません。

この記事では、Microsoft Dynamics CRMでマネージド ソリューションをアンインストールしようとしたときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2503016

現象

Microsoft Dynamics CRMでマネージド ソリューションをアンインストールしようとすると、次のエラー メッセージが表示されます。

削除しようとしたオブジェクトが別のオブジェクトに関連付けられているので、削除できません

ただし、エラー メッセージが参照するオブジェクトであるオブジェクトを特定するのは困難です。 CRM プラットフォーム トレース ログには詳細が表示されません。

たとえば、この問題は次のいずれかのシナリオで発生する可能性があります。

  • アーティクル テンプレートを含むマネージド ソリューションがインストールされている。
  • 管理ソリューションの Article Temple を参照する記事レコードがシステムにあります。

原因

ソリューション内の記事テンプレートはエンティティではなくレコードです。 そのため、依存関係はレコード レベルであり、エンティティ レベルではありません。 この場合、依存関係の追跡は機能せず、代わりに連鎖エラーが発生します。

既定では、アーティクル テンプレートとアーティクルには、連鎖削除の制限として 1:N のリレーションシップがあります。 これにより、テンプレートがアーティクル レコードによって参照されている場合に、システムからアーティクル テンプレート レコードが削除されなくなります。

解決方法

このエラーが原因でマネージド ソリューションをアンインストールできない場合は、ソリューション内のソリューション コンポーネントのレコードの種類をチェックし、レコードのいずれかがそれらのコンポーネントを参照しているかどうかをチェックする必要があります。 参照を解決するには、ソリューション コンポーネントに関連付けられているレコードを削除または変更してから、ソリューションをもう一度アンインストールする必要がある場合があります。

詳細

同様の問題は、次のような他の種類のソリューション コンポーネントで発生します。

  • その他のテンプレートの種類
  • Microsoft サポート技術情報の記事
  • Web リソース
  • プロセス (子プロセス)