Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You install the DNS Server role on a computer that is running Windows Server 2008 R2.

  • You configure the DNS server to connect to a public DNS server on the Internet for name resolution.

  • You do not configure any forwarders on the DNS server.

In this scenario, the DNS Server service does not resolve some external DNS names after it works for a while. Therefore, you cannot access some applications or some websites that rely on these external DNS names.

Notes

  • To resolve this issue, you have to restart the DNS Server service or clear the DNS cache.

  • This issue usually occurs if you use the DNS Cache Locking feature in Windows Server 2008 R2.

Cause

This issue occurs because the DNS Server service cannot correctly handle the situation in which the glue record is expired or removed.

Resolution

Hotfix information

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760
    0.
    20xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.
    21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Cache.dns

Not applicable

3,198

10-Jun-2009

20:31

Not applicable

Dns.exe

6.1.7600.20930

696,320

22-Mar-2011

05:15

x64

Dnsserver.events.xml

Not applicable

609

10-Jun-2009

20:31

Not applicable

Cache.dns

Not applicable

3,198

05-Nov-2010

01:52

Not applicable

Dns.exe

6.1.7601.21689

696,832

22-Mar-2011

05:08

x64

Dnsserver.events.xml

Not applicable

609

05-Nov-2010

01:52

Not applicable

Workaround

Workaround for Windows Server 2008 R2



To work around this issue, restart the DNS Server service. Or, type the following command at a command prompt, and then press ENTER to clear the DNS cache:

dnscmd /clearcache

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the DNS Cache Locking feature, visit the following TechNet website:

General information about the DNS Cache Locking featureFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information


Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_626603afd074f82a85a123a8284b1a67_31bf3856ad364e35_6.1.7601.21689_none_e28975fd1d5ee264.manifest

File version

Not applicable

File size

710

Date (UTC)

23-Mar-2011

Time (UTC)

07:57

File name

Amd64_eb10c5926a17acb934a77496c4381161_31bf3856ad364e35_6.1.7600.20930_none_3853ac3a142a00de.manifest

File version

Not applicable

File size

710

Date (UTC)

23-Mar-2011

Time (UTC)

07:57

File name

Amd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.1.7600.20930_none_aab58b90093f26d7.manifest

File version

Not applicable

File size

158,131

Date (UTC)

22-Mar-2011

Time (UTC)

06:06

File name

Amd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.1.7601.21689_none_ac6ed9ae06860560.manifest

File version

Not applicable

File size

158,131

Date (UTC)

22-Mar-2011

Time (UTC)

05:42

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×