Errore 80048163 quando un utente federato tenta di accedere a Microsoft 365, Azure o Intune

Problema

Quando un utente federato tenta di accedere a un servizio cloud Microsoft, ad esempio Microsoft 365, Microsoft Azure o Microsoft Intune da una pagina Web di accesso il cui URL inizia con https://login.microsoftonline.com, l'autenticazione per tale utente non riesce. L'utente riceve il messaggio di errore seguente:

Sorry, but we're having trouble signing you in

Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80048163

Causa

Questo problema può verificarsi se una delle seguenti condizioni è vera:

  • L'UPN di un utente è stato aggiornato e le informazioni di accesso precedenti sono state memorizzate nella cache nel server Active Directory Federation Services (AD FS). Quando l'account SAM dell'utente viene modificato, le informazioni di accesso memorizzate nella cache potrebbero causare problemi la volta successiva in cui l'utente tenta di accedere ai servizi.
  • Le attestazioni configurate nell'attendibilità della relying party con Microsoft Entra ID restituiscono dati imprevisti. Questo comportamento può verificarsi quando le attestazioni associate all'attendibilità della relying party vengono modificate o rimosse manualmente.

Soluzione

Risoluzione 1: Disabilitare la memorizzazione nella cache delle credenziali dell'autorità di sicurezza locale (LSA) nel server AD FS

È possibile aggiornare l'impostazione di timeout della cache LSA nel server AD FS per disabilitare la memorizzazione nella cache delle informazioni sulle credenziali di Active Directory. Usare questo metodo con cautela. Potrebbe caricare ulteriormente il server e Active Directory.

Importante

Questo metodo contiene i passaggi che indicano come modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per altre informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo Come eseguire il backup e ripristinare il Registro di sistema in Windows.

Per risolvere questo problema, attenersi alla seguente procedura:

  1. Assicurarsi che le modifiche apportate all'UPN dell'utente siano sincronizzate tramite la sincronizzazione della directory.

  2. Indicare all'utente di disconnettersi dal computer e quindi di accedere di nuovo.

  3. Se i passaggi 1 e 2 non consentono di risolvere il problema, seguire questa procedura:

    1. Aprire Editor del Registro di sistema e quindi individuare la sottochiave seguente:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    2. Fare clic con il pulsante destro del mouse su Lsa, scegliere Nuovo e quindi fare clic su Valore DWORD.

    3. Digitare LsaLookupCacheMaxSize e quindi premere INVIO per denominare il nuovo valore.

    4. Fare clic con il pulsante destro del mouse su LsaLookupCacheMaxSize e quindi scegliere Modifica.

    5. Nella casella Dati valore digitare 0 e quindi fare clic su OK.

    6. Uscire dall'editor del Registro di sistema.

La riconfigurazione di LsaLookupCacheMaxSize può influire sulle prestazioni di accesso e questa riconfigurazione non è necessaria dopo la riduzione dei sintomi. Questo metodo deve essere usato solo temporaneamente ed è consigliabile eliminare il valore LsaLookupCacheMaxSize dopo la risoluzione del problema. A tal fine, attenersi alla seguente procedura:

  1. Aprire Editor del Registro di sistema e quindi individuare la sottochiave seguente:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Fare clic con il pulsante destro del mouse su LsaLookupCacheMaxSize e quindi scegliere Elimina.

  3. Uscire dall'editor del Registro di sistema.

Risoluzione 2: aggiornare l'attendibilità della relying party con Microsoft Entra ID

Per aggiornare l'attendibilità della relying party, vedere la sezione "Come aggiornare la configurazione del dominio federato di Microsoft 365" dell'articolo Microsoft seguente:

Come aggiornare o ripristinare le impostazioni di un dominio federato in Microsoft 365, Azure o Intune

Ulteriori informazioni

Ulteriore assistenza Accedere alla community Microsoft o al sito Web dei forum di Microsoft Entra.