Federasyon kullanıcısı Microsoft 365, Azure veya Intune oturum açmaya çalıştığında hata 80048163

Sorun

Federasyon kullanıcısı Microsoft 365, Microsoft Azure gibi bir Microsoft bulut hizmetinde oturum açmaya çalıştığında veya URL'si ile https://login.microsoftonline.combaşlayan bir oturum açma web sayfasından Microsoft Intune bu kullanıcının kimlik doğrulaması başarısız oluyor. Kullanıcı aşağıdaki hata iletisini alır:

Sorry, but we're having trouble signing you in

Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80048163

Neden

Aşağıdaki koşullardan biri doğruysa bu sorun oluşabilir:

  • Kullanıcının UPN'i güncelleştirildi ve eski oturum açma bilgileri Active Directory Federasyon Hizmetleri (AD FS) (AD FS) sunucusunda önbelleğe alındı. Kullanıcının SAM hesabı değiştirildiğinde, önbelleğe alınan oturum açma bilgileri kullanıcının hizmetlere erişmeye çalıştığı bir sonraki seferde sorunlara neden olabilir.
  • Bağlı olan taraf güveninde Microsoft Entra ID ayarlanan talepler beklenmeyen veriler döndürür. Bu davranış, bağlı olan taraf güveniyle ilişkili talepler el ile düzenlendiğinde veya kaldırıldığında ortaya çıkabilir.

Çözüm

Çözüm 1: AD FS sunucusunda Yerel Güvenlik Yetkilisi (LSA) kimlik bilgilerini önbelleğe almayı devre dışı bırakma

Active Directory kimlik bilgisi bilgilerinin önbelleğe alınmasını devre dışı bırakmak için AD FS sunucusunda LSA önbellek zaman aşımı ayarını güncelleştirebilirsiniz. Bu yöntemi dikkatli kullanın. Sunucuya ve Active Directory'ye ek yük bindirebilir.

Önemli

Bu yöntem, kayıt defterini nasıl değiştirebileceğinizi belirten adımlar içerir. Ancak kayıt defterini hatalı biçimde değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle bu adımları dikkatle uyguladığınızdan emin olun. Ek koruma için kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Böylece, bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Windows'da kayıt defterini yedekleme ve geri yükleme makalesini görüntülemek üzere aşağıdaki makale numarasını tıklatın.

Bu sorunu çözmek için şu adımları izleyin:

  1. Kullanıcının UPN'sinde yapılan değişikliklerin dizin eşitlemesi aracılığıyla eşitlenmiş olduğundan emin olun.

  2. Kullanıcıyı bilgisayarın oturumunu kapatması ve ardından yeniden oturum açması için yönlendirin.

  3. 1. ve 2. adımlar sorunu çözmezse şu adımları izleyin:

    1. Kayıt Defteri Düzenleyici açın ve aşağıdaki alt anahtarı bulun:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    2. Lsa'ya sağ tıklayın, Yeni'ye ve ardından DWORD Değeri'ne tıklayın.

    3. LsaLookupCacheMaxSize yazın ve yeni değeri adlandırmak için ENTER tuşuna basın.

    4. LsaLookupCacheMaxSize öğesine sağ tıklayın ve ardından Değiştir'e tıklayın.

    5. Değer verileri kutusuna 0 yazın ve Tamam'a tıklayın.

    6. Kayıt Defteri Düzenleyicisi'nden çıkın.

LsaLookupCacheMaxSize yeniden yapılandırma, oturum açma performansını etkileyebilir ve belirtiler alta geçtikten sonra bu yeniden yapılandırma gerekli değildir. Bu yöntem yalnızca geçici olarak kullanılmalıdır ve sorun çözüldükten sonra LsaLookupCacheMaxSize değerini silmenizi kesinlikle öneririz. Bunu yapmak için şu adımları uygulayın:

  1. Kayıt Defteri Düzenleyici açın ve aşağıdaki alt anahtarı bulun:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. LsaLookupCacheMaxSize öğesine sağ tıklayın ve ardından Sil'e tıklayın.

  3. Kayıt Defteri Düzenleyicisi'nden çıkın.

2. Çözüm: Bağlı olan taraf güvenini Microsoft Entra ID ile güncelleştirme

Bağlı olan taraf güvenini güncelleştirmek için, aşağıdaki Microsoft makalesinin "Microsoft 365 federasyon etki alanının yapılandırmasını güncelleştirme" bölümüne bakın:

Microsoft 365, Azure veya Intune bir federasyon etki alanının ayarlarını güncelleştirme veya onarma

Daha fazla bilgi

Yine de yardım mı gerekiyor? Microsoft Topluluğu'na veya Microsoft Entra Forumları web sitesine gidin.