メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況で問題が発生します。

  • BizTalk Server 2006 R2 の Microsoft または Microsoft BizTalk Server 2009 年に、MIME/SMIME エンコーダー パイプライン コンポーネントを使用する送信パイプラインがあります。 MIME/SMIME エンコーダー パイプライン コンポーネントの署名の種類を設定するには署名します。

  • 送信メッセージに署名するのには送信パイプラインを実行している BizTalk オーケストレーションを作成します。 たとえば、オーケストレーションでメッセージの割り当て図形の送信パイプラインを呼び出す式を使用します。 詳細については、「関連情報」セクションを参照してください。

  • Microsoft BizTalk Server 2006 R2 Service Pack 1 (SP1) をインストールするとします。 または、Microsoft BizTalk Server 2010 にアップグレードします。

  • BizTalk オーケストレーションを実行するとします。

このシナリオでは、送信メッセージは署名されていません。 さらに、次のようなエラー メッセージがアプリケーション ログに記録されます。

送信パイプラインを実行中にエラーが発生しました:「< パイプライン名 >」元:「MIME/SMIME エンコーダー」送信ポート:」「URI 名"< ポート名を送信 >理由: エンコーダーが見つかりませんでした署名のため送信メッセージに署名できません「現在のユーザー \ 個人用」証明書ストア内の証明書です。

原因

この問題は、BizTalk Server が正しくない場所に証明書を検索しようとするために発生します。 注: これらの確認手順は、Windows クライアントにのみ適用されます。 BizTalk Server 2006 R2 の SP1 および BizTalk Server 2010 は、複数の証明書を署名に使用できる新しい機能を紹介します。

解決方法

累積的な更新プログラム パッケージの情報

詳細については、累積的な更新プログラム パッケージの入手については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックする方法。

2573000 BizTalk Server 2010 の累積的な更新プログラム パッケージ 2 注: BizTalk Server 2006 R2 sp1 ではこの問題が発生した場合は、この問題を回避する「回避策」セクション手順に従うことができます。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

回避策

以下の手順に従って、この問題を回避するには。

  1. プロパティ スキーマを展開するのにには、次の名前空間を使用します。

    http://schemas.microsoft.com/BizTalk/2003/system-properties.BTS.OutboundSignatureCertificate

  2. BTS のを設定します。OutboundSignatureCertificate送信パイプラインを実行する前に、オーケストレーション コードで証明書の拇印の値を使用するプロパティです。

詳細情報

MIME/SMIME エンコーダー パイプライン コンポーネントを構成する方法の詳細については、次の MSDN web サイトを参照してください。

MIME/SMIME エンコーダー パイプライン コンポーネントを構成する方法パイプラインを実行する式を使用する方法の詳細については、次の MSDN web サイトを参照してください。

パイプラインを実行する式を使用する方法BizTalk Server の修正プログラムに関する詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。

2003907 BizTalk Server の修正プログラムに関する情報BizTalk Server のサービス パックと累積的な更新プログラム パッケージの詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。

2555976 BizTalk Server のサービス パックと累積的な更新の一覧

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×