Seite kann nicht angezeigt werden, wenn Sie eine Verbindung über SSL herstellen

Dieser Artikel hilft Ihnen, das Problem zu beheben, bei dem die Seite nicht angezeigt werden kann, wenn Sie eine Verbindung über SSL herstellen.

Ursprüngliche Produktversion: Internetinformationsdienste
Ursprüngliche KB-Nummer: 260096

Symptome

Wenn Sie mithilfe von Secure Socket Layer (SSL) eine Verbindung mit einem Computer herstellen, auf dem Internetinformationsdienste (IIS) ausgeführt werden, kann die folgende Fehlermeldung auftreten:

Die Seite kann nicht angezeigt werden.
Die gesuchte Seite ist derzeit nicht verfügbar. Auf der Website treten möglicherweise technische Schwierigkeiten auf, oder Sie müssen ihre Browsereinstellungen anpassen.

Diese Website ist in der Regel die zweite Website auf dem Server. Das Herstellen einer Verbindung mit der Website über HTTP funktioniert ordnungsgemäß.

Ursache

Diese Fehlermeldung kann auftreten, wenn Ssl auf der Standardwebsite festgelegt ist und Sie das Zertifikat entfernen und dann versuchen, es auf einer zweiten Website einzurichten.

Wenn Sie einen netstat -an Befehl ausführen, sehen Sie, dass ein Dienst an Port 443 lauscht, aber Sie können keine Verbindung damit herstellen. Dies wird durch eine neue Implementierung in IIS-Versionen 5.0 und höher namens Socketpooling verursacht.

Lösung

Hinweis

Für die Zwecke dieses Artikels werden zwei Websites installiert: die Standardwebsite und die Verwaltungswebsite. Ssl ist standardmäßig auf der Standardwebsite aktiviert.

  1. Öffnen Sie die Security Eigenschaften für die Standardwebsite, und wählen Sie dann Serverzertifikat aus.
  2. Klicken Sie im Assistenten auf Vorhandenes Zertifikat zuweisen, und wählen Sie dann ein Zertifikat aus der Liste aus.
  3. Wenn Sie den Assistenten abgeschlossen haben, klicken Sie auf die Registerkarte Website und dann auf Erweitert.
  4. Löschen Sie alle Einträge, die im SSL-Fenster aufgeführt sind.
  5. Klicken Sie erneut auf Serverzertifikat , klicken Sie auf Aktuelles Zertifikat entfernen, und klicken Sie auf OK.
  6. Klicken Sie in der Microsoft Management Console (MMC) mit der rechten Maustaste auf den Computernamen, und klicken Sie dann auf IIS neu starten.

Sie sollten nun über SSL eine Verbindung mit dem Server herstellen können.

Problemumgehung

Durch einen Neustart der IIS-Dienste wird die Fehlermeldung möglicherweise behoben. Wenn dies nicht der Fall ist, führen Sie die Schritte im Abschnitt "Lösung" dieses Artikels aus.

Weitere Informationen

Nachdem SSL auf einem IIS-Webserver aktiviert wurde, beginnt der IIS-Dienst, an allen verwendeten und nicht verwendeten IP-Adressen an den Ports 80 und 443 zu lauschen. Für Server mit mehreren IP-Adressen können Sie dieses Feature deaktivieren. Dieses Feature wurde das Produkt zur Leistungssteigerung hinzugefügt.

Dieses Problem tritt normalerweise auf, wenn Sie versuchen, SSL auf der Verwaltungswebsite einzurichten. IIS sucht die SSL-Einstellungen für die Standardwebsite und lauscht an Port 443. Die Standardwebsite verfügt jedoch nicht über ein Zertifikat, das dieser Website entspricht. Daher kann keine Verbindung hergestellt werden. Daher können Sie sehen, dass ein Server an Port 443 lauscht, aber sie können keine Verbindung mit dem Standort herstellen.

Schritte zum Reproduzieren dieses Verhaltens

  1. Erstellen Sie auf einem Computer mit der Standardwebsite und der Verwaltungswebsite ein Zertifikat, und legen Sie es dann auf der Standardwebsite fest. Belassen Sie den SSL-Port bei 443.
  2. Klicken Sie in den Standardeigenschaften der Website auf die Registerkarte Sicherheit , und klicken Sie dann auf Serverzertifikat.
  3. Klicken Sie auf Aktuelles Zertifikat entfernen und dann auf OK.
  4. Klicken Sie auf der Verwaltungswebsite auf Serverzertifikat, wählen Sie ein Zertifikat zu, und wählen Sie dann ein Zertifikat aus der Liste aus.
  5. Stellen Sie sicher, dass der Port 443 ist.
  6. Versuchen Sie, über SSL (https://localmachine) eine Verbindung mit der Verwaltungswebsite herzustellen. Sie benötigen die Portnummer des Standorts nicht, da SSL jetzt an Port 443 lauscht.
  7. Die Seite kann nicht angezeigt werden Fehler tritt im Browser auf.