No se puede mostrar la página al conectarse a través de SSL

Este artículo le ayuda a resolver el problema en el que no se puede mostrar la página al conectarse a través de SSL.

Versión del producto original: Internet Information Services
Número de KB original: 260096

Síntomas

Al conectarse a un equipo que ejecuta Internet Information Services (IIS) mediante capa de sockets seguros (SSL), puede producirse el siguiente mensaje de error:

No se puede mostrar la página.
La página que está buscando no está disponible actualmente. Es posible que el sitio web esté experimentando dificultades técnicas o que tenga que ajustar la configuración del explorador.

Este sitio web suele ser el segundo sitio web del servidor. La conexión al sitio web a través de HTTP funciona correctamente.

Causa

Este mensaje de error puede producirse si tiene SSL establecido en el sitio web predeterminado y quita el certificado y, a continuación, intenta configurarlo en un segundo sitio web.

Si ejecuta un netstat -an comando, puede ver que un servicio está escuchando en el puerto 443, pero no puede conectarse a él. Esto se debe a una nueva implementación en las versiones 5.0 y posteriores de IIS denominada Agrupación de sockets.

Solución

Nota:

Para los fines de este artículo, se instalan dos sitios web: el sitio web predeterminado y el sitio web de administración. De forma predeterminada, SSL está habilitado en el sitio web predeterminado.

  1. Abra las Security propiedades del sitio web predeterminado y, a continuación, seleccione Certificado de servidor.
  2. En el asistente, haga clic en Asignar un certificado existente y, a continuación, seleccione un certificado de la lista.
  3. Cuando haya completado el asistente, haga clic en la pestaña Sitio web y, a continuación, haga clic en Opciones avanzadas.
  4. Elimine todas las entradas que aparecen en la ventana SSL.
  5. Vuelva a hacer clic en Certificado de servidor, en Quitar el certificado actual y en Aceptar.
  6. Haga clic con el botón derecho en el nombre del equipo en Microsoft Management Console (MMC) y, a continuación, haga clic en Reiniciar IIS.

Ahora debería poder conectarse al servidor mediante SSL.

Solución alternativa

Reiniciar los servicios IIS puede resolver el mensaje de error. Si no es así, siga los pasos descritos en la sección "Resolución" de este artículo.

Más información

Después de habilitar SSL en un servidor web IIS, el servicio IIS comienza a escuchar en todas las direcciones IP usadas y sin usar en los puertos 80 y 443. En el caso de los servidores de direcciones IP múltiples, es posible que desee deshabilitar esta característica. Esta característica se agregó al producto para mejorar el rendimiento.

Este problema suele producirse al intentar configurar SSL en el sitio web de administración. IIS busca la configuración SSL del sitio web predeterminado y escucha en el puerto 443. Sin embargo, el sitio web predeterminado no tiene un certificado que se corresponda con ese sitio. Por lo tanto, no se puede establecer ninguna conexión, por lo que puede ver un servidor escuchando en el puerto 443, pero no puede conectarse al sitio.

Pasos para reproducir este comportamiento

  1. En un equipo que tenga el sitio web predeterminado y el sitio web de administración, cree un certificado y, a continuación, establézcalo en el sitio web predeterminado. Deje el puerto SSL en 443.
  2. Haga clic en la pestaña Seguridad de las propiedades predeterminadas del sitio web y, a continuación, haga clic en Certificado de servidor.
  3. Haga clic en Quitar el certificado actual y, a continuación, haga clic en Aceptar.
  4. Haga clic en Certificado de servidor en el sitio web de administración , elija asignar un certificado y, a continuación, seleccione un certificado de la lista.
  5. Asegúrese de que el puerto es 443.
  6. Intente conectarse al sitio web de administración a través de SSL (https://localmachine). No necesita el número de puerto del sitio porque SSL está escuchando en el puerto 443 ahora.
  7. No se puede mostrar el error de la página en el explorador.