La page ne peut pas être affichée lorsque vous vous connectez via SSL

Cet article vous aide à résoudre le problème où la page ne peut pas être affichée lorsque vous vous connectez via SSL.

Version du produit d’origine : Internet Information Services
Numéro de la base de connaissances d’origine : 260096

Symptômes

Lorsque vous vous connectez à un ordinateur exécutant Internet Information Services (IIS) à l’aide de SSL (Secure Socket Layer), le message d’erreur suivant peut se produire :

La page ne peut pas être affichée.
La page que vous recherchez est actuellement indisponible. Le site Web peut rencontrer des difficultés techniques ou vous devrez peut-être ajuster les paramètres de votre navigateur.

Ce site Web est généralement le deuxième site Web sur le serveur. La connexion au site Web via HTTP fonctionne correctement.

Cause

Ce message d’erreur peut se produire si le protocole SSL est défini sur le site web par défaut, que vous supprimez le certificat, puis que vous essayez de le configurer sur un deuxième site Web.

Si vous exécutez une netstat -an commande, vous pouvez voir qu’un service écoute sur le port 443, mais que vous ne pouvez pas vous y connecter. Cela est dû à une nouvelle implémentation dans IIS versions 5.0 et ultérieures appelée Pooling de sockets.

Résolution

Remarque

Pour les besoins de cet article, deux sites Web sont installés : le site Web par défaut et le site Web d’administration. Par défaut, SSL est activé sur le site web par défaut.

  1. Ouvrez les Security propriétés du site Web par défaut, puis sélectionnez Certificat de serveur.
  2. Dans l’Assistant, cliquez sur Attribuer un certificat existant, puis sélectionnez un certificat dans la liste.
  3. Une fois l’Assistant terminé, cliquez sur l’onglet Site web , puis sur Avancé.
  4. Supprimez toutes les entrées répertoriées dans la fenêtre SSL.
  5. Cliquez de nouveau sur Certificat de serveur , sur Supprimer le certificat actuel, puis sur OK.
  6. Cliquez avec le bouton droit sur le nom de l’ordinateur dans microsoft Management Console (MMC), puis cliquez sur Redémarrer IIS.

Vous devez maintenant être en mesure de vous connecter au serveur à l’aide de SSL.

Solution de contournement

Le redémarrage des services IIS peut résoudre le message d’erreur. Si ce n’est pas le cas, suivez les étapes décrites dans la section « Résolution » de cet article.

Plus d’informations

Une fois SSL activé sur un serveur web IIS, le service IIS commence à écouter toutes les adresses IP utilisées et inutilisées sur les ports 80 et 443. Pour les serveurs d’adresses IP multiples, vous pouvez désactiver cette fonctionnalité. Cette fonctionnalité a été ajoutée au produit pour un gain de performances.

Ce problème se produit généralement lorsque vous essayez de configurer SSL sur le site Web d’administration. IIS recherche les paramètres SSL pour le site Web par défaut et écoute sur le port 443. Toutefois, le site Web par défaut n’a pas de certificat pour correspondre à ce site. Par conséquent, aucune connexion ne peut être établie, c’est pourquoi vous pouvez voir un serveur à l’écoute sur le port 443, mais vous ne pouvez pas vous connecter au site.

Étapes pour reproduire ce comportement

  1. Sur un ordinateur disposant du site Web par défaut et du site web d’administration, créez un certificat, puis définissez-le sur le site Web par défaut. Laissez le port SSL sur 443.
  2. Cliquez sur l’onglet Sécurité dans les propriétés du site Web par défaut, puis cliquez sur Certificat de serveur.
  3. Cliquez sur Supprimer le certificat actuel, puis sur OK.
  4. Cliquez sur Certificat de serveur sur le site web d’administration , choisissez d’attribuer un certificat, puis sélectionnez un certificat dans la liste.
  5. Assurez-vous que le port est 443.
  6. Essayez de vous connecter au site web d’administration via SSL (https://localmachine). Vous n’avez pas besoin du numéro de port du site, car SSL est à l’écoute sur le port 443.
  7. L’erreur ne peut pas être affichée se produit dans le navigateur.