Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Tento článek se týká aplikace Microsoft Dynamics NAV ve všech zemích a všechna národní prostředí jazyka.

Příznaky

Při použití procedura poštu SMTP (400) v klientovi na míru rolím (RTC) v aplikaci Microsoft Dynamics NAV 2009 v prostředí třetí vrstvy e-mailové zprávy lze odesílat pouze když je vybrána anonymní ověřování v nastavení poštovního protokolu SMTP.
Však e-mailové zprávy lze odesílat pomocí libovolného typu ověřování v klasickém klientovi.
Poznámka: Při spuštění RTC v server hostící NAV služeb vrstvy (NST), procedura poštu SMTP (400) pracuje správně pomocí libovolného typu ověřování.
K tomuto problému dochází v následujících produktů:

  • Aplikace Microsoft Dynamics NAV 2009 R2

  • Aplikace Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)

Příčina

K tomuto problému dochází, protože identita klienta se liší v prostředích tři vrstvy. Proto ověřování problémy dojít v Microsoft Exchange Server.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix je nyní k dispozici od společnosti Microsoft. Však je určena pouze k odstranění problému popsaného v tomto článku. Použijte ji pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud jste závažně tento problém, doporučujeme počkat na další aktualizaci service pack produktu Microsoft Dynamics NAV 2009 nebo další verze produktu Microsoft Dynamics NAV, která obsahuje tuto opravu hotfix.

Poznámka: Ve zvláštních případech poplatky, které jsou třeba obvykle zaplatit za telefonní hovory mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft Dynamics a souvisejících produktů Určuje, že konkrétní aktualizace odstraní váš problém. Výdaje na technickou podporu použije dalších otázek a problémů, které nelze vyřešit konkrétní aktualizací.



Informace o instalaci

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo odvozené. To zahrnuje, ale není omezen pouze na předpokládané záruky obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou pomoci vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo vytvářet postupy podle vašich konkrétních požadavků.

Poznámka: Před instalací této opravy hotfix ověřte, že všichni uživatelé klienta Microsoft Navision odhlášeni systému. To zahrnuje uživatele klienta Microsoft Navision Application Services (NAS). Je třeba klienta pouze uživatel přihlášený při implementaci opravy hotfix.

Chcete-li implementovat tuto opravu hotfix, musí mít licenci vývojáře.

Doporučujeme, aby uživatelský účet v okně přihlášení systému Windows nebo v okně přihlášení databáze přidělí "SUPER" ID role. Pokud uživatelský účet nelze přiřadit ID role "SUPER", musíte ověřit, že uživatelský účet má následující oprávnění:

  • Změnit oprávnění pro objekt, který budete měnit.

  • Oprávnění ke spuštění pro System Object ID 5210 objekt a System Object ID 9015 objekt.



Poznámka: Nemáte práva k úložištím dat. Pokud nebudete provádět opravu dat.

Změny kódu

Poznámka: Vždy otestujte opravy kódu v kontrolovaném prostředí před instalací opravy v provozních počítačích.
Chcete-li vyřešit tento problém, změňte kód v procedura poštu SMTP (400). Po použití změny e-mailové zprávy bude vytvořen a odeslán z klienta namísto serveru. E-mailové zprávy budou proto zachovat identitu vykonávajícího uživatele.
Chcete-li to provést, postupujte takto:

  1. Implementovat a zaregistrovat sestavení Microsoft.Navision.Mail.dll v klientovi. Chcete-li to provést, spusťte následující příkaz:

    /tlb:Microsoft.Navision.Mail.tlb modul RegAsm / codebase Microsoft.Navision.Mail.dll

  2. Změňte kód v procedura poštu SMTP (400) takto:
    Existující kód

    ...PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail);
    Mail.FromName := SenderName;
    ...

    Změněný kód

    ...PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail,TRUE,TRUE);
    Mail.FromName := SenderName;
    ...

Předpoklady

Musí mít jednu z následujících produktů nainstalovali tuto opravu hotfix:

  • Aplikace Microsoft Dynamics NAV 2009 R2

  • Aplikace Microsoft Dynamics NAV 2009 Service Pack 1

Musí mít následující opravy hotfix:

  • 2499881 nastavení TLS pro SMTP komunikaci nelze konfigurovat v aplikaci Microsoft Dynamics NAV 2009

  • 2345735 nelze změnit výchozí port pro SMTP komunikaci v produktu Microsoft Dynamics NAV

  • 2479702 e-mailové zprávy je nesprávné při vytváření e-mailové zprávy pomocí metody AppendBody v aplikaci Microsoft Dynamics NAV 2009 Service Pack 1

  • 2280492 přílohy nejsou uvolněny, dokud není uzavřen klienta Microsoft Dynamics NAV při odesílání e-mailových zpráv s přílohami pomocí procedura poštu SMTP (400)

  • 2516144 přijímat poštu poškozených zpráv při použití určité verze 7 vydání Microsoft.Navision.Mail.dll soubor v aplikaci Microsoft Dynamics NAV 2009

Informace o odinstalaci

Tato oprava hotfix nelze odebrat.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Poznámka: Toto je článek "Rychlé publikování" vytvářen přímo v rámci odborné pomoci společnosti Microsoft. Informace obsažené v tomto dokumentu jsou poskytovány tak, jak je v reakci na vznikající problémy. V důsledku rychlosti v jeho zpřístupnění materiály, mohou obsahovat typografické chyby a mohou být upraveny kdykoli bez předchozího upozornění. Viz Podmínky použití pro další aspekty.

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×