Microsoft hesabıyla oturum açın
Oturum açın veya hesap oluşturun.
Merhaba,
Farklı bir hesap seçin.
Birden çok hesabınız var
Oturum açmak istediğiniz hesabı seçin.

Giriş

Active Directory etki alanı Hizmetleri (AD DS), Active Directory 'de oluşturulan kullanıcılara, bilgisayarlara, gruplara ve güvenlere benzersiz güvenlik tanımlayıcıları (SID 'Ler) atar. SID 'Ler, tek tonde artan bir göreli tanımlayıcıyla (RID) art arda eklenmiş bir etki alanı önekinden oluşur. Her Active Directory etki alanına, 1.000.000.000 RIDs 'den oluşan bir genel RID havuzu atanır. Her Active Directory etki alanı denetleyicisinin yeni güvenlik sorumlularını oluşturmasına olanak tanımak için, her etki alanı denetleyicisi, RID Yöneticisinden geçerli ve bekleme durumu RID havuzlarını tahsis edilir. Etki alanı için genel RID havuzu ve etki alanındaki tek tek etki alanı denetleyicilerindeki yerel havuzlar bittiğinde, ek kullanıcılar, bilgisayarlar ve gruplar artık etki alanında oluşturulamaz. Bu sorunu geçici olarak çözmek için, nesneleri ve uygulamaları oluşturabilir ve yeni bir etki alanına taşıyabilirsiniz. Bu makalede, bir mantık hatasının çok sayıda RID havuz isteğine neden olabileceği bir koşul açıklanmaktadır. Bu genel RID havuz tükenmesi

Belirtiler

Bazı ender durumlarda, Active Directory etki alanı denetleyicileri beklenmedik bir şekilde yüksek miktarda RID kaynağı tüketebilir. Bu davranış genel RID havuzunu durdurur. Bu sorun oluştuğunda, aşağıdaki sorunlardan biriyle veya birden çoğuyla karşılaşırsınız:

  • Genel RID havuzundaki RID 'Ler sürekli olarak tüketilmektedir.

  • Genel RID havuzunda tüketilen RIDs sayısı beklenenden büyük, bu da etki alanının kullanım süresi boyunca kasıtlı olarak oluşturulan güvenlik sorumlularının sayısını dikkate aldır.

  • DCDIAG RID Manager testi, rIDSetReferences özniteliğinin başarısız olduğunu gösterir. Ayrıca, aşağıdaki hata iletisini alırsınız:

    Test başlatma: başyönetici Uyarı: CN =ad, OU = etki alanı DENETLEYICILERI, DC =ad, DC =ad, DC =ad, DC =ad Rid kümesi başvurusu alınamadı: 8481 ile başarısız oldu: Arama, veritabanından öznitelikleri alamadı. ......................... ad başarısız oldu test eden Manager

KB 2618669 ' deki düzeltme, Windows Server 2008 R2 tabanlı etki alanı denetleyicilerinde bu davranışı algılayıp engellemeye olanak tanır.

Bu davranış, 

  • Windows Server 2019 ' den sonra yayınlanan işletim sistemi sürümleri

  • Windows Server 2019

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

Neden

Bazı ender durumlarda, bir etki alanı denetleyicisi, Global RID havuzundan her 30 saniyede bir, RIDs için yinelenen istekler verebilir. RID havuz güncelleştirmeleri için yinelemeli isteklerin önemli bir süre boyunca devam etmesine izin veriliyorsa, Global RID havuzu çok fazla RID tüketimine sahip olabilir. Olağanüstü durumlarda, Global RID havuzu tümüyle tükenebilir.

Çözüm

Genel RID havuzunda çok fazla RID kullanımını önleyecek şekilde, aşağıdaki eylemleri gerçekleştirmeniz önerilir:

  • Var olan tüm Windows Server 2008 R2 etki alanı denetleyicilerinde (Eylül 2016, KB3185278) sonrasına yayınlanan en son aylık güncelleştirmeyi yükleyin.

  • Güncelleştirmeyi Windows Server 2008 R2 yükleme medyasında tümleştirin. Bunu yaparak, gelecekteki etki alanı denetleyicilerinde bu güncelleştirmenin de bulunduğunu garanti edersiniz.

  • RTM sürümünde bu işlevselliği içeren daha yeni işletim sistemi sürümlerinde Active Directory rolünü dağıtın.

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft 'tan edinilebilir. Ancak bu düzeltmenin yalnızca bu makalede açıklanan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu makalede açıklanan sorunu yaşayan sistemlere uygulayın. Bu düzeltmeye ek sınama da gelebilir. Bu nedenle, bu sorundan ciddi bir şekilde etkilenmiyorsa, bu düzeltmeyi içeren bir sonraki yazılım güncelleştirmesini beklemenizi öneririz. Düzeltme indirilebilir durumdaysa, bu Bilgi Bankası makalesinin en üstünde "Düzeltme indirilebilir" bölümü vardır. Bu bölüm görüntülenmezse, düzeltmeyi edinmek için Microsoft Müşteri Hizmetleri ve destek 'e başvurun. Not Ek sorunlar oluşursa veya sorun giderme işlemleri gerekiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Bu belirli düzeltmeye uygun olmayan ek destek sorularına ve sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve destek telefon numaralarının tam listesi için veya ayrı bir hizmet isteği oluşturmak için aşağıdaki Microsoft Web sitesini ziyaret edin:

http://support.microsoft.com/contactus/?ws=support Not "Düzeltme indirilebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Dilinizi görmüyorsanız, bunun nedeni bu dilde bir düzeltme yoktur.

Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Ek Bilgi

Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için, Microsoft Bilgi Bankası 'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:

824684 Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması

Daha fazla yardıma mı ihtiyacınız var?

Daha fazla seçenek mi istiyorsunuz?

Abonelik avantajlarını keşfedin, eğitim kurslarına göz atın, cihazınızın güvenliğini nasıl sağlayacağınızı öğrenin ve daha fazlasını yapın.

Topluluklar, soru sormanıza ve soruları yanıtlamanıza, geri bildirimde bulunmanıza ve zengin bilgiye sahip uzmanlardan bilgi almanıza yardımcı olur.

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?
Gönder’e bastığınızda, geri bildiriminiz Microsoft ürün ve hizmetlerini geliştirmek için kullanılır. BT yöneticiniz bu verileri toplayabilecek. Gizlilik Bildirimi.

Geri bildiriminiz için teşekkürler!

×