Verze HTTP offline adresáře aplikace Outlook (OAB) se nestahuje

Příznaky

Pomocí aplikace Microsoft Outlook se můžete připojit k poštovní schránce Microsoft Exchange Server. Když spustíte ruční stahování offline adresáře (OAB) z umístění HTTP(S), indikátor průběhu, který se zobrazí v dialogovém okně Průběh odesílání a přijímání aplikace Outlook , se zdá, že se zablokuje nebo zablokuje. Stahování se nikdy nedokončí a místní soubory OAB se neaktualizují.

Příčina

Existuje několik známých příčin tohoto problému.

  • Bezdrátová zařízení v počítači mají zastaralé ovladače.

    K tomuto problému může dojít, pokud jsou nainstalovány staré nebo zastaralé ovladače zařízení pro bezdrátová periferní zařízení. To zahrnuje ovladače klávesnice a myši.

  • Zásady pro službu inteligentního přenosu na pozadí (BITS) jsou nakonfigurované na vašem počítači.

    Zásady SLUŽBY BITS umožňují řídit rychlost stahování aktualizací. Pokud hodnoty zásad nejsou správně nakonfigurované, můžou účinně zabránit dokončení stahování.

  • Služba inteligentního přenosu na pozadí není spuštěná.

    Pokud služba Inteligentní přenos na pozadí není spuštěná, OAB se nestáhne.

Řešení

Pokud chcete tento problém vyřešit, použijte jedno nebo více následujících řešení.

  • Aktualizace ovladačů zařízení pro bezdrátový hardware

    Připojte bezdrátový přijímač a podívejte se na služba Windows Update: Nejčastější dotazy ke kontrole aktualizací:

    Nainstalujte aktualizaci, která se zobrazí jako Volitelná aktualizace hardwaru a má následující název:

    Microsoft HID Non-User Input Data Filter

    Nebo nainstalujte nejnovější software IntelliPoint nebo IntelliType. Pokud to chcete udělat, podívejte se na článek Počítačové příslušenství, které pomáhá & učení.

    Pokud používáte klávesnici nebo myš jiného výrobce, navštivte web výrobce a stáhněte si nejnovější verzi ovladače zařízení nebo nejnovější aktualizaci zařízení.

  • Zkontrolujte, jestli v registru nedochází k nějakým zásadám BITS.

    Pokud používáte umístění HTTP, ze kterého chcete stáhnout OAB, proces stahování OAB zpracovává služba BITS. V této konfiguraci budete chtít zjistit, jestli máte nakonfigurované nějaké zásady BITS.

    Zásady služby BITS najdete v registru pod následujícím klíčem:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\BITS

    Pod tímto klíčem je možné nakonfigurovat následující hodnoty DWORD:

    EnableBitsMaxBandwidth
    MaxBandwidthValidFrom
    MaxBandwidthValidTo
    MaxTransferRateOnSchedule
    MaxTransferRateOffSchedule

    Pokud najdete EnableBitsMaxBandwith = 1, platí omezení stahování bits a ostatní hodnoty používá služba BITS ke správě stahování. Pokud chcete zjistit, jestli se tím problém se stahováním OAB nevyřeší, obraťte se na správce systému a zakažte omezování stahování BITS.

  • Ujistěte se, že je spuštěná služba inteligentního přenosu na pozadí.

    Pokud používáte umístění HTTP, ze kterého chcete stáhnout OAB, proces stahování OAB zpracovává služba BITS. V této konfiguraci budete chtít zajistit, aby byl spuštěn stav služby inteligentního přenosu na pozadí .

    1. V nabídce Start zadejte Services.msc do pole Prohledat programy a soubory a pak v podokně výsledků vyberte Services.msc .

    2. V dialogovém okně Služby vyhledejte službu s názvem Služba inteligentního přenosu na pozadí.

    3. Zkontrolujte stav služby. Ujistěte se, že je stav služby Spuštěno.

      Snímek obrazovky se stavem služby inteligentního přenosu na pozadí

      Pokud služba inteligentního přenosu na pozadí není spuštěná, pokračujte v těchto krocích a službu spusťte.

    4. V dialogovém okně Služby poklikejte na Služba inteligentního přenosu na pozadí.

    5. V rozevíracím seznamu Typ spouštění vyberte Automaticky (zpožděné spuštění) a pak vyberte Použít.

      Snímek obrazovky s možností automatického spuštění (zpožděné spuštění)

    6. Pak vyberte Spustit a spusťte službu.

    Můžete také zkontrolovat registr a zobrazit aktuální konfiguraci služby Inteligentní přenos na pozadí.

    Klíč: HKEY_LOCAL_MACHINE\system\currentcontrolset\Services\BITS
    DWORD: Start
    Hodnoty: 4 = Zakázáno, 3 = ruční, 2 = automatické

    Poznámka

    Neměňte stav služby prostřednictvím registru. Tyto informace jsou k dispozici pouze pro referenci.

Další informace

Pro Outlook 2010 a Outlook 2007 můžete pomocí následujícího postupu zjistit, jestli ke stažení OAB používáte umístění HTTP.

  1. Spusťte Aplikaci Outlook, pokud není aktuálně spuštěná.
  2. Podržte stisknutou klávesu CTRL , klikněte pravým tlačítkem myši na ikonu Outlooku v oznamovací oblasti na pravé straně hlavního panelu a pak vyberte Testovat automatickou konfiguraci e-mailu.
  3. Zrušte zaškrtnutí políčka Use Guessmart (Použít guessmart ) a potom zrušte zaškrtnutí políčka Secure Guessmart Authentication (Secure Guessmart Authentication ).
  4. Zaškrtněte políčko Použít automatickou konfiguraci .
  5. Pokud jste ji ještě nezadali, zadejte svoji e-mailovou adresu a heslo a pak vyberte Testovat.
  6. Na kartě Výsledky si poznamenejte cestu k adrese URL OAB.

Pokud hodnota adresy URL OAB začíná na HTTP, pak ke stažení OAB používáte umístění HTTP. Pokud je hodnota adresa URL OABVeřejné složky, pak ke stažení OAB nepoužíváte umístění HTTP.

Poznámka

Outlook 2016 a Outlook 2013 používají ke stažení OAB jenom umístění HTTP.