Problém
Když se uživatelé pokusí ověřit aplikaci, která nepatří do prohlížeče, do cloudové služby Microsoftu, jako je Microsoft 365, Microsoft Azure nebo Microsoft Intune z konkrétního klientského počítače, nastane jeden nebo víc z těchto problémů:
-
Správci se nemůžou k cloudové službě přihlásí pomocí následujících nástrojů pro správu:
– Nástroj Microsoft Azure Active Directory Sync (na serveru pro synchronizaci adresářů)
-Modul Microsoft Azure Active Directory pro Windows PowerShell (na počítači, na kterém je nainstalovaný)
-
Uživatelé se nemohou k cloudové službě přihlásí pomocí následujících bohatých klientských aplikací:
– Microsoft Outlook
– Microsoft Lync 2010
-Microsoft Office Professional Plus
-Aplikace systému Microsoft Office
Když se uživatelé pokusí získat přístup k portálu Cloud Service pomocí webového prohlížeče ze stejného počítače, můžou uživatelé zaznamenat některý z následujících příznaků:
-
Internet Explorer nemůže zobrazit webovou stránku.
-
Uživatel je před načtením webové stránky vyzván k zadání přihlašovacích údajů.
Při přístupu k cloudové službě z jiných počítačů pomocí stejných informací o uživatelských účtech nemají uživatelé tyto příznaky. Uživatelé můžou úspěšně získat přístup ke cloudové službě z jiných počítačů.
Příčina
Tento problém se obvykle vyskytuje v konkrétním klientském počítači nebo ve skupině klientských počítačů. Tento problém může nastat pro všechny klientské počítače pouze v případě, že pro cloudovou službu nejsou nastavené žádné počítače. Ověřování aplikace bez prohlížeče nemusí být plně funkční, pokud nastavení klienta cloudové služby není správně implementované.
Tento problém může způsobovat následující scénáře klientského počítače:
-
Síťové připojení ke cloudové službě je omezené.
-
Brána firewall, proxy servery nebo obojí vyžadují místní ověřování.
-
Nejsou splněné požadavky aplikace mimo prohlížeč.
-
Je nainstalovaná stará verze pomocníka pro přihlášení ke službám Microsoft Online Services.
-
Aplikace mimo prohlížeč není pro cloudovou službu nastavená.
Než budete tento problém řešit, zkontrolujte, že jsou splněné všechny následující podmínky:
-
Klávesnice na klávesnici klientského počítače funguje správně a uživatelské jméno a heslo byly zadány správně.
-
Ověřování aplikace mimo prohlížeč nefunguje pro stejný uživatelský účet v jiných klientských počítačích. Pokud se všechny ostatní počítače setkávají se stejnými příznaky pro stejný uživatelský účet, znamená to, že problém souvisí s uživatelským účtem. Další informace najdete v článku znalostní báze Microsoft Knowledge Base:
nemůžete se přihlásit k účtu organizace, jako je Microsoft 365, Azure nebo Intune . -
Problémy s přístupem nejsou omezeny na federované uživatele v klientském počítači. Pokud dochází k problémům s přístupem k jenom federovaným uživatelům, bude pravděpodobně problém s konfigurací jednotného přihlašování. Další informace najdete v následujících článcích znalostní báze Microsoft Knowledge Base:
přihlášení k Microsoft 365, Azure nebo Intune pomocí jednotného přihlašování na některých zařízeních nefunguje
, protože se neočekávaně zobrazuje přihlašovací údaje k pracovnímu nebo školnímu účtu.
řešení problémů s nastavením jednotného přihlašování v Microsoft 365, Intune nebo Azure
Řešení
Tip: Pokud chcete diagnostikovat a automaticky opravovat několik běžných problémů s přihlašováním k Office, můžete si stáhnout a spustit Pomocníka pro podporu a obnovení.
Pokud chcete tento problém vyřešit, použijte jednu nebo více následujících metod podle toho, jaká je Pravděpodobná příčina problému.
Řešení 1: připojení k síti je omezené.
Použijte prohlížeč a zkuste získat přístup k http://www.MSN.com. Pokud nemůžete získat přístup k tomuto webu, odstraňte problémy s připojením k síti.
-
Na příkazovém řádku můžete pomocí nástrojů ipconfig a ping řešit potíže s připojením IP. Další informace o tom, jak postupovat, najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
řešení potíží s základními problémy s protokolem TCP/IP -
Na příkazovém řádku spusťte nástroj nslookup www.MSN.com a zjistěte, zda DNS překládá názvy internetových serverů.
-
Ujistěte se, že nastavení serveru proxy v možnostech Internetu odráží příslušný proxy server, pokud je proxy server použit v místní síti.
-
Pokud je na hranici sítě nainstalována brána TMG (Forefront Threat Management Gateway) a brána firewall vyžaduje ověření klienta, bude možná potřeba nainstalovat a nakonfigurovat klientský program Forefront TMG na klientském zařízení pro přístup k Internetu. Požádejte o pomoc správce cloudové služby.
Řešení 2: brány firewall nebo proxy servery vyžadují další ověřování
Tento problém vyřešíte konfigurací výjimky pro Microsoft 365 adresy URL a aplikací z ověřovacího serveru proxy. Pokud jste třeba na serveru ISA (Microsoft Internet Security and Acceleration Server) 2006 vytvořit pravidlo Povolit, které splňuje následující kritéria:
-
Povolit odchozí připojení k následujícímu cíli: *. microsoftonline.com
-
Povolit odchozí připojení k následujícímu cíli: *. microsoftonline-p.com
-
Povolit odchozí připojení k následujícímu cíli: *. sharepoint.com
-
Povolit odchozí připojení k následujícímu cíli: *. outlook.com
-
Povolit odchozí připojení k následujícímu cíli: *. lync.com
-
Povolit odchozí připojení k následujícímu cíli: osub.microsoft.com
-
Porty 80/443
-
Protokoly TCP a HTTPS
-
Pravidlo musí platit pro všechny uživatele.
-
Časový limit HTTPS/SSL nastaven na 8 hodin
Řešení 3: nejsou splněné požadavky aplikace non-Browser nebo Pomocník pro přihlášení ke službám Microsoft Online Services je zastaralý
Pokud se některé operační systémy nebo aplikace, které nepoužívají prohlížeč, neaktualizují podle příslušných předpokladů, může se stát, že nebudou mít přístup k příslušným službám. Ujistěte se, že počítač a aplikace splňují požadavky na systém pro cloudovou službu. Další informace o požadavcích na systém Microsoft 365 získáte kliknutím sem:
Požadavky na systém pro Microsoft 365
Nejsnadnější způsob, jak zajistit, aby byl počítač správně aktualizován pro Microsoft 365 je spuštění nástroje pro nastavení plochy v Microsoft 365. Nainstalujte ho takto:
-
Ve webovém prohlížeči přejděte na https://Portal.Office.com, přihlaste se a v pravém podokně klikněte na Stáhnout .
-
Přejděte do dolní části stránky. V části nastavení a konfigurace desktopových aplikací Officeklikněte na Nastavenía potvrďte, že se zobrazí výzva ke spuštění nástroje Microsoft 365 nastavení plochy.
Nebo si můžete stáhnout a ručně nainstalovat požadované aktualizace a balíčky z následujícího webu Microsoftu:
Ruční instalace aktualizací desktopové aktualizace pro Microsoft 365
Řešení 4: aplikace, která není prohlížeč, není pro cloudovou službu nastavená
Pokud se u některých aplikací, které nejsou prohlížeče, nevytvořily profily, nebudou moct tyto aplikace správně přistupovat k určeným službám.
Nejsnadnější způsob, jak zajistit, aby byl počítač správně aktualizován pro Microsoft 365 je spuštění nástroje pro nastavení plochy v Microsoft 365. Nainstalujte ho takto:
-
Ve webovém prohlížeči přejděte na https://Portal.Office.com, přihlaste se a v pravém podokně klikněte na Stáhnout .
-
Přejděte do dolní části stránky. V části nastavení a konfigurace desktopových aplikací Officeklikněte na Nastavenía potvrďte, že se zobrazí výzva ke spuštění nástroje Microsoft 365 nastavení plochy.
Nebo si můžete stáhnout a ručně nainstalovat požadované aktualizace a balíčky z následujícího webu Microsoftu:
Ruční instalace aktualizací desktopové aktualizace pro Microsoft 365
Nebo můžete profily aplikací nastavit ručně.
Řešení 5: nemůžete se přihlásit pomocí Office 2016 nebo Office 2013 s moderním ověřováním na Surface pro 3
Tento problém byl opraven ve Windows 10 verze 1511. Tento problém vyřešíte instalací všech kumulativních aktualizací pro Windows 10 ze služby Windows Update. Nebo – minimale – nainstalujte kumulativní aktualizaci pro Windows 10:
Kumulativní aktualizace pro Windows 10 verze 1511:10.2015
Pokud nemůžete nainstalovat aktualizaci, postupujte takto:
Důležité: Postupujte opatrně. Pokud byste nesprávně změnili registr, mohlo by dojít k vážným problémům. Než ho změníte, postupujte podle těchto pokynů k zálohování registru pro obnovení v případě, že dojde k problémům.
-
Ve Windows 10 zadejte do vyhledávacího pole na hlavním panelu tlačítko regedit a stisknutím klávesy ENTER spusťte Editor registru.
-
Podle toho, jakou verzi Office používáte, proveďte jednu z následujících akcí:
-
Pokud máte Office 2016, odstraňte následující klíč registru:
HKEY_CURRENT_USER \software\microsoft\office\16.0\common\identity\identities -
Pokud máte Office 2013, odstraňte následující klíč registru:
HKEY_CURRENT_USER \software\microsoft\office\15.0\common\identity\identities
Další informace
Další informace o problémech s konkrétním neprohlížečovým aplikacím najdete v následujících článcích znalostní báze Microsoft Knowledge Base:
Potřebujete další pomoc? Přejděte na web komunity Microsoftu nebo na webu služby Azure Active Directory .