Yinelenen veya geçersiz öznitelikler Microsoft 365'te dizin eşitlemesini engelliyor

Belirtiler

Microsoft 365'te, dizin eşitlemesi tamamlandığında bir yönetici aşağıdaki e-posta iletisini alır:

From: [MSOnlineServicesTeam@MicrosoftOnline.com](mailto:msonlineservicesteam@microsoftonline.com)Subject: Directory Synchronization Error Report

E-posta iletisindeki hata raporu aşağıdaki hata iletilerinden birini veya daha fazlasını içerebilir:

  • Microsoft Online Services dizininizde aynı proxy adresine sahip eşitlenmiş bir nesne zaten var.
  • Kullanıcı kimliği bulunamadığından bu nesne güncelleştirilemiyor.
  • Bu nesneyle ilişkilendirilmiş aşağıdaki öznitelikler yerel dizininizdeki başka bir nesneyle zaten ilişkili olabilecek değerlere sahip olduğundan, Microsoft Online Services'da bu nesne güncelleştirilemiyor.
  • Bu nesneyle ilişkilendirilmiş aşağıdaki öznitelikler yerel dizin hizmetlerinizdeki başka bir nesneyle zaten ilişkili olabilecek değerlere sahip olduğundan bu nesne güncelleştirilemiyor: [UserPrincipalName john@contoso.com;]. Yerel dizininizdeki yinelenen değerleri düzeltin veya kaldırın.
  • Bu nesneyle ilişkilendirilmiş aşağıdaki öznitelikler yerel dizin hizmetlerinizdeki başka bir nesneyle zaten ilişkili olabilecek değerlere sahip olduğundan bu nesne güncelleştirilemiyor: [ProxyAddresses SMTP:john@contoso.com;]. Yerel dizininizdeki yinelenen değerleri düzeltin veya kaldırın.

Ayrıca, Microsoft Entra ID (Connect) Eşitleme Hizmeti çalıştırıyorsanız, uygulama oturum açma Olay Görüntüleyicisi aşağıdaki hata iletilerinden birini içeren bir olay kimliği 6941 örneği günlüğe kaydedilir:

Event ID: 6941
Log Name: Application
Source: ADSync
Level: Error
Details:
ECMA2 MA export run caused an error. 

Error Name: AttributeValueMustBeUnique
Error Detail: Unable to update this object because the following attributes associated with this object have values that may already be associated with another object in your local directory services: [UserPrincipalName john@contoso.com;]. Correct or remove the duplicate values in your local directory. Please refer to https://support.microsoft.com/kb/2647098 for more information on identifying objects with duplicate attribute values.
Event ID: 6941
Log Name: Application
Source: ADSync
Level: Error
Details:
ECMA2 MA export run caused an error.

Error Name: InvalidSoftMatch
Error Detail: Unable to update this object because the following attributes associated with this object have values that may already be associated with another object in your local directory services: [ProxyAddresses SMTP:john@contoso.com;]. Correct or remove the duplicate values in your local directory.

Neden

şirket içi Active Directory Etki Alanı Hizmetleri (AD DS) şemasındaki kullanıcı nesnelerinin yinelenen veya geçersiz diğer ad değerleri varsa ve bu kullanıcı nesneleri dizin eşitlemesi sırasında AD DS şemasından Microsoft 365'e doğru eşitlenmediyse bu sorun oluşabilir.

Microsoft 365'teki tüm diğer ad değerleri belirli bir kuruluş için benzersiz olmalıdır. Basit Posta Aktarım Protokolü (SMTP) adresinde at işaretinden (@) sonra birden çok benzersiz sonekiniz olsa bile, tüm diğer ad değerleri benzersiz olmalıdır.

Şirket içi ortamda, SMTP adresinde at işaretinden (@) sonra gelen sonekleri temel alarak benzersiz oldukları sürece aynı diğer ad değerlerine sahip olabilirsiniz.

Microsoft 365 için bulutta yinelenen diğer ad değerlerine sahip nesneler oluşturursanız, diğer adları benzersiz hale getirmek için, bir diğer adın sonuna benzersiz bir numara eklenir. (Örneğin, yinelenen diğer ad değerleri "Albert" ise, bunlardan biri otomatik olarak "Albert2" olur. "Albert2" zaten kullanılıyorsa, diğer ad "Albert3" olur ve bu şekilde devam eder.) Ancak, şirket içi AD DS'nizde yinelenen diğer ad değerlerine sahip nesneler oluşturulursa, dizin eşitlemesi çalıştırıldığında ve nesne eşitlemesi başarısız olduğunda nesne çakışması oluşur.

Çözüm

Bu sorunu çözmek için, diğer AD DS nesneleriyle çakışan yinelenen değerleri ve değerleri belirleyin. Bunu yapmak için aşağıdaki yöntemlerden birini kullanın.

Yöntem 1: IdFix Microsoft Entra Eşitleme Aracı Hata Düzeltme Aracı'nı kullanma

Yinelenen veya geçersiz öznitelikleri tanımlamak için IdFix Microsoft Entra Eşitleme Aracı Hata Düzeltme Aracı'nı kullanın. IdFix Aracı'nı kullanarak yinelenen öznitelikleri çözmek için aşağıdaki Microsoft Bilgi Bankası makalesine bakın:

idFix aracını çalıştırdıktan sonra iki veya daha fazla nesne için HATA sütununda 2857385 "Yinelenen" görüntüleniyor

Yöntem 2: Mevcut şirket içi kullanıcıyı Microsoft Entra bir kullanıcıyla eşleme

Bunu yapmak için aşağıdaki Microsoft Bilgi Bankası makalesine bakın:

2641663 Dizin eşitlemesi için şirket içi kullanıcı hesaplarını Microsoft 365 kullanıcı hesaplarıyla eşleştirmek için SMTP eşleştirmeyi kullanma

Yöntem 3: Dizin eşitlemesi aracılığıyla Microsoft Entra ID oluşturulmamış nesnelerin neden olduğu öznitelik çakışmalarını belirleme

Microsoft 365 yönetim araçları kullanılarak oluşturulan (ve dizin eşitlemesi aracılığıyla Microsoft Entra ID oluşturulmamış) kullanıcı nesnelerinin neden olduğu öznitelik çakışmalarını belirlemek için şu adımları izleyin:

  1. Şirket içi AD DS kullanıcı hesabının benzersiz özniteliklerini belirleyin. Bunu yapmak için, Windows Destek Araçları'nın yüklü olduğu bir bilgisayarda şu adımları izleyin:

    1. Başlat'a tıklayın, Çalıştır'a tıklayın, ldp.exe yazın ve tamam'a tıklayın.

    2. Bağlantı'ya tıklayın, Bağlan'a tıklayın, AD DS etki alanı denetleyicisinin bilgisayar adını yazın ve tamam'a tıklayın.

    3. Bağlantı'ya, Bağla'ya ve ardından Tamam'a tıklayın.

    4. Görünüm'e tıklayın, Ağaç Görünümü'ne tıklayın, BaseDN açılan listesinde AD DS etki alanını seçin ve ardından Tamam'a tıklayın.

    5. Gezinti bölmesinde, doğru eşitlenmemiş nesneyi bulup çift tıklatın. Pencerenin sağ tarafındaki Ayrıntılar bölmesi tüm nesne özniteliklerini listeler. Aşağıdaki örnekte nesne öznitelikleri gösterilmektedir:

      Nesne özniteliklerinin bir örneğini gösteren ekran görüntüsü.

    6. userPrincipalName özniteliğinin ve her SMTP adresinin değerlerini çok değerli proxyAddresses özniteliğine kaydedin. Bu değerlere daha sonra ihtiyacınız olacak.

      Öznitelik adı Örnek Notlar
      Proxyaddresses proxyAddresses (3): x500:/o=Exchange/ou=Exchange Yönetim Grubu (GroupName)/cn=Recipients/cn=GUID; smtp:7628376@service.contoso.com; SMTP:7628376@contoso.com; Öznitelik etiketinin yanında parantez içinde görüntülenen sayı, çok değerli öznitelikteki proxy adresi değerlerinin sayısını gösterir. Her ayrı proxy adresi değeri noktalı virgülle (;)) gösterilir. Birincil SMTP proxy adresi değeri büyük harf "SMTP:" ile gösterilir
      Userprincipalname 7628376@contoso.com

      Not

      Ldp.exe, Windows Server 2008'e ve Windows Server 2003 Destek Araçları'na dahildir. Windows Server 2003 Destek Araçları, Windows Server 2003 yükleme medyasında yer alır. Veya aracı edinmek için şu Microsoft web sitesine gidin: Windows Server 2003 Service Pack 2 32 bit Destek Araçları

  2. Windows PowerShell için Azure Active Directory modülünü kullanarak Microsoft 365'e bağlanın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'a tıklayın, Tüm Programlar'a tıklayın, Microsoft Entra ID'a tıklayın ve Windows PowerShell için Azure Active Directory modülü'ne tıklayın.

    2. Aşağıdaki komutları sunuldukları sırayla yazın ve her komutun ardından Enter tuşuna basın:

      $cred = get-credential
      

      Not

      İstendiğinde Microsoft 365 yönetici kimlik bilgilerinizi girin.

      Connect-MSOLService –credential $cred
      

      Not

      Azure AD ve MSOnline PowerShell modülleri 30 Mart 2024 itibarıyla kullanım dışı bırakılmıştır. Daha fazla bilgi edinmek için kullanımdan kaldırma güncelleştirmesini okuyun. Bu tarihten sonra bu modüllere yönelik destek, Microsoft Graph PowerShell SDK'sına geçiş yardımı ve güvenlik düzeltmeleriyle sınırlıdır. Kullanım dışı bırakılan modüller Mart 30 2025'e kadar çalışmaya devam edecektir.

      Microsoft Entra ID (eski adıyla Azure AD) ile etkileşime geçmek için Microsoft Graph PowerShell'e geçiş öneririz. Sık sorulan geçiş soruları için Bkz. Geçiş SSS. Not: MSOnline'ın 1.0.x sürümleri 30 Haziran 2024'den sonra kesintiye neden olabilir.

      Konsol penceresini açık bırakın. Sonraki adımda bunu kullanmanız gerekir.

  3. Microsoft 365'te yinelenen userPrincipalName özniteliklerini denetleyin.

    2. adımda açtığınız konsol bağlantısında, aşağıdaki komutları sunuldukları sırayla yazın ve her komutun ardından Enter tuşuna basın:

    $userUPN = "<search UPN>"
    

    Not

    Bu komutta, "search UPN" yer tutucusu 1f. adımda kaydettiğiniz UserPrincipalName özniteliğini temsil eder.

    get-msoluser –UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null}
    

    Konsol penceresini açık bırakın. Sonraki adımda yeniden kullanacaksınız.

  4. Yinelenen proxyAddressesattributes olup olmadığını denetleyin. 2. adımda açtığınız konsol bağlantısında, aşağıdaki komutları sunuldukları sırayla yazın ve her komutun ardından Enter tuşuna basın:

    $UserCredential = Get-Credential
    Connect-ExchangeOnline -Credential $UserCredential
    
  5. 1f. adımda kaydettiğiniz her proxy adresi girdisi için, aşağıdaki komutları sunuldukları sırayla yazın ve her komut sonrasında Enter tuşuna basın:

    $proxyAddress = "<search proxyAddress>"
    

    Not

    Bu komutta, "search proxyAddress" yer tutucusu, 1f. adımda kaydettiğiniz proxyAddresses özniteliğinin değerini temsil eder.

    Get-EXOMailbox | Where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) -eq $true} | foreach {get-MsolUser -ObjectID $_.ExternalDirectoryObjectId | Where {($_.LastDirSyncTime -eq $null)}}
    

3. ve 4. adımda komutları çalıştırdıktan sonra döndürülen öğeler, dizin eşitlemesi aracılığıyla oluşturulmamış ve doğru eşitlenmemiş nesneyle çakışan özniteliklere sahip kullanıcı nesnelerini temsil eder.

Çakışan veya geçersiz öznitelik değerlerini belirledikten sonra, aşağıdaki Microsoft Bilgi Bankası makalesindeki adımları izleyerek sorunu giderin:

2643629 Azure Active Directory Eşitleme aracı kullanıldığında bir veya daha fazla nesne eşitlenmiyor

Daha fazla bilgi

Bu makaledeki Windows PowerShell komutları, Windows PowerShell için Azure Active Directory modülünü gerektirir. Windows PowerShell için Azure Active Directory modülü hakkında daha fazla bilgi için aşağıdaki Microsoft web sitesine gidin:

Microsoft Entra Cmdlet'leri

Yine de yardım mı gerekiyor? Microsoft Community web sitesine gidin.