Problem mit dem ausstehenden Status bei der Verzeichnissynchronisierung für Microsoft 365, Azure oder Intune behoben

Problembeschreibung

Eines der folgenden Symptome treten in einem Microsoft-Clouddienst wie Microsoft 365, Microsoft Azure oder Microsoft Intune auf:

  • Wenn Sie die Verzeichnissynchronisierung im Microsoft 365 Admin Center aktivieren, gibt die Seite an, dass die Verzeichnissynchronisierung aktiviert ist. Wenn Sie jedoch das Azure Active Directory-Synchronisierungstool installieren und den Konfigurations-Assistenten ausführen, erhalten Sie die folgende Meldung:

    Error 15: DirSync not activated

    Anschließend rufen Sie die Seite Verzeichnissynchronisierung status erneut auf, um die Verzeichnissynchronisierungs-status anzuzeigen. Wenn Sie sich im mittleren Bereich unter 3: Active Directory-Synchronisierung ansehen, wird die folgende Meldung angezeigt:

    Active Directory synchronization is being activated

  • Wenn Sie die Verzeichnissynchronisierung auf der Seite Verzeichnissynchronisierung status des Microsoft 365-Portals deaktivieren, gibt die Seite an, dass die Verzeichnissynchronisierung aktiviert ist.

    Anschließend rufen Sie die Seite Verzeichnissynchronisierung status erneut auf, um die Verzeichnissynchronisierungs-status anzuzeigen. Wenn Sie sich im mittleren Bereich unter 3: Active Directory-Synchronisierung ansehen, wird die folgende Meldung angezeigt:

    Active Directory synchronization is being deactivated

Ursache

Dieses Problem kann auftreten, wenn die Verzeichnissynchronisierung nicht vollständig aktiviert oder deaktiviert ist. Es kann bis zu 72 Stunden dauern, bis die Aktivierung oder Deaktivierung abgeschlossen ist.

Hinweis

Azure AD- und MSOnline PowerShell-Module sind ab dem 30. März 2024 veraltet. Weitere Informationen finden Sie im Veralteten Update. Nach diesem Datum ist die Unterstützung für diese Module auf Migrationsunterstützung zum Microsoft Graph PowerShell SDK und Sicherheitskorrekturen beschränkt. Die veralteten Module funktionieren weiterhin bis zum 30. März 2025.

Es wird empfohlen, zu Microsoft Graph PowerShell zu migrieren, um mit Microsoft Entra ID (früher Azure AD) zu interagieren. Häufig gestellte Fragen zur Migration finden Sie in den häufig gestellten Fragen zur Migration. Hinweis: Version 1.0.x von MSOnline kann nach dem 30. Juni 2024 unterbrochen werden.

Führen Sie die folgenden Schritte aus, um zu ermitteln, ob die Verzeichnissynchronisierung aktiviert oder deaktiviert ist, indem Sie das Azure Active Directory-Modul für Windows PowerShell verwenden:

  1. Wählen Sie Start aus, geben Sie azure Active Directory-Modul für Windows PowerShell in das Suchfeld ein, und wählen Sie dann Azure Active Directory-Modul für Windows PowerShell aus.

  2. Geben Sie die folgenden Cmdlets in der Reihenfolge ein, in der sie dargestellt werden. Stellen Sie sicher, dass Sie die EINGABETASTE drücken, nachdem Sie die einzelnen Cmdlets eingegeben haben.

    • $cred = get-credential

      Hinweis

      Wenn Sie dazu aufgefordert werden, geben Sie ihre Anmeldeinformationen für den Clouddienstadministrator ein.

    • Connect-MSOLService -credential $cred

    • (Get-MSOLCompanyInformation).DirectorySynchronizationEnabled

      Hinweis

      Dieses Cmdlet gibt den Wert True oder False zurück. Wenn True zurückgegeben wird, wird die Verzeichnissynchronisierung aktiviert. Wenn false festgelegt ist, wird die Verzeichnissynchronisierung deaktiviert.

Fehlerbehebung

Warten Sie, bis die Verzeichnissynchronisierung aktiviert oder deaktiviert ist. Beachten Sie Folgendes:

Wenn die Verzeichnissynchronisierung nach der erwarteten Zeit nicht aktiviert oder deaktiviert wird, führen Sie die folgenden Schritte aus, und wenden Sie sich dann an Microsoft-Support:

  1. Geben Sie in derselben Windows PowerShell Konsole ein, die Sie in Schritt 2 des Abschnitts "Ursache" verwendet haben, das folgende Cmdlet ein, und drücken Sie dann die EINGABETASTE:

    (Get-MSOLCompanyInformation).DirectorySynchronizationStatus

    Hinweis

    Wenn die Ausgabe "PendingEnabled" oder "PendingDisabled" nach Ablauf der 24- oder 72-Stunden-Wartezeit angibt, ist dies ein bekanntes Problem, das sich auf Exchange Online auswirkt.

  2. Sammeln Sie die folgenden Informationen aus der Windows PowerShell Verbindung:

    • Kontext-ID: Um die Kontext-ID zu erfassen, geben Sie das folgende Cmdlet ein, und drücken Sie dann die EINGABETASTE:

      (Get-MSOLCompanyInformation).objectID

    • Dienst instance: Geben Sie das folgende Cmdlet ein, und drücken Sie dann die EINGABETASTE, um die Dienst-instance zu erfassen:

      (Get-MSOLCompanyInformation).AuthorizedServiceInstances

  3. Wenden Sie sich an Microsoft-Support.

Weitere Informationen

Weitere Informationen zum Aktivieren der Verzeichnissynchronisierung in Microsoft 365, Azure und Intune finden Sie unter Vorbereiten der Verzeichnissynchronisierung mit Microsoft 365.

Benötigen Sie weitere Hilfe? Besuchen Sie die Microsoft Community oder die Microsoft Entra Foren-Website.