Microsoft 365, Azure veya Intune için dizin eşitlemesiyle ilgili beklemedeki durum sorunu düzeltildi

Belirtiler

Microsoft 365, Microsoft Azure veya Microsoft Intune gibi bir Microsoft bulut hizmetinde aşağıdaki belirtilerden biriyle karşılaşırsınız:

Neden

Dizin eşitlemesi tamamen etkinleştirilmediyse veya devre dışı bırakılmıyorsa bu sorun oluşabilir. Etkinleştirme veya devre dışı bırakma işleminin tamamlanması 72 saat kadar sürebilir.

Not

Azure AD ve MSOnline PowerShell modülleri 30 Mart 2024 itibarıyla kullanım dışı bırakılmıştır. Daha fazla bilgi edinmek için kullanımdan kaldırma güncelleştirmesini okuyun. Bu tarihten sonra bu modüllere yönelik destek, Microsoft Graph PowerShell SDK'sına geçiş yardımı ve güvenlik düzeltmeleriyle sınırlıdır. Kullanım dışı bırakılan modüller Mart 30 2025'e kadar çalışmaya devam edecektir.

Microsoft Entra ID (eski adıyla Azure AD) ile etkileşime geçmek için Microsoft Graph PowerShell'e geçiş öneririz. Sık sorulan geçiş soruları için Bkz. Geçiş SSS. Not: MSOnline'ın 1.0.x sürümleri 30 Haziran 2024'den sonra kesintiye neden olabilir.

Dizin eşitlemesinin etkinleştirilip etkinleştirilmediğini veya devre dışı bırakıldığını belirlemek için Windows PowerShell için Azure Active Directory modülünü kullanarak şu adımları izleyin:

  1. Başlat'ı seçin, arama kutusuna Windows PowerShell için Azure Active Directory modülü yazın ve Windows PowerShell için Azure Active Directory modülü'nü seçin.

  2. Aşağıdaki cmdlet'leri sunuldukları sırayla yazın. Her cmdlet'i yazdıktan sonra Enter tuşuna bastığınıza emin olun.

    • $cred = get-credential

      Not

      İstendiğinde bulut hizmeti yöneticisi kimlik bilgilerinizi girin.

    • Connect-MSOLService -credential $cred

    • (Get-MSOLCompanyInformation).DirectorySynchronizationEnabled

      Not

      Bu cmdlet Doğru veya Yanlış değerini döndürür. True döndürürse dizin eşitlemesi etkinleştirilir. False ise dizin eşitleme devre dışı bırakılır.

Çözüm

Dizin eşitlemesi etkinleştirilene veya devre dışı bırakılana kadar bekleyin. Aşağıdakilere dikkat edin:

Dizin eşitlemesi beklenen süreden sonra etkinleştirilmediyse veya devre dışı bırakılmıyorsa şu adımları izleyin ve Microsoft Desteği başvurun:

  1. "Neden" bölümünün 2. adımında kullandığınız Windows PowerShell konsolunda aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

    (Get-MSOLCompanyInformation).DirectorySynchronizationStatus

    Not

    24 saat veya 72 saatlik bekleme süresi sona erdikten sonra çıkışta "PendingEnabled" veya "PendingDisabled" ifadesi gösteriliyorsa, bu Exchange Online etkileyen bilinen bir sorundur.

  2. Windows PowerShell bağlantısından aşağıdaki bilgileri toplayın:

    • Bağlam Kimliği: Bağlam kimliğini toplamak için aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

      (Get-MSOLCompanyInformation).objectID

    • Hizmet örneği: Hizmet örneğini toplamak için aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

      (Get-MSOLCompanyInformation).AuthorizedServiceInstances

  3. Microsoft Desteği başvurun.

Daha fazla bilgi

Microsoft 365, Azure ve Intune dizin eşitlemesini etkinleştirme hakkında daha fazla bilgi için bkz. Microsoft 365'e dizin eşitlemesi için hazırlanma.

Yine de yardım mı gerekiyor? Microsoft Topluluğu'na veya Microsoft Entra Forumları web sitesine gidin.