I messaggi di posta elettronica inviati dall'ambiente locale a Microsoft 365 mostrano indirizzi di posta elettronica non visualizzati in Da

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Nota

La configurazione guidata ibrida inclusa nel Exchange Management Console in Microsoft Exchange Server 2010 non è più supportata. Pertanto, non è più consigliabile usare la configurazione guidata ibrida precedente. Usare invece la procedura guidata configurazione ibrida di Microsoft 365 disponibile all'indirizzo https://aka.ms/HybridWizard. Per altre informazioni, vedere Configurazione guidata ibrida di Microsoft 365 per Exchange 2010.

Sintomi

Dopo la migrazione delle cassette postali dall'ambiente locale a Microsoft 365 in una distribuzione ibrida, il campo Da dei messaggi di posta elettronica inviati dall'ambiente locale a Microsoft 365 non visualizza i nomi visualizzati. Al contrario, nel campo Da vengono visualizzati gli indirizzi di posta elettronica.

Causa

Questo problema si verifica se la distribuzione ibrida è configurata in modo non corretto.

Per verificare che si stia verificando questo problema, esaminare l'intestazione di posta elettronica di un messaggio di posta elettronica inviato dall'account utente locale. In genere, X-MS-Exchange-Organization-AuthAs deve essere elencato come Interno. Se X-MS-Exchange-Organization-AuthAs è elencato come anonimo o se manca, indica una configurazione errata o una route di posta non corretta.

Risoluzione

Per correggere il problema, attenersi alla procedura seguente:

  1. Controllare il percorso della posta.

    La route più semplice è il server cassette postali di Exchange 2010 al server hub di Exchange 2010 (server ibrido) al connettore in ingresso Exchange Online Protection (EOP) per Exchange Online. Assicurarsi che non siano presenti dispositivi di rete non necessari, ad esempio dispositivi gateway antispam tra il server hub di Exchange 2010 (server ibrido) e EOP. Questi dispositivi potrebbero rimuovere l'intestazione necessaria.

  2. Controllare il dominio remoto del server Exchange locale. A tal fine, attenersi alla seguente procedura:

    1. In Exchange Management Shell eseguire il comando di PowerShell seguente:

      Get-RemoteDomain < NameOfService>.< DomainName>.com | FL
      

      Ad esempio:

      Get-RemoteDomain exchangedelegation.contoso.com | FL
      
    2. Nell'output verificare che gli TrustedMailOutboundEnabledattributi , TargetDeliveryDomaine IsInternal siano impostati su True.

    3. Se gli attributi nel passaggio 2b non sono impostati su True, usare il Set-RemoteDomain comando per modificare il valore in True.

  3. Controllare il dominio remoto in Microsoft 365. A tal fine, attenersi alla seguente procedura:

    1. Connettersi a Exchange Online tramite una sessione remota di PowerShell. Per altre informazioni su come eseguire questa operazione, vedere Connettersi a Exchange Online PowerShell.

    2. Eseguire il comando di PowerShell seguente:

      Get-RemoteDomain <FQDNOfOnPremisesEndConnector> | FL
      
    3. Nell'output verificare che l'attributo TrustedMailnboundEnabled sia impostato su True.

    4. Se l'attributo nel passaggio 3C non è impostato su True, usare il Set-RemoteDomain comando per modificare il valore in True.

  4. Assicurarsi che Transport Layer Security (TLS) sia implementato e abilitato in entrambi gli ambienti e che il nome di dominio completo (FQDN) sia impostato correttamente. Controllare il connettore di invio locale e il connettore in ingresso EOP usando Exchange Server Deployment Assistant in Exchange Deployment Assistant.

  5. Controllare il certificato di Exchange del connettore di invio nei server Exchange locali responsabili della distribuzione della posta elettronica a EOP. Il certificato di Exchange deve avere SMTP (Simple Mail Transfer Protocol) abilitato e deve corrispondere al nome di dominio completo del connettore di invio.

Se il problema persiste dopo aver seguito questi passaggi, contattare il supporto tecnico Microsoft 365.

Ulteriori informazioni

Ulteriore assistenza Visitare community Microsoft o forum TechNet di Exchange.