"Impossibile avviare l'applicazione. Contattare il fornitore dell'applicazione" quando si esegue l'installazione desktop di Microsoft 365

Problema

Quando si tenta di eseguire un'applicazione ClickOnce di Microsoft 365, ad esempio Installazione desktop Microsoft 365 o Microsoft 365 Desktop Readiness Tool, viene visualizzato il messaggio di errore seguente:

Impossibile avviare l'applicazione. Contattare il fornitore dell'applicazione.

Screenshot del messaggio di errore nella finestra di dialogo Non è possibile avviare l'applicazione.

Quando si fa clic su Dettagli, viene visualizzato un messaggio di errore dettagliato simile al seguente:

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of https://<NameOfDomain>/ClickOnceConnector/Office365DesktopSetup.application resulted in exception. Following failure messages were detected:
+ Unable to install this application because an application with the same identity is already installed. To install this application, either modify the manifest version for this application or uninstall the preexisting application.

Causa

Questo problema si verifica se l'applicazione è stata memorizzata nella cache dell'applicazione ClickOnce. L'applicazione deve essere rimossa dalla cache prima di poterla eseguire correttamente.

Soluzione

Per cancellare la cache dell'applicazione ClickOnce, seguire questa procedura:

  1. Fare clic su Start, selezionare Esegui, digitare cmd e fare clic su OK.
  2. Digitare il comando seguente e quindi premere INVIO: rundll32 dfshim CleanOnlineAppCache

Per verificare se il problema è stato risolto, seguire questa procedura:

Ulteriori informazioni

Per altre informazioni, vedere Informazioni di riferimento sull'API non gestita ClickOnce.

Ulteriore assistenza Passare al https://go.microsoft.com/fwlink/?linkid=2003907 sito Web.