Erreur « Impossible d’établir l’authentification mutuelle » lors de l’utilisation de l’Analyseur de connectivité à distance pour tester Outlook Anywhere dans Microsoft 365

Remarque

L’Assistant Configuration hybride inclus dans le console de gestion Exchange dans Microsoft Exchange Server 2010 n’est plus pris en charge. Par conséquent, vous ne devez plus utiliser l’ancien Assistant Configuration hybride. Utilisez plutôt l’Assistant Configuration hybride De Microsoft 365. Pour plus d’informations, consultez Assistant Configuration hybride Microsoft 365 pour Exchange 2010.

Symptômes

Remarque

Le scénario suivant s’applique uniquement aux clients Microsoft 365 qui disposent d’un déploiement hybride de Exchange Server et de Exchange Online locaux.

Lorsque vous utilisez l’outil Analyseur de connectivité à distance Microsoft pour tester la fonctionnalité Outlook Anywhere dans un environnement Microsoft 365, l’outil affiche le message d’erreur suivant :

L’authentification mutuelle n’a pas pu être établie.

En outre, un utilisateur peut rencontrer les symptômes suivants :

  • L’utilisateur est invité à entrer des informations d’identification à plusieurs reprises et ne peut pas se connecter à Exchange Online à l’aide d’Outlook Anywhere.

  • L’utilisateur reçoit le message d’erreur suivant lors de l’utilisation d’Outlook 2010 ou Outlook 2007 pour créer automatiquement le profil Outlook :

    Une connexion chiffrée à votre serveur de messagerie n’est pas disponible. Cliquez sur Suivant pour tenter d’utiliser une connexion non chiffrée.

Cause

Ce problème se produit si une ou plusieurs des conditions suivantes sont remplies :

  • Le nom commun ne correspond pas à la chaîne d’authentification mutuelle (msstd :) entrée dans l’outil Analyseur de connectivité à distance.
  • La chaîne d’authentification mutuelle est valide. Toutefois, l’attribut CertPrincipalName de l’objet EXPR OutlookProvider stocké dans Active Directory n’est pas valide.

Remarque

La chaîne d’authentification mutuelle équivaut au paramètre Se connecter uniquement aux serveurs proxy qui ont ce nom de principal dans leur certificat dans les paramètres de proxy Exchange dans Outlook.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Affichez le certificat de serveur web installé sur le serveur hybride et confirmez le nom commun auquel le certificat a été émis (par exemple, mail.contoso.com).

  2. Ouvrez les paramètres du proxy Exchange dans Outlook et case activée que le nom de domaine complet (FQDN) dans le champ Nom du principal d’authentification mutuelle est entré correctement (par exemple, msstd : mail.contoso.com).

  3. Si nécessaire, exécutez l’applet de commande suivante à l’aide d’Exchange Management Shell pour modifier l’attribut CertPrincipalName :

    Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.contoso.com"
    

Informations supplémentaires

L’outil Analyseur de connectivité à distance négocie une connexion SSL (Secure Sockets Layer) à l’hôte distant pour récupérer diverses propriétés sur les certificats X509. L’outil évalue l’attribut Subject pour identifier le nom de domaine complet ou le nom commun qui a été affecté au certificat (par exemple, mail.contoso.com).

Pour plus d’informations sur les noms des principaux, consultez Noms des principaux.

Pour plus d’informations sur les fournisseurs Outlook, consultez :

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