Erro "Não foi possível estabelecer a Autenticação Mútua" ao utilizar o Analisador de Conectividade Remota para testar o Outlook Em Qualquer Lugar no Microsoft 365

Nota

O assistente de Configuração Híbrida incluído no Consola de Gestão do Exchange no Microsoft Exchange Server 2010 já não é suportado. Por conseguinte, já não deve utilizar o antigo assistente de Configuração Híbrida. Em vez disso, utilize o assistente de Configuração Híbrida do Microsoft 365. Para obter mais informações, consulte Assistente de Configuração Híbrida do Microsoft 365 para o Exchange 2010.

Sintomas

Nota

O cenário seguinte aplica-se apenas aos clientes do Microsoft 365 que tenham uma implementação híbrida de Exchange Server e Exchange Online no local.

Quando utiliza a ferramenta Microsoft Remote Connectivity Analyzer para testar a funcionalidade Outlook Anywhere num ambiente do Microsoft 365, a ferramenta apresenta a seguinte mensagem de erro:

Não foi possível estabelecer a Autenticação Mútua.

Além disso, um utilizador pode deparar-se com os seguintes sintomas:

  • É pedido repetidamente ao utilizador as credenciais e não consegue ligar-se ao Exchange Online com o Outlook Anywhere.

  • O utilizador recebe a seguinte mensagem de erro ao utilizar o Outlook 2010 ou o Outlook 2007 para criar automaticamente o perfil do Outlook:

    Não está disponível uma ligação encriptada ao servidor de correio. Clique em Seguinte para tentar utilizar uma ligação não encriptada.

Causa

Este problema ocorre se uma ou mais das seguintes condições forem verdadeiras:

  • O nome comum não corresponde à cadeia de autenticação mútua (msstd:) introduzida na ferramenta Remote Connectivity Analyzer.
  • A cadeia de autenticação mútua é válida. No entanto, o CertPrincipalName atributo para o objeto EXPR OutlookProvider armazenado no Active Directory é inválido.

Nota

A cadeia de autenticação mútua equivale à ligação Apenas a servidores proxy que têm este nome principal na respetiva definição de certificado nas definições de proxy do Exchange no Outlook.

Resolução

Para resolver este problema, siga estes passos:

  1. Veja o certificado de servidor Web instalado no servidor híbrido e confirme o nome comum para o qual o certificado foi emitido (por exemplo, mail.contoso.com).

  2. Abra as definições de proxy do Exchange no Outlook e verifique se o nome de domínio completamente qualificado (FQDN) no campo Nome Principal de Autenticação Mútua foi introduzido corretamente (por exemplo, msstd: mail.contoso.com).

  3. Se for necessário, execute o seguinte cmdlet com a Shell de Gestão do Exchange para alterar o CertPrincipalName atributo :

    Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.contoso.com"
    

Mais informações

A ferramenta Remote Connectivity Analyzer negoceia uma ligação SSL (Secure Sockets Layer) ao anfitrião remoto para obter várias propriedades em certificados X509. A ferramenta avalia o Subject atributo para identificar o FQDN ou o nome comum que foi atribuído ao certificado (por exemplo, mail.contoso.com).

Para obter mais informações sobre os nomes principais, veja Nomes Principais.

Para obter mais informações sobre os fornecedores do Outlook, consulte:

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