メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。
英語
申し訳ございません。この記事は、ご利用の言語では用意されていません。

Microsoft distributes Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) fixes as one downloadable file. Because the fixes are cumulative, each new release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2008 R2 Service Pack 1 (SP1) fix release.

Symptoms

When you start SQL Server 2008 R2 or SQL Server 2008 SP3, or when a client sends a request to the program, one of the following errors is logged in the SQL Server error log.

Error 1

Date Time,Server,Unknown,IO Completion Listener (0xb34) Worker 0x000000000CA181A0 appears to be non-yielding on Node 3. Approx CPU Used: kernel 0 ms<c/> user 0 ms<c/> Interval: 14999.

Error 2

Date Time ,Server,Unknown,* Non-yielding IOCP Listener
Date Time ,Server,Unknown,*
Date Time ,Server,Unknown,* Date Time spid spid
Date Time ,Server,Unknown,* BEGIN STACK DUMP:


Additionally, the application may stop responding.

Note This is a SQL Server issue. This issue does not depend on the operating system that the server is running. However, this issue is known to occur when the following conditions are true:

  • The updates that are described in the following Microsoft Knowledge Base article are installed on the computer that is running SQL Server:

    2491214 "Non-yielding Scheduler" error and SQL Server 2008 or SQL Server 2008 R2 stops responding intermittently in Windows Server 2008 or in Windows Server 2008 R2

  • The update that is described in the following Microsoft Knowledge Base article is not installed on the computer that is running SQL Server:

    2398202 An application may stop responding when the application closes a socket connection or shuts down



Cause

This issue is caused by unexpected Winsock behavior that occurs in SQL Server 2008 R2 and SQL Server 2008.

Resolution

Cumulative update information

SQL Server 2008 Service Pack 3

The fix for this issue was first released in Cumulative Update 7 for SQL Server 2008 Service Pack 3. For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2738350 Cumulative Update package 7 for SQL Server 2008 Service Pack 3Note Because the builds are cumulative, each new fix release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2008 Service Pack 3 fix release. We recommend that you consider applying the most recent fix release that contains this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2629969 The SQL Server 2008 builds that were released after SQL Server 2008 Service Pack 3 was released

SQL Server 2008 R2 Service Pack 1


The fix for this issue was first released in Cumulative Update 7. For more information about how to obtain this cumulative update package for SQL Server 2008 R2 SP1, click the following article number to view the article in the Microsoft Knowledge Base:

2703282 Cumulative update package 7 for SQL Server 2008 R2 Service Pack 1Note Because the builds are cumulative, each new fix release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2008 R2 SP1 fix release. We recommend that you consider applying the most recent fix release that contains this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2567616 The SQL Server 2008 R2 builds that were released after SQL Server 2008 R2 Service Pack 1 was released

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.


If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.


Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have SQL Server 2008 R2 SP1 installed.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.


File name

File version

File size

Date

Time

Platform

Sqlservr.exe

2009.100.2814.0

43,083,176

12-May-2012

09:30

x86

Sqlservr.exe

2009.100.2814.0

62,173,608

12-May-2012

09:41

x64

Sqlservr.exe

2009.100.2814.0

122,146,720

12-May-2012

09:33

IA-64


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

ヘルプを表示

その他のオプションが必要ですか?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

この情報は役に立ちましたか?

どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×