SQL Server 2012'de yinelenen batch etiketi değeri kullanıldığında MDS varlık tabanlı hazırlama başarısız olabilir

Bu makale, SQL Server 2012'de yinelenen batch etiketi değeri kullanıldığında Ana Veri Hizmetleri (MDS) varlık tabanlı hazırlamanın başarısız olması sorununu çözmenize yardımcı olur.

Orijinal ürün sürümü: SQL Server 2012
Özgün KB numarası: 2712547

Belirtiler

Aşağıdaki senaryoyu inceleyin:

  • Verileri MDS'ye aktarmak için Microsoft SQL Server 2012 MDS varlık tabanlı hazırlama işlemini kullanırsınız.

  • Toplu işlemi tanımlamak için sütunu kullanarak BatchTag çeşitli MDS hazırlama tablolarını (stg.name) hazırlama verileriyle doldurursunuz.

  • Farklı bir MDS modelindeki farklı bir varlığa ait ayrı bir hazırlama tablosunu doldurmak için aynı BatchTag değeri kullanırsınız.

  • Toplu işlemeyi başlatmak için gerekli saklı yordamları çalıştırırsınız. Veya hazırlama toplu işlemini MDS web sitesindeki Integration Management işlevsel alanından başlatabilirsiniz.

Hazırlama işlemini başlattığınızda, üç saklı yordamdan birini kullanırsınız:

  • stg.udp_name_Leaf

  • stg.udp_name_Consolidated

  • stg.udp_name_Relationship

Not

<Ad> yer tutucusu, varlık oluşturulduğunda belirtilen hazırlama tablosunun adıdır.

Aşağıdaki örneklerde hazırlama saklı yordamı kullanılarak hazırlama işleminin nasıl başlatileceği gösterilir:

  • exec mds.stg.udp_entityname1 'versionAdescription',0,'batchtag'

  • exec mds.stg.udp_entityname2 'versionBdescription',0,'batchtag'

Bu senaryoda, hazırlama işlemini başlattığınızda aşağıdaki hata iletisini alırsınız:

MDSERR310029
Belirtilen toplu iş durumu geçerli değil.

Ayrıca, toplu iş durumunu denetlediğinizde, değeri olan BatchTag toplu işlemin süresiz olarak Çalışıyor durumunda takılı kaldığını fark edeceksiniz.

Not

MDS web sitesinden , Tümleştirme Yönetimi'ne tıklayıp modeli seçerek durumu görüntüleyerek veya tabloyu sorgulayarak [mdm].[tblStgBatch] toplu iş durumunu denetleyebilirsiniz.

Neden

MDS varlık tabanlı hazırlama işlemi MDS modeline bakılmaksızın durumu denetlediğinden BatchTag bu sorun oluşur.

Çözüm

Toplu işleminiz Çalışıyor durumunda takıldıysa toplu işlemi durdurun ve toplu işlemi yeniden işlemeyi deneyin. Toplu işlemi durdurmak için SQL deyimini çalıştırın: Exec [mdm].[udpStagingBatchQueueActivate] Bu sorunu çözmek için kayıtların hazırlama tablosundaki BatchTag değerini yeni bir adla güncelleştirin. Ayrıca, alanın kayıtlar için 0 olarak ayarlandığından emin olunimportstatus_ID.

Daha fazla bilgi

Hazırlama işlemini başlatma hakkında daha fazla bilgi için aşağıdaki web sitesine gidin: