Um serviço do System Center pode não começar depois de aplicar a atualização 2677070

Este artigo corrige um problema no qual o serviço system center data access ou o serviço de Configuração de Gerenciamento do System Center não é iniciado depois que você aplica 2677070 de atualização.

Versão original do produto: Microsoft System Center 2012 Operations Manager, System Center 2012 Service Manager, Microsoft System Center Service Manager 2010
Número de KB original: 2730040

Sintomas

Depois de aplicar a atualização 2677070, o serviço System Center Data Access ou o serviço de Configuração de Gerenciamento do System Center podem não começar com um erro de tempo limite.

Além disso, depois de abrir o console Service Manager, o seguinte erro pode ser exibido:

No momento, o servidor de gerenciamento de Data Warehouse de relatórios não está disponível. Você não poderá exibir relatórios ou administrar o Data Warehouse até que este servidor esteja disponível. Entre em contato com o administrador do sistema. Depois que o servidor ficar disponível, feche o console e abra novamente para se conectar.

Motivo

Esse problema ocorre porque o sistema não pode recuperar CTLs (listas de confiança de certificado confiável e não confiável). Se o sistema não tiver acesso a Windows Update, seja porque o sistema não está conectado à Internet ou porque Windows Update é bloqueado por regras de firewall, a rede de recuperação de tempo limite antes que o serviço possa continuar seu procedimento de inicialização. Em alguns casos, esse tempo limite de recuperação de rede pode exceder o tempo limite de inicialização do serviço de 30 segundos. Se um serviço não puder relatar essa inicialização concluída após 30 segundos, o gerenciador de controle de serviço interromperá o serviço.

As URLs para atualizar a CTL foram alteradas com esta atualização. Portanto, se as URLs anteriores foram codificadas como exceções no firewall ou proxy ou se não houver acesso à Internet no computador, a CTL não poderá ser atualizada.

Solução alternativa 1

Validar que firewalls de limite, regras de acesso de roteador ou servidores proxy downstream habilitam sistemas que têm 2677070 de atualização instalados para entrar em contato com o Microsoft Update. Para obter mais informações sobre esse requisito, consulte Um atualizador automático de certificados revogados está disponível para Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2. (Isso inclui as URLs que a atualização CTL acessa.)

Solução alternativa 2

Altere as configurações de Política de Grupo. Para fazer isso, siga estas etapas:

  1. No nó Configuração do Computador no Política de Grupo Editor Local, clique duas vezes em Políticas.
  2. Clique duas vezes em Configurações do Windows, clique duas vezes em Configurações de Segurança e clique duas vezes em Políticas de Chave Pública.
  3. No painel de detalhes, clique duas vezes em Configurações de Validação do Caminho do Certificado.
  4. Selecione a guia Recuperação de Rede, selecione a caixa Definir essas configurações de política marcar e desmarque os certificados de atualização automática na caixa marcar programa de certificado raiz da Microsoft (recomendado).
  5. Selecione OK e feche o Política de Grupo Editor Local.

Solução alternativa 3

Modifique o registro. Para fazer isso, execute as etapas a seguir.

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

  1. Clique em Iniciar, Clique em Executar, digite regedit na caixa Abrir e clique em OK.

  2. Localize e selecione a seguinte subchave de Registro:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\SystemCertificates

  3. Clique com o botão AuthRootdireito do mouse, selecione Novo e, em seguida, selecione DWORD.

  4. Digite DisableRootAutoUpdate e pressione Enter.

  5. Clique com o botão DisableRootAutoUpdatedireito do mouse e selecione Modificar.

  6. Na caixa Dados do valor, digite 1 e clique em OK.

  7. No menu Arquivo, clique em Sair.

Solução alternativa 4

Aumente o tempo limite de serviço padrão.

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

  1. Clique em Iniciar, clique em Executar, digite regedit na caixa Abrir e clique em OK.

  2. Localize e selecione a seguinte subchave de Registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

  3. Clique com o botão direito do mouse em Controle, aponte para Novo e selecione DWORD.

  4. Na caixa Novo Valor , digite ServicesPipeTimeoute pressione Enter.

  5. Clique com o botão ServicesPipeTimeoutdireito do mouse e selecione Modificar.

  6. Clique em Decimal, digite o número de milissegundos que você deseja aguardar até o tempo limite do serviço e clique em OK.

    Por exemplo, para aguardar 60 segundos antes do tempo limite do serviço, digite 60000.

  7. No menu Arquivo , clique em Sair e reinicie o computador.

Solução alternativa 5

Desbloqueie as URLs atualizadas no firewall ou proxy ou desabilite a verificação de CRL para o serviço de Acesso a Dados e o serviço de Configuração de Gerenciamento.

Para baixar as CTLs mais recentes, use as seguintes URLs atualizadas:

Abra um dos seguintes arquivos em um editor de texto:

  • Para o serviço de Acesso a Dados: Microsoft.Mom.Sdk.ServiceHost.exe.config
  • Para o serviço configuração de gerenciamento: Microsoft.Mom.ConfigServiceHost.exe.config (em Service Manager) ou cshost.exe.config (no Operations Manager)

Para desabilitar a verificação de CRL, adicione a seguinte linha na <seção runtime> :

<generatePublisherEvidence enabled="false"/>

O exemplo a seguir mostra essa marca sendo adicionada para o System Center 2012 Operations Manager no arquivo Cshost.exe.config.

<runtime>
<generatePublisherEvidence enabled="false"/>  
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Microsoft.EnterpriseManagement.HealthService" publicKeyToken="31bf3856ad364e35" />
<publisherPolicy apply="no" />
<bindingRedirect oldVersion="6.0.4900.0" newVersion="7.0.5000.0" />
</dependentAssembly>
<publisherPolicy apply="no" />
<probing privatePath="" />
</assemblyBinding>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Microsoft.Mom.Common" publicKeyToken="31bf3856ad364e35" />
<publisherPolicy apply="no" />
<bindingRedirect oldVersion="6.0.4900.0" newVersion="7.0.5000.0" />
</dependentAssembly>
<publisherPolicy apply="no" />
<probing privatePath="" />
</assemblyBinding>
<gcServer enabled="true"/>
</runtime>

O exemplo a seguir mostra a mesma marca adicionada no arquivo de configuração do System Center Operations Manager 2007 R2 (Microsoft.Mom.Sdk.ServiceHost.exe.config):

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<runtime>
<generatePublisherEvidence enabled="false"/>  
<gcServer enabled="true"/>
</runtime>

Os dois arquivos *.config podem ser encontrados nos seguintes diretórios:

  • System Center Service Manager 2010:%ProgramFiles%\System Center Service Manager 2010
  • SystemCenter 2012 Operations Manager: %ProgramFiles%\System Center 2012\Operations Manager\Server
  • System Center 2012 Service Manager:%ProgramFiles%\System Center 2012\Service Manager