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Symptômes

Dans Microsoft Outlook 2016 pour Mac ou Office pour Mac 2011, vous recevez un message « Aucun résultat » lorsque vous essayez de rechercher un message électronique ou d’appliquer un filtre à un dossier, et les éléments de tâche ne sont pas affichés dans le dossier Tâches. En outre, lorsque vous recherchez des éléments de courrier à l’aide de la recherche Spotlight native de Mac OS, votre recherche échoue.

Cause

Ce problème peut se produire pour l’une des raisons suivantes :


Microsoft Outlook 2016 pour Mac :

  • L’indexation de la recherche Spotlight est incomplète.

  • Le nom du profil contient des caractères spéciaux tels que la barre oblique (/).

  • Le profil ou l’un de ses dossiers parents sont ajoutés à l’onglet Confidentialité dans Spotlight.

  • Le dossier Profils Outlook 15 ne se trouve pas sous ~/Library/Group Containers/UBF8T346G9. Office/Outlook.

  • L’index De recherche Spotlight est endommagé.



Microsoft Outlook pour Mac 2011 :

  • L’indexation de la recherche Spotlight est incomplète.

  • Le nom de l’identité contient des caractères spéciaux tels que la barre oblique (/).

  • L’identité ou l’un de ses dossiers parents sont ajoutés à l’onglet Confidentialité dans Spotlight.

  • Le dossier Données utilisateur Microsoft ne se trouve pas sous le dossier ~/Documents.

  • L’index De recherche Spotlight est endommagé.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Exécutez l’utilitaire OutlookSearchRepair .

  2. Si vous avez récemment créé un profil Outlook dans Outlook 2016 pour Mac ou une nouvelle identité dans Outlook pour Mac 2011, ajouté un nouveau compte ou si vous avez récemment importé de nouvelles données à partir d’une source telle qu’un fichier PST ou OLM, l’indexation Spotlight peut ne pas être terminée. Dans ce cas, Outlook pour Mac affiche un message « Aucun résultat ». Pour résoudre ce problème, attendez la fin de l’indexation, puis recherchez à nouveau.

  3. Assurez-vous que le nom de votre profil dans Outlook 2016 pour Mac ou votre nom d’identité dans Outlook pour Mac 2011 ne comporte pas de caractères spéciaux, tels que la barre oblique (/). 
    Pour afficher votre nom de profil ou d’identité :

    Outlook 2016 pour Mac :

    1. Cliquez sur Accéder, Applications.

    2. Right-Click Microsoft Outlook, puis sélectionnez Afficher le contenu du package.

    3. Développez Contenu, SharedSupport, puis ouvrez le Gestionnaire de profils Outlook.


    Note Vous pouvez créer un alias pour le Gestionnaire de profils Outlook et le déplacer vers votre bureau ou un autre emplacement pratique si vous préférez.

    Outlook pour Mac 2011 :

    Pour afficher vos noms d’identité dans l’utilitaire de base de données Microsoft, maintenez la touche Option enfoncée, puis cliquez sur l’icône Outlook pour Mac 2011.

  4. Si le nom du profil ou de l’identité contient un caractère spécial, procédez comme suit pour modifier le nom :

    1. Ouvrez le dossier Outlook 2016 pour Mac Profile ou Outlook pour Mac 2011 Identity.

      Dans Outlook 2016 pour Mac, l’emplacement est :
      /Users/<Nom d’utilisateur>/Library/Group Containers/UBF8T346G9. Profils Office/Outlook/Outlook 15/

      Dans Outlook pour Mac 2011, l’emplacement est :
      Utilisateurs/<nom d’utilisateur>/Documents/Données utilisateur Microsoft/Identités Office 2011/

    2. Renommez le nom du dossier profil Outlook 2016 pour Mac ou le nom du dossier d’identité Outlook pour Mac 2011 qui contient des caractères spéciaux en supprimant les caractères spéciaux.

    3. Vérifiez que le nom du profil ou de l’identité a été modifié en l’affichant de la manière suivante en fonction de votre version de Outlook pour Mac :


      Dans Outlook 2016 pour Mac :

      1. Cliquez sur Accéder, Applications.

      2. Right-Click Microsoft Outlook, puis sélectionnez Afficher le contenu du package.

      3. Développez Contenu, SharedSupport, puis ouvrez le Gestionnaire de profils Outlook.


      Note Vous pouvez créer un alias pour le Gestionnaire de profils Outlook et le déplacer vers votre bureau ou un autre emplacement pratique si vous préférez.

      En Outlook pour Mac 2011 :

      Ouvrez l’utilitaire de base de données Microsoft en maintenant la touche Option enfoncée, puis en cliquant sur l’icône Outlook pour Mac 2011.

    4. Si nécessaire, sélectionnez le profil ou l’identité dont le nom a été modifié, cliquez sur l’icône d’engrenage, puis cliquez sur Définir par défaut.

  5. Vérifiez dans Mac OS que le dossier Profil ou Identité Outlook ou l’un de ses dossiers parents n’est pas ajouté à l’onglet Confidentialité dans Spotlight. Si votre dossier profils Outlook 2016 pour Mac, votre dossier d’identité Outlook pour Mac 2011 ou l’un de leurs dossiers parents s’affiche dans cet onglet, Spotlight n’indexe pas cet emplacement de dossier. Supprimez ces emplacements de l’onglet Confidentialité dans Spotlight et laissez le temps à ces emplacements de terminer l’indexation.

  6. Vérifiez que les données de profil Outlook 2016 pour Mac ou d’identité Outlook pour Mac 2011 sont stockées sous l’emplacement par défaut approprié.

    Outlook 2016 pour Mac : assurez-vous que le dossier Profils Outlook 15 est stocké sous ~/Library/Group Containers/UBF8T346G9. Dossier Office/Outlook.

    Outlook pour Mac 2011 : assurez-vous que le dossier Données utilisateur Microsoft est stocké sous le dossier ~/Documents.

  7. Si le problème n’est toujours pas résolu, l’index Spotlight peut être endommagé. Pour réindexer l’index Spotlight, procédez comme suit :

    1. Redémarrez le Mac afin qu’il redémarre les services Spotlight.

    2. Accédez à Finder > Applications > Utilitaires > Terminal.

    3. Tapez mdimport -L.

    4. Important : si vous voyez plusieurs instances de « Microsoft Outlook Spotlight Importer.mdimporter », supprimez l’application Outlook que vous n’utilisez pas , videz-la de la Corbeille, redémarrez votre Mac et revenez à l’étape 1.

    5. Dans le Terminal, réindexez votre base de données Outlook à l’aide de la commande suivante et en remplaçant votre propre nom d’utilisateur par le <user_name> espace réservé :

      mdimport -g « /Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter » -d1 « /Users/<user_name>/Library/Group Containers/UBF8T346G9. Profils Office/Outlook/Outlook 15/<my_profile_name>.Remarque

      Dans cette commande, le chemin après « -g » est le chemin d’accès par défaut de l’installation d’Outlook.  Le chemin après « -d1 » est le chemin d’accès par défaut de votre profil, où <my_profile_name> est , par défaut « Profil principal ». Vous devrez remplacer vos chemins d’accès réels si vous avez renommé votre profil ou installé Outlook dans un autre emplacement.

    6. La réindexation prend un certain temps. Une fois le processus terminé, quittez, puis redémarrez Outlook.

Si vous ne pouvez toujours pas effectuer de recherche dans Spotlight après avoir suivi ces étapes et si vous avez accordé suffisamment de temps pour que l’indexation Spotlight soit terminée, vous devrez peut-être désinstaller Office pour Mac et le réinstaller. Pour plus d’informations sur la procédure à suivre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft : 

2398768 Comment supprimer complètement Office pour Mac 2011

Informations supplémentaires

Lorsque vous effectuez une recherche dans Outlook 2016 pour Mac ou Outlook pour Mac 2011 sur Mac OS X, tenez compte des éléments suivants :

  • Mac OS inclut la recherche Spotlight. Mac OS contrôle l’indexation du disque dur pour la recherche Spotlight.

  • Les deux versions de Outlook pour Mac s’appuient sur La recherche Spotlight pour fournir des résultats de recherche pour les données Outlook.

  • Les filtres dans Outlook pour Mac s’appuient également sur La recherche Spotlight pour fournir des résultats de recherche.

  • Les tâches dans Outlook pour Mac sont affichées à l’aide de filtres. Ces filtres s’appuient sur la recherche Spotlight.

  • L’indexation à la une peut prendre plusieurs minutes lorsque de nouvelles données sont introduites. Par exemple, cela peut se produire lors de la réception de nouveaux messages électroniques.

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