No se puede acceder a un buzón mediante Outlook después de que un buzón remoto se mueva de un entorno de Exchange Server local a Microsoft 365

Síntomas

Después de mover el buzón de un usuario de un entorno de Microsoft Exchange Server local a Microsoft 365, el usuario no puede acceder al buzón mediante Microsoft Outlook. Sin embargo, el usuario puede acceder al buzón mediante Outlook Web App.

Además, es posible que vea un mensaje de error en el Consola de administración de Exchange similar al siguiente después del traslado del buzón remoto con error:

<Fecha><y hora> [] <Fecha><y hora> [] No se pudo convertir el buzón de origen "Primary (00000000-0000-0000-0000-00000000000)" al usuario habilitado para correo después del traslado. Intente 6/6. Error: UpdateMovedMailboxPermanentException.

Causa

Este problema puede producirse si deshabilita la herencia de permisos en el usuario de destino en el esquema de Active Directory local.

Por lo tanto, aunque el buzón local del usuario está marcado como movido en Exchange Server, no se convierte en un buzón de usuario remoto como se esperaba. El buzón local del usuario continúa con la inclusión de un usuario habilitado para buzones de correo habitual.

Solución

Para resolver este problema, siga estos pasos:

  1. Identifique todas las propiedades de usuario en el buzón de correo y, a continuación, guarde esta información en un archivo de texto. Para ello, abra el Shell de administración de Exchange y ejecute el siguiente comando:

    Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt
    
  2. Deshabilite el buzón local del usuario. Para ello, use uno de los métodos siguientes:

    • Use el Consola de administración de Exchange para deshabilitar el buzón local del usuario.
    • Use el Shell de administración de Exchange para deshabilitar el buzón local del usuario. Para ello, ejecute el siguiente comando del Shell de administración de Exchange:
    Disable-Mailbox <UserMailbox>
    

    Para obtener más información sobre este cmdlet, vea Deshabilitar un buzón de correo.

  3. Convierta el buzón local del usuario en un buzón de usuario remoto. Para ello, ejecute el siguiente cmdlet del Shell de administración de Exchange:

    Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>
    
  4. Una vez aprovisionado el buzón remoto, modifique los atributos de buzón personalizados (por ejemplo, el legacyExchangeDN atributo) que desee y que no se hayan asignado mediante una directiva de dirección de correo electrónico a la cuenta de usuario.

Más información

Nota:

En Microsoft Exchange 2010, un buzón remoto consta de un usuario habilitado para correo que existe en el Active Directory local y un buzón asociado que existe en el servicio basado en la nube.

Para obtener más información sobre los cmdlets que se mencionan en este artículo, consulte:

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