Non è possibile accedere a una cassetta postale usando Outlook dopo lo spostamento di una cassetta postale remota da un ambiente Exchange Server locale a Microsoft 365

Sintomi

Dopo aver spostato la cassetta postale di un utente da un ambiente Microsoft Exchange Server locale a Microsoft 365, l'utente non può accedere alla cassetta postale usando Microsoft Outlook. Tuttavia, l'utente può accedere alla cassetta postale usando Outlook Web App.

Inoltre, è possibile che venga visualizzato un messaggio di errore nel Exchange Management Console simile al seguente dopo lo spostamento remoto della cassetta postale non riuscita:

<Data><e> ora [] <Ora>>< [] Impossibile convertire la cassetta postale di origine 'Primary (000000000-0000-0000-0000-00000000000000)' all'utente abilitato alla posta elettronica dopo lo spostamento. Tentativo 6/6. Errore: UpdateMovedMailboxPermanentException.

Causa

Questo problema può verificarsi se si disabilita l'ereditarietà delle autorizzazioni per l'utente di destinazione nello schema Active Directory locale.

Pertanto, anche se la cassetta postale locale dell'utente è contrassegnata come spostata in Exchange Server, non viene convertita in una cassetta postale utente remota come previsto. La cassetta postale locale dell'utente continua a includere un normale utente abilitato per le cassette postali.

Risoluzione

Per risolvere il problema, seguire la procedura seguente:

  1. Identificare tutte le proprietà utente nella cassetta postale e quindi salvare queste informazioni in un file di testo. A tale scopo, aprire Exchange Management Shell ed eseguire il comando seguente:

    Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt
    
  2. Disabilitare la cassetta postale locale dell'utente. A tale scopo, usare uno dei metodi seguenti:

    • Usare il Exchange Management Console per disabilitare la cassetta postale locale dell'utente.
    • Utilizzare Exchange Management Shell per disabilitare la cassetta postale locale dell'utente. A tale scopo, eseguire il comando di Exchange Management Shell seguente:
    Disable-Mailbox <UserMailbox>
    

    Per altre informazioni su questo cmdlet, vedere Disabilitare una cassetta postale.

  3. Convertire la cassetta postale locale dell'utente in una cassetta postale utente remota. A tale scopo, eseguire il cmdlet di Exchange Management Shell seguente:

    Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>
    
  4. Dopo aver effettuato il provisioning della cassetta postale remota, modificare tutti gli attributi della cassetta postale personalizzati (ad esempio, l'attributo legacyExchangeDN ) desiderati e che non sono stati assegnati dall'indirizzo di posta elettronica all'account utente.

Ulteriori informazioni

Nota

In Microsoft Exchange 2010 una cassetta postale remota è costituita da un utente abilitato alla posta elettronica presente nel Active Directory locale e da una cassetta postale associata presente nel servizio basato sul cloud.

Per altre informazioni sui cmdlet menzionati in questo articolo, vedere:

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