Problemas de desempenho do Outlook num ficheiro .ost ou .pst do Modo Exchange em Cache

Número original da BDC: 2768656

Sintomas

No Microsoft Outlook, pode deparar-se com sintomas como:

  • Quando utiliza o Modo Exchange em Cache ou um ficheiro de dados do Outlook (.pst), nota um desempenho reduzido quando efetua determinadas ações.
  • Se as pastas Caixa de Entrada, Calendário, Tarefas, Itens Enviados ou Itens Eliminados do Outlook contiverem muitos itens, o desempenho será reduzido.
  • O desempenho do calendário é inconsistente. Por exemplo, as atualizações de reuniões podem não ser refletidas no calendário principal, partilhado ou delegado.
  • As pastas demoram muito tempo a aparecer ou não aparecem corretamente.
  • Se o seu perfil do Outlook contiver caixas de correio partilhadas e tiver a colocação em cache ativada (Transferir Pastas Partilhadas estiver selecionada), irá deparar-se com problemas de sincronização de pastas, desempenho reduzido ou outros problemas se o número de pastas partilhadas por caixa de correio exceder os 500. Para obter mais informações, consulte Problemas de desempenho e sincronização quando trabalha com pastas numa caixa de correio secundária no Outlook. Além disso, os erros são registados na pasta Problemas de Sincronização e os eventos "9646" são registados no Registo de aplicações.
  • Em casos extremos em que existem mais de 10 000 pastas, o Outlook é muito lento a abrir. Este comportamento ocorre devido ao tempo necessário para enumerar o grande número de pastas.

Causa

Estes problemas podem ocorrer se uma caixa de correio contiver muitas pastas ou se existirem muitos itens numa pasta. Não existe um limite restritivo para quantas pastas uma caixa de correio pode conter ou quantos itens uma pasta pode conter. No entanto, poderá ter um desempenho reduzido à medida que o número de itens se aproxima dos 10 000 itens de calendário, 10 000 pastas ou 100 000 itens de correio por pasta. Um grande número de reuniões periódicas ou reuniões periódicas de longa duração também podem ter um efeito exagerado no desempenho.

Resolução

Para corrigir problemas de desempenho que afetam o seu Calendário, Correio ou pastas partilhadas, utilize as seguintes resoluções, conforme adequado.

Resoluções para problemas do Calendário

Para corrigir problemas de desempenho que afetam o seu Calendário, experimente os seguintes métodos.

Método 1: Gerir o crescimento de exceções para reuniões periódicas

Nem todos os itens de calendário têm um efeito igual no desempenho. As reuniões únicas têm um efeito relativamente pequeno e as reuniões periódicas de longa duração têm um efeito maior. Uma alteração efetuada numa instância de uma reunião periódica cria exceções armazenadas na série de reuniões periódica. Cada alteração aos atributos da reunião, como o assunto, corpo, localização ou hora, cria uma exceção correspondente. Eventualmente, estas exceções inflacionam o tamanho da reunião periódica e impõem um maior custo de desempenho. Pode mitigar este custo mais elevado ao utilizar as definições de Periodicidade do Compromisso para definir uma hora de fim ou uma contagem máxima de periodicidade. Em seguida, pode criar uma nova reunião periódica em vez de prolongar a periodicidade existente.

Método 2: Ativar melhorias no calendário partilhado

Utilize a opção Ativar melhoramentos do calendário partilhado para os utilizadores que têm permissões de edição para um calendário partilhado para melhorar o desempenho. Quando ativa esta opção, as ações do calendário são enviadas diretamente para o servidor em vez de terem de ser sincronizadas a partir do armazenamento local. Isto torna a resolução de conflitos mais eficiente.

Para obter mais informações sobre como ativar e gerir os melhoramentos do calendário partilhado, consulte Como ativar e desativar as atualizações de partilha do calendário do Outlook

Método 3: Limitar a janela Sincronização

Pode limitar a janela de sincronização utilizada para pastas de calendário para reduzir o número de itens armazenados localmente nas suas pastas de calendário. Fazê-lo pode melhorar o desempenho.

Importante

Siga cuidadosamente os passos indicados nesta secção. Poderão ocorrer problemas graves se modificar o registo de forma incorreta. Antes de o modificar, faça uma cópia de segurança do registo para restauro caso ocorram problemas.

Em Definições da Janela de Sincronização, ajuste o número de meses de dados sincronizados para os calendários partilhados principais. Para fazer isto, crie a chave de registo seguinte.

Nota: este método aplica-se à Versão 1810 ou a uma versão posterior do Microsoft 365 Apps para Grandes Empresas (Clique-e-Use).

Descrição Definição para ativar a janela Sincronização de Calendários
Caminho do registo HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowSetting
Tipo REG_DWORD
Valor Valor = 0 Inativo
Valor = 1 pasta Calendário Principal
Valor = 2 Todas as pastas do Calendário
A predefinição é 0 se não estiver definida.
Descrição Definição para controlar o número de meses na janela Sincronização do Calendário
Caminho do registo HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowSettingMonths
Tipo REG_DWORD
Valor Valor = Selecione um valor decimal para definir o número de meses na janela de sincronização do Calendário. Por exemplo, selecione 1, 3, 6 ou 12.
A predefinição é 6 se não estiver definida.
Descrição Definição para controlar se deve manter todos os itens periódicos em vez de os filtrar
Caminho do registo HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name CalendarSyncWindowAllRecurring
Tipo REG_DWORD
Valor Valor = 0: apenas as séries de reuniões periódicas que tenham uma data de fim no futuro ou que se insoram na definição atual da janela de sincronização do calendário serão sincronizadas.
Valor = 1: todas as séries de reuniões periódicas serão sincronizadas, independentemente da data de fim.
A predefinição é 0 se não estiver definida.
Explicação Por predefinição (se o valor não estiver definido ou estiver definido como 0), serão sincronizados os conjuntos de reuniões periódicas com uma data de fim futura ou dentro da definição da janela de sincronização do calendário atual. Por exemplo, se a data de hoje for 3 de maio de 2022 e a janela de sincronização do calendário estiver definida para 1 mês, todas as séries de reuniões periódicas que têm uma data de fim no dia 3 de abril de 2022 serão sincronizados. Se a data de fim estiver fora da definição da janela de sincronização, a série de reuniões periódica será removida do ficheiro .ost.
Para sincronização de todas as séries de reuniões periódicas independentemente da data de fim, defina o valor CalendarSyncWindowAllRecurring para 1.

Estas chaves de registo atualizam a restrição de sincronização para que o cliente que está a utilizar o Modo Exchange em Cache transfira menos itens de Calendário, mesmo para um Calendário com vários anos de histórico no servidor. Estas chaves não limpam os conteúdos mais antigos do Calendário que já foram transferidos. No entanto, este método pode ser eficaz se estiver disposto a limpar itens offline e a voltar a sincronizar o seu Calendário (em vez de eliminar itens antigos em volume). Se já tiver o Calendário no perfil, tem de limpar os Itens Offline depois de definir as chaves de registo e reiniciar o Outlook.

Para limpar os itens de Calendário offline, siga estes passos:

  1. Abra o painel Calendário no Outlook e clique com o botão direito do rato na pasta Calendário .
  2. Selecione Propriedades.
  3. No separador Geral, selecione Limpar Itens Offline.
  4. Selecione OK.

Resoluções para problemas de Correio

Se tiver pastas cujo conteúdo esteja a aproximar-se do limite de 10 000 itens de calendário, 10 000 pastas ou 100 000 itens de correio e estes itens estiverem armazenados num ficheiro de dados do Outlook (.pst) ou num ficheiro de dados offline do Outlook (.ost), mova itens das pastas maiores para pastas separadas ou mais pequenas na mesma caixa de correio ou ficheiro de dados. Opcionalmente, se tiver um arquivo online do Microsoft Exchange, pode mover itens para esse arquivo ou criar políticas de retenção para eliminar automaticamente itens mais antigos.

Arquivar itens de Correio

Se tiver ativado a Caixa de Correio de Arquivo Online, arquive os itens na Caixa de Correio de Arquivo Online.

Aplicar uma política de retenção

Para eliminar itens mais antigos da pasta Correio ou Calendário, aplique uma política de retenção. Por exemplo, qualquer item que não seja modificado no prazo de um ano é movido para a pasta Itens Eliminados.

Resolução de problemas de Pastas Partilhadas

Para corrigir problemas de desempenho que afetam as pastas partilhadas, experimente o seguinte método.

Limitar a janela Sincronizar

Para reduzir o número de itens armazenados localmente, limite a janela de sincronização utilizada para pastas partilhadas. Fazê-lo pode melhorar o desempenho.

Importante

Siga cuidadosamente os passos indicados nesta secção. Poderão ocorrer problemas graves se modificar o registo de forma incorreta. Antes de o modificar, faça uma cópia de segurança do registo para restauro caso ocorram problemas.

Para ajustar o número de dias de dados sincronizados para pastas partilhadas, adicione os seguintes valores de registo.

Descrição Definição para ativar a janela Pastas Partilhadas
Caminho do registo HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Name SharedFolderSyncWindowSettingDays
Tipo REG_DWORD
Valor Valor = Selecione um valor decimal para definir o número de dias (1-365) para a janela de sincronização de pastas partilhadas.

Executar Suporte da Microsoft e o Assistente de Recuperação

Nota

Suporte da Microsoft e os cenários do Assistente de Recuperação não estão disponíveis para o novo Outlook para Windows.

Pode utilizar Suporte da Microsoft e o Assistente de Recuperação para diagnosticar problemas de Calendário e Correio que afetam o Outlook. Para transferir e instalar o Assistente, consulte About Suporte da Microsoft and Recovery Assistant (Acerca de Suporte da Microsoft e Assistente de Recuperação).

Para determinar a causa dos problemas de desempenho, inicie o Assistente e execute o Diagnóstico do Outlook na secção Diagnóstico Avançado .

Mais informações

Para ver a contagem de itens num Calendário do Outlook quando utiliza o Modo Exchange em Cache, utilize a caixa de diálogo Propriedades do Calendário:

  1. No Outlook, abra o painel Calendário e, em seguida, clique com o botão direito do rato na pasta Calendário .
  2. Selecione Propriedades.
  3. No separador Geral, selecione Mostrar o número total de itens.
  4. Selecione o separador Sincronização.
  5. Veja a contagem em Ver estatísticas para esta pasta.

O Outlook utiliza um ficheiro .ost apenas se a conta de e-mail do Exchange estiver configurada para utilizar o Modo Exchange em Cache. Se o Outlook estiver configurado para ligar à caixa de correio do Exchange no modo Online, não será utilizado um .ost ficheiro.

Se o seu cliente do Outlook estiver ligado ao Exchange no modo Online e não tiver pastas de contagem elevada de itens num ficheiro .pst, quaisquer problemas de desempenho que possa estar a ocorrer no servidor. Para obter mais informações, consulte Poderá ocorrer pausas na aplicação se tiver um ficheiro de dados do Outlook grande.