Nie można nawiązać połączenia z usługą Azure Information Protection przy użyciu Windows PowerShell

Uwaga

Usługa Microsoft Azure Information Protection była wcześniej znana jako Usługa Microsoft Azure Rights Management.

W tym artykule rozwiązano problem polegający na tym, że nie można nawiązać połączenia z usługą Azure Information Protection Service przy użyciu Windows PowerShell w Office 365.

Oryginalna wersja produktu: Tożsamość Microsoft Entra, Azure Information Protection
Oryginalny numer KB: 2797755

Symptomy

Podczas próby nawiązania połączenia z usługą Microsoft Azure Information Protection przy użyciu Windows PowerShell w Microsoft Office 365 zostanie wyświetlony komunikat o błędzie podobny do następującego:

PS C:\> Connect-AipService

Connect-AipService : The attempt to connect to the Azure Information Protection service failed. Verify that the user name and password you are using are correct and try again. If you have continued problems, see http://go.microsoft.com/fwlink/?LinkId=251909.

The correlation ID is 1df4c755-f859-4284-907b-be5d2a551260. Please note and provide this value if asked by support for it.

At line:1 char:1

+ Connect-AipService

+ ~~~~~~~~~~~~~~~~~~

+ CategoryInfo : NotSpecified: (:) [Connect-AipService], ApplicationFailedException

+ FullyQualifiedErrorId : NotSpecified,Microsoft.RightsManagementServices.Online.Admin.PowerShell.ConnectAipServiceCommand

Może również zostać wyświetlony następujący komunikat o błędzie:

Odwołanie do obiektu nie zostało ustawione na wystąpienie obiektu.

Przyczyna

Ten problem występuje, jeśli spełniony jest co najmniej jeden z następujących warunków:

  • Wprowadzono nieprawidłową nazwę użytkownika lub hasło.
  • Nie jesteś administratorem firmy.
  • Nie masz subskrypcji obejmującej usługę Azure Information Protection.
  • Sieć uniemożliwia nawiązywanie połączenia z usługą Azure Information Protection.
  • Używasz Windows PowerShell 7. Użycie programu PowerShell 7 spowoduje błąd "Odwołanie do obiektu nie jest ustawione na wystąpienie obiektu". Aby uzyskać więcej informacji, zobacz Znane problemy — Azure Information Protection.

Rozwiązanie

Uwaga

Jeśli usługa Azure Information Protection nie jest włączona dla Twojej firmy, użyj Centrum administracyjne platformy Microsoft 365, aby ją włączyć. Aby uzyskać więcej informacji o tym, jak to zrobić, przeczytaj plan wdrożenia usługi Azure Information Protection.

Aby rozwiązać ten problem, upewnij się, że są spełnione następujące warunki:

  • Upewnij się, że wprowadzono poprawną nazwę użytkownika i hasło. Aby sprawdzić, czy zostały wprowadzone poprawnie, zaloguj się do portalu Office 365.
  • Aby nawiązać połączenie z usługą Azure Information Protection, musisz być administratorem globalnym.
  • Aby korzystać z usługi Azure Information Protection, musisz mieć subskrypcję obejmującą usługę Azure Information Protection.
  • Skontaktuj się z administratorem sieci, aby upewnić się, że sieć spełnia wymagania dotyczące nawiązywania połączenia z usługą Azure Information Protection. Wymagania są następujące:
    • Połączenia przychodzące i wychodzące do *.aadrm.com są włączone.
    • Połączenia przychodzące i wychodzące z (*.cloudapp.netrmsoprod*-b-rms*.cloudapp.net) są włączone.
    • Port 443 jest otwarty.
  • Użyj Windows PowerShell 5. Wersję programu PowerShell można sprawdzić za pomocą $PSVersionTable.PSVersion polecenia .

Więcej informacji

Aby uzyskać więcej informacji na temat usługi Azure Information Protection, odwiedź stronę AIPService.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.