Une erreur s’affiche dans un rapport de synchronisation d’annuaires : cette société a dépassé le nombre d’objets pouvant être synchronisés

Cet article explique comment augmenter le quota du service d’annuaire Active Directory pour la synchronisation d’annuaires dans un environnement Office 365, Azure ou Microsoft Intune.

Version du produit d’origine : Services cloud (rôles Web/Rôles de travail), Microsoft Entra ID, Microsoft Intune, Sauvegarde Azure, Office 365 Gestion des utilisateurs et des domaines
Numéro de la base de connaissances d’origine : 2812409

Symptômes

Vous recevez un message électronique de MSOnlineServicesTeam@MicrosoftOnline.com qui contient le message d’erreur suivant :

Erreur 016 : La synchronisation a été arrêtée. Cette société a dépassé le nombre d’objets pouvant être synchronisés. Contactez le support Microsoft Online Services.

Remarque

Cet article peut également être utilisé si vous souhaitez simplement demander d’augmenter le quota du service d’annuaire au cas où vous envisagez d’avoir plus que le nombre autorisé d’objets dans un service cloud Microsoft, tel que Office 365, Azure ou Microsoft Intune, et que vous n’utilisez pas la synchronisation Active Directory. Le quota de service d’annuaire actuel dans Microsoft Entra ID est de 50 000 objets.

Cause

Ce problème se produit parce que le nombre d’objets que vous avez créés dans votre Microsoft Entra ID dépasser la limite de votre service d’annuaire. Microsoft Entra ID limite le nombre d’objets pouvant être créés par chaque organization. Les groupes, les contacts et les objets utilisateur dans votre Microsoft Entra organization sont comptabilisés dans le cadre de l’utilisation de l’annuaire de votre organization.

Votre quota de service d’annuaire par défaut est calculé selon les instructions suivantes :

  • Si vous n’avez aucun domaine vérifié, le quota de service d’annuaire actuel dans Microsoft Entra ID est de 50 000 objets.

    1. Si votre organization a été créé avant le 5 octobre 2011, votre quota de service d’annuaire par défaut est de 10 000 objets.
    2. Si votre organization a été créé après le 5 octobre 2011 et avant mai 2012, votre quota de service d’annuaire par défaut est de 20 000 objets.
    3. Si votre organization a été créé après mai 2012, votre quota de service d’annuaire par défaut est de 50 000 objets.
  • Si vous avez au moins un domaine vérifié, le quota de service d’annuaire par défaut dans Microsoft Entra ID est de 300 000 objets.

Résolution

Lorsque le nombre de groupes, de contacts et d’objets utilisateur dans votre Active Directory local dépasse le quota de votre service d’annuaire, vous pouvez demander une augmentation de la limite de quota de service d’annuaire pour votre entreprise. Cette augmentation vous permet de synchroniser plus d’objets que la limite par défaut actuelle lorsque vous utilisez la synchronisation d’annuaires.

Pour continuer à créer des objets dans votre organization, vous devez ajouter un domaine ou demander une augmentation du quota de votre service d’annuaire. Pour ce faire, utilisez les méthodes suivantes.

Méthode 1

Si vous n’avez pas de domaine vérifié, vous devez ajouter un domaine pour augmenter votre limite de quota à 300 000 objets. Pour plus d’informations, consultez Ajouter votre domaine.

Méthode 2

Si vous avez plus de 300 000 objets dans votre service d’annuaire Active Directory local, pour augmenter le nombre d’objets pouvant être synchronisés au-delà de 300 000, contactez Support Microsoft.

Informations supplémentaires

Un quota de service d’annuaire est implémenté à l’aide du service cloud comme méthode pour limiter le nombre maximal d’objets qui peuvent être créés et détenus par un seul principal de sécurité. Tous les objets synchronisés à l’aide de la synchronisation d’annuaires avec une entreprise ont la valeur créateur/propriétaire définie sur le groupe administrateurs par défaut pour cette société. Par exemple, le groupe administrateurs est défini comme suit : admins@contoso1.microsoftonline.com. Par conséquent, cette configuration empêche les utilisateurs de créer un nombre illimité d’objets à l’aide de la synchronisation d’annuaires. Si une entreprise a un besoin légitime de synchroniser plus que la limite de quota du service d’annuaire, envoyez une demande de service au support technique.

Foire aux questions

Question 1 : Les objets qui ont été ajoutés manuellement via le portail du service cloud ou via l’API de service cloud, comme Exchange Online PowerShell, sont-ils comptabilisés dans le quota de mon entreprise en ligne ?

Réponse 1 : Oui.

Question 2 : Les objets supprimés sont-ils comptabilisés dans le quota de mon entreprise en ligne ?

Réponse 2 : Oui. Lorsqu’un client de service cloud supprime un objet d’une société en ligne, l’objet supprimé est placé dans un conteneur d’objets supprimés du service d’annuaire. L’objet reste dans le conteneur d’objets supprimés jusqu’à l’expiration de la durée de vie de la pierre tombstone. L’expiration est actuellement définie sur 30 jours.

Par exemple, envisagez le scénario suivant : Une entreprise en ligne évalue un service cloud à l’aide d’un environnement de non-production Active Directory local. Le service cloud organization a été créé avant le 5 octobre 2011 et la limite de synchronisation par défaut est de 10 000 objets. L’entreprise effectue une synchronisation en bloc de 8 000 objets de groupe et d’objets de contact à l’aide de l’outil Synchronisation d’annuaires. Plus tard, l’entreprise en ligne décide d’effectuer les opérations suivantes :

  1. Supprimez ces objets de groupe et ces objets contact de l’environnement Active Directory DS local hors production de l’entreprise.
  2. Ajoutez 8 000 objets utilisateur à son environnement Active Directory DS local hors production.
  3. Synchronisez les mises à jour avec son entreprise en ligne.

Les 8 000 objets de groupe et les objets contact sont déplacés vers le conteneur d’objets supprimés dans le service d’annuaire. Et ces objets continuent de consommer jusqu’à 25 pour cent du quota de l’entreprise en ligne jusqu’à ce qu’ils soient définitivement supprimés après la période de 30 jours tombstone. (Ce pourcentage est égal à 2 000 objets, ou 8 000 × 25 p. 100.) Par conséquent, après avoir synchronisé les 5 000 nouveaux objets utilisateur, l’entreprise en ligne consommera 10 000 objets de son quota Active Directory disponible, 2 000 à partir d’objets supprimés et 8 000 à partir des nouveaux objets utilisateur. Pendant la période tombstone de 30 jours (et cette période peut coïncider avec la période d’évaluation de l’entreprise en ligne), la société en ligne peut ne pas être en mesure d’ajouter des objets supplémentaires à l’aide de la synchronisation d’annuaires. Cette condition se produit parce que le quota de service d’annuaire de l’entreprise en ligne a été atteint.

Dans ce scénario, l’entreprise en ligne qui effectue l’évaluation du service cloud doit réduire le nombre d’objets dans son environnement de non-production Active Directory local DS pour terminer l’évaluation du produit. Toutefois, si l’entreprise en ligne ne peut pas réduire le nombre d’objets, elle doit demander une augmentation de son quota de services d’annuaire.

Question 3 : Le fait d’avoir plusieurs domaines vérifiés signifie-t-il que je peux avoir un quota supérieur à 300 000 objets ?

Réponse 3 : Non. Un quota d’annuaires de 300 000 objets vous est accordé si vous avez un ou plusieurs domaines vérifiés. Vous ne disposez pas d’un quota de 300 000 objets pour chaque domaine vérifié que vous inscrivez.

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